summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-sunffb
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-10-13 07:45:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-10-13 07:45:08 +0000
commit1742c4fbeed8c5d75f7b54b49c5a7607e6453f40 (patch)
tree5c1588bcc55dc0d528b29233e0611c59fb10d358 /x11-drivers/xf86-video-sunffb
parentc783d50e7fee5084aebe410ba68270885f073586 (diff)
downloadfreebsd-ports-1742c4fbeed8c5d75f7b54b49c5a7607e6453f40.zip
Xorg-server update to 1.17.2 with related driver updates and bumps.
Update fontproto to 2.1.3. Update libXfont to 1.5.1. Update xf86-input-keyboard 1.8.1. Update xf86-input-vmmouse to 13.1.0. Update xf86-input-void to 1.4.1. Update xf86-video-chips to 1.2.6. Update xf86-video-cirrus to 1.5.3. Update xf86-video-mach64 to 6.9.5. Update xf86-video-neomagic to 1.2.9. Update xf86-video-r128 to 6.10.0. Update xf86-video-s3virge to 1.10.7. Update xf86-video-savage to 2.3.8. Update xf86-video-siliconmotion to 1.7.8. Update xf86-video-sis to 0.10.8. Update xf86-video-trident to 1.3.7. Update xf86-video-vesa to 2.3.4. * All other xf86-* drivers where bump and/or patched to allow them to compile and work with the new xorg-server. * The ATI-ums driver is removed because the API it depends on was removed from the xorg-server. * Add patch to sunffb to make the lack of XAA non-fatal (not build/run tested due to lack of hardware). * Remove the extra patches in xorg-server for arm. The code seems to support it now natively. Please file a bug if this is not the case. * Update the xorg-server support in virtualbox-ose-additions for vboxmouse. [1] Submitted by: jkim@ [1] Obtained from: Graphics devel repo
Diffstat (limited to 'x11-drivers/xf86-video-sunffb')
-rw-r--r--x11-drivers/xf86-video-sunffb/Makefile2
-rw-r--r--x11-drivers/xf86-video-sunffb/files/patch-src_ffb__driver.c33
2 files changed, 34 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-sunffb/Makefile b/x11-drivers/xf86-video-sunffb/Makefile
index ba1abd9bef32..96849c60cde6 100644
--- a/x11-drivers/xf86-video-sunffb/Makefile
+++ b/x11-drivers/xf86-video-sunffb/Makefile
@@ -2,7 +2,7 @@
PORTNAME= xf86-video-sunffb
PORTVERSION= 1.2.2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-drivers/xf86-video-sunffb/files/patch-src_ffb__driver.c b/x11-drivers/xf86-video-sunffb/files/patch-src_ffb__driver.c
new file mode 100644
index 000000000000..a11731b49e7b
--- /dev/null
+++ b/x11-drivers/xf86-video-sunffb/files/patch-src_ffb__driver.c
@@ -0,0 +1,33 @@
+From 181b60190c1f81fc9b9b5deb07d536b78f2536ab Mon Sep 17 00:00:00 2001
+From: Matthieu Herrb <matthieu.herrb@laas.fr>
+Date: Mon, 10 Jun 2013 21:51:08 +0200
+Subject: Unbreak when XAA is not present.
+
+Turn accel off if loading XAA fails.
+
+Signed-off-by: Matthieu Herrb <matthieu.herrb@laas.fr>
+Reviewed-by: Alex Deucher <alexander.deucher@amd.com>
+
+diff --git a/src/ffb_driver.c b/src/ffb_driver.c
+index af13484..7f17d64 100644
+--- src/ffb_driver.c
++++ src/ffb_driver.c
+@@ -413,9 +413,12 @@ FFBPreInit(ScrnInfoPtr pScrn, int flags)
+ return FALSE;
+ }
+
+- if (xf86LoadSubModule(pScrn, "xaa") == NULL) {
+- FFBFreeRec(pScrn);
+- return FALSE;
++ if (!pFfb->NoAccel) {
++ if (xf86LoadSubModule(pScrn, "xaa") == NULL) {
++ xf86DrvMsg(pScrn->scrnIndex, X_INFO,
++ "Loading XAA failed, acceleration disabled\n");
++ pFfb->NoAccel = TRUE;
++ }
+ }
+
+ if (pFfb->HWCursor && xf86LoadSubModule(pScrn, "ramdac") == NULL) {
+--
+cgit v0.10.2
+