summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorOleg Sidorkin <osidorkin@gmail.com>2023-01-16 22:34:14 +0300
committerJason E. Hale <jhale@FreeBSD.org>2023-01-17 15:58:31 -0500
commitbbbaebcf3bce14d6e320a086345351ed0718305c (patch)
treed88b3b6068d47d39ec4999729a97db82a276260c /www
parent628f67be988ad294aaf70d314ada076fdf97c5d6 (diff)
downloadfreebsd-ports-bbbaebcf3bce14d6e320a086345351ed0718305c.zip
www/py-woob: Do not install tests files
PR: 269003
Diffstat (limited to 'www')
-rw-r--r--www/py-woob/Makefile1
-rw-r--r--www/py-woob/files/patch-setup.py14
2 files changed, 15 insertions, 0 deletions
diff --git a/www/py-woob/Makefile b/www/py-woob/Makefile
index fb75e9c84f70..7c6a45e1d264 100644
--- a/www/py-woob/Makefile
+++ b/www/py-woob/Makefile
@@ -1,5 +1,6 @@
PORTNAME= woob
PORTVERSION= 3.1
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/www/py-woob/files/patch-setup.py b/www/py-woob/files/patch-setup.py
new file mode 100644
index 000000000000..aed574c2686f
--- /dev/null
+++ b/www/py-woob/files/patch-setup.py
@@ -0,0 +1,14 @@
+Exclude test files from being installed.
+PR: 269003
+
+--- setup.py.orig 2022-12-20 10:22:03 UTC
++++ setup.py
+@@ -29,7 +29,7 @@ from setuptools import find_packages, setup
+
+
+ def install_woob():
+- packages = set(find_packages(exclude=['modules', 'modules.*']))
++ packages = set(find_packages(exclude=['modules', 'modules.*', 'tests', 'tests.*']))
+
+ data_files = [
+ ('share/man/man1', glob.glob('man/*')),