summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-08-11 11:29:11 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-08-11 11:29:11 +0000
commit9c3712cf15ddf3f82d608e2bd9a4a3a13a0ab584 (patch)
tree024ad0e42dbc9b5ef6af689be804f25e90f07aa1 /www
parent6e3c247bb735995a1a945bd80910f223fb2da038 (diff)
downloadfreebsd-ports-9c3712cf15ddf3f82d608e2bd9a4a3a13a0ab584.zip
Update RUN_DEPENDS
- While I'm here, sort *_DEPENDS - Bump PORTREVISION for dependency change
Diffstat (limited to 'www')
-rw-r--r--www/py-falcon/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/www/py-falcon/Makefile b/www/py-falcon/Makefile
index 83efebecd2d6..2ea67cd5c7d8 100644
--- a/www/py-falcon/Makefile
+++ b/www/py-falcon/Makefile
@@ -3,6 +3,7 @@
PORTNAME= falcon
PORTVERSION= 1.4.1
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,13 +14,13 @@ COMMENT= High-performance Python framework for building cloud APIs
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}jsonschema>=0:devel/py-jsonschema@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-mimeparse>=1.5.2:devel/py-python-mimeparse@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.4.0:devel/py-six@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsonschema>=0:devel/py-jsonschema@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}msgpack>=0:devel/py-msgpack@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.4.0:devel/py-six@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}mimeparse>=1.5.2:devel/py-mimeparse@${PY_FLAVOR}
USES= python
USE_PYTHON= distutils autoplist cython