summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-01-25 15:10:21 -0600
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-01-25 15:13:29 -0600
commit8ea662c5f71699443c369821319d211bd91f5901 (patch)
tree850e13001360a27bd99973ab246f85c1ba006f6b /www
parent58310a68d2e7085a56113b5025317c86b7946222 (diff)
downloadfreebsd-ports-8ea662c5f71699443c369821319d211bd91f5901.zip
www/mod_php8*: Fix build
USES=apache must be called before bsd.pre.port.mk however this was overridden using an include clause. During my previous commit on refactoring apache.mk these include blocks were deleted which causes failure to the build of these port as USES=apache in preport.mk is never called. This commit changes and refactors the code. Fixes: 40843b1 Mk/Uses/apache.mk: Refactor after removal of older versions
Diffstat (limited to 'www')
-rw-r--r--www/mod_php80/Makefile3
-rw-r--r--www/mod_php81/Makefile3
-rw-r--r--www/mod_php82/Makefile3
3 files changed, 9 insertions, 0 deletions
diff --git a/www/mod_php80/Makefile b/www/mod_php80/Makefile
index 8ca5af8db5f6..6b5651434f38 100644
--- a/www/mod_php80/Makefile
+++ b/www/mod_php80/Makefile
@@ -13,4 +13,7 @@ OPTIONS_EXCLUDE= CGI CLI EMBED FPM
AP2FILTER_DESC= Use Apache 2.x filter interface (experimental)
+AP2FILTER_CONFIGURE_ON=--with-apxs2filter=${APXS}
+AP2FILTER_CONFIGURE_OFF=--with-apxs2=${APXS}
+
.include "${MASTERDIR}/Makefile"
diff --git a/www/mod_php81/Makefile b/www/mod_php81/Makefile
index b5c0cfd961a2..82d7543e42b3 100644
--- a/www/mod_php81/Makefile
+++ b/www/mod_php81/Makefile
@@ -13,4 +13,7 @@ OPTIONS_EXCLUDE= CGI CLI EMBED FPM
AP2FILTER_DESC= Use Apache 2.x filter interface (experimental)
+AP2FILTER_CONFIGURE_ON=--with-apxs2filter=${APXS}
+AP2FILTER_CONFIGURE_OFF=--with-apxs2=${APXS}
+
.include "${MASTERDIR}/Makefile"
diff --git a/www/mod_php82/Makefile b/www/mod_php82/Makefile
index a32582b36c28..723a425618b4 100644
--- a/www/mod_php82/Makefile
+++ b/www/mod_php82/Makefile
@@ -12,4 +12,7 @@ OPTIONS_EXCLUDE= CGI CLI EMBED FPM
AP2FILTER_DESC= Use Apache 2.x filter interface (experimental)
+AP2FILTER_CONFIGURE_ON=--with-apxs2filter=${APXS}
+AP2FILTER_CONFIGURE_OFF=--with-apxs2=${APXS}
+
.include "${MASTERDIR}/Makefile"