summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2021-02-14 15:45:10 +0000
committerMikael Urankar <mikael@FreeBSD.org>2021-02-14 15:45:10 +0000
commit6bebfaa8a06c3187bca906011d999c16309d24ae (patch)
tree5e766fb7e5ba1a7986d2a87601f3d0b9735dc0c8 /www
parent81c9086f8e0100f8cd0dd6642ca8425958baaf12 (diff)
downloadfreebsd-ports-6bebfaa8a06c3187bca906011d999c16309d24ae.zip
lang/rust: Update to 1.50.0
- Use bundled libgit/libssh, the versions in ports are too old - Update lang/rust-nightly to 2021-02-12 - Update devel/racer to 2.1.41 - Import upstream patch to fix build issue for Firefox and related ports (https://bugzilla.mozilla.org/show_bug.cgi?id=1684261) Changes: https://github.com/rust-lang/rust/releases/tag/1.50.0 Tested by: mikael, pkubaj Differential Revision: https://reviews.freebsd.org/D28616
Diffstat (limited to 'www')
-rw-r--r--www/castor/Makefile2
-rw-r--r--www/deno/Makefile1
-rw-r--r--www/ffsend/Makefile2
-rw-r--r--www/firefox-esr/Makefile1
-rw-r--r--www/firefox-esr/files/patch-bug168426173
-rw-r--r--www/firefox/Makefile1
-rw-r--r--www/firefox/files/patch-bug168426178
-rw-r--r--www/geckodriver/Makefile2
-rw-r--r--www/jwt-cli/Makefile2
-rw-r--r--www/lychee/Makefile2
-rw-r--r--www/miniserve/Makefile2
-rw-r--r--www/monolith/Makefile2
-rw-r--r--www/newsboat/Makefile2
-rw-r--r--www/websocat/Makefile2
-rw-r--r--www/zola/Makefile1
15 files changed, 164 insertions, 9 deletions
diff --git a/www/castor/Makefile b/www/castor/Makefile
index 5250ed90746f..c4da04435597 100644
--- a/www/castor/Makefile
+++ b/www/castor/Makefile
@@ -2,7 +2,7 @@
PORTNAME= castor
DISTVERSION= 0.8.16
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= https://git.sr.ht/~julienxx/${PORTNAME}/archive/${DISTVERSIONFULL}${EXTRACT_SUFX}?dummy=/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
diff --git a/www/deno/Makefile b/www/deno/Makefile
index 046d10105467..7b49f115dd26 100644
--- a/www/deno/Makefile
+++ b/www/deno/Makefile
@@ -3,6 +3,7 @@
PORTNAME= deno
DISTVERSIONPREFIX= v
DISTVERSION= 1.7.2
+PORTREVISION= 1
CATEGORIES= www
MAINTAINER= mikael@FreeBSD.org
diff --git a/www/ffsend/Makefile b/www/ffsend/Makefile
index ed2fcabfa750..2b7f5c09b87e 100644
--- a/www/ffsend/Makefile
+++ b/www/ffsend/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ffsend
DISTVERSIONPREFIX= v
DISTVERSION= 0.2.68
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MAINTAINER= 0mp@FreeBSD.org
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 585ddf8caf00..42fd07dab0dd 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -3,6 +3,7 @@
PORTNAME= firefox
DISTVERSION= 78.7.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox-esr/files/patch-bug1684261 b/www/firefox-esr/files/patch-bug1684261
new file mode 100644
index 000000000000..ed6c517319d7
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug1684261
@@ -0,0 +1,73 @@
+
+# HG changeset patch
+# User Emilio Cobos Álvarez <emilio@crisal.io>
+# Date 1609006565 0
+# Node ID 0e8f444683cb9c4079d3b2250f32f986043ea582
+# Parent 55097a5cf353f1b2a2228820bdf26bb69a1372a0
+Bug 1684261 - Fix build with rust nightly. r=jrmuizel, a=RyanVM
+
+Fixes errors like:
+
+ dependency (nix) specification is ambiguous. Only one of `branch`, `tag` or `rev` is allowed.
+
+I've left the most specific dependency, but for wgpu the rev is not
+right, so I've kept the branch which effectively preserves behavior.
+
+Differential Revision: https://phabricator.services.mozilla.com/D100485
+
+diff --git a/.cargo/config.in b/.cargo/config.in
+--- .cargo/config.in
++++ .cargo/config.in
+@@ -1,16 +1,16 @@
+ # This file contains vendoring instructions for cargo.
+ # It was generated by `mach vendor rust`.
+ # Please do not edit.
+
+ [source."https://github.com/shravanrn/nix/"]
+-branch = "r0.13.1"
+ git = "https://github.com/shravanrn/nix/"
+ replace-with = "vendored-sources"
++rev = "4af6c367603869a30fddb5ffb0aba2b9477ba92e"
+
+ [source."https://github.com/mozilla/rkv"]
+ git = "https://github.com/mozilla/rkv"
+ replace-with = "vendored-sources"
+ rev = "e3c3388e6632cf55e08d773b32e58b1cab9b2731"
+
+ [source."https://github.com/mozilla/neqo"]
+ git = "https://github.com/mozilla/neqo"
+diff --git a/Cargo.lock b/Cargo.lock
+--- Cargo.lock
++++ Cargo.lock
+@@ -3195,17 +3195,17 @@ source = "registry+https://github.com/ru
+ checksum = "0cdc457076c78ab54d5e0d6fa7c47981757f1e34dc39ff92787f217dede586c4"
+ dependencies = [
+ "unreachable",
+ ]
+
+ [[package]]
+ name = "nix"
+ version = "0.13.1"
+-source = "git+https://github.com/shravanrn/nix/?branch=r0.13.1#4af6c367603869a30fddb5ffb0aba2b9477ba92e"
++source = "git+https://github.com/shravanrn/nix/?rev=4af6c367603869a30fddb5ffb0aba2b9477ba92e#4af6c367603869a30fddb5ffb0aba2b9477ba92e"
+ dependencies = [
+ "bitflags",
+ "cc",
+ "cfg-if",
+ "libc",
+ "void",
+ ]
+
+--- Cargo.toml
++++ Cargo.toml
+@@ -68,8 +68,8 @@ panic = "abort"
+ libudev-sys = { path = "dom/webauthn/libudev-sys" }
+ packed_simd = { git = "https://github.com/hsivonen/packed_simd", rev="0917fe780032a6bbb23d71be545f9c1834128d75" }
+ rlbox_lucet_sandbox = { git = "https://github.com/PLSysSec/rlbox_lucet_sandbox/", rev="d510da5999a744c563b0acd18056069d1698273f" }
+-nix = { git = "https://github.com/shravanrn/nix/", branch = "r0.13.1", rev="4af6c367603869a30fddb5ffb0aba2b9477ba92e" }
+-spirv_cross = { git = "https://github.com/kvark/spirv_cross", branch = "wgpu3", rev = "20191ad2f370afd6d247edcb9ff9da32d3bedb9c" }
++nix = { git = "https://github.com/shravanrn/nix/", rev="4af6c367603869a30fddb5ffb0aba2b9477ba92e" }
++spirv_cross = { git = "https://github.com/kvark/spirv_cross", branch = "wgpu3" }
+ # failure's backtrace feature might break our builds, see bug 1608157.
+ failure = { git = "https://github.com/badboy/failure", rev = "64af847bc5fdcb6d2438bec8a6030812a80519a5" }
+ failure_derive = { git = "https://github.com/badboy/failure", rev = "64af847bc5fdcb6d2438bec8a6030812a80519a5" }
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index a1b826274c4e..5d7443d3d915 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -3,6 +3,7 @@
PORTNAME= firefox
DISTVERSION= 85.0.2
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
diff --git a/www/firefox/files/patch-bug1684261 b/www/firefox/files/patch-bug1684261
new file mode 100644
index 000000000000..954c0df10cf9
--- /dev/null
+++ b/www/firefox/files/patch-bug1684261
@@ -0,0 +1,78 @@
+
+# HG changeset patch
+# User Emilio Cobos Álvarez <emilio@crisal.io>
+# Date 1609006565 0
+# Node ID 48f46a7eada94d51d8bd508b5122642865ddef3d
+# Parent f1bc2b9069ab9b6a246c10501782c0af267c77d7
+Bug 1684261 - Fix build with rust nightly. r=jrmuizel
+
+Fixes errors like:
+
+ dependency (nix) specification is ambiguous. Only one of `branch`, `tag` or `rev` is allowed.
+
+I've left the most specific dependency, but for wgpu the rev is not
+right, so I've kept the branch which effectively preserves behavior.
+
+Differential Revision: https://phabricator.services.mozilla.com/D100485
+
+--- .cargo/config.in.orig 2021-02-12 15:09:04.023268000 +0100
++++ .cargo/config.in 2021-02-12 15:09:20.428857000 +0100
+@@ -3,9 +3,9 @@
+ # Please do not edit.
+
+ [source."https://github.com/shravanrn/nix/"]
+-branch = "r0.13.1"
+ git = "https://github.com/shravanrn/nix/"
+ replace-with = "vendored-sources"
++rev = "4af6c367603869a30fddb5ffb0aba2b9477ba92e"
+
+ [source."https://github.com/mozilla/neqo"]
+ git = "https://github.com/mozilla/neqo"
+
+diff --git a/Cargo.lock b/Cargo.lock
+--- Cargo.lock
++++ Cargo.lock
+@@ -3447,17 +3447,17 @@ source = "registry+https://github.com/ru
+ checksum = "0cdc457076c78ab54d5e0d6fa7c47981757f1e34dc39ff92787f217dede586c4"
+ dependencies = [
+ "unreachable",
+ ]
+
+ [[package]]
+ name = "nix"
+ version = "0.13.1"
+-source = "git+https://github.com/shravanrn/nix/?branch=r0.13.1#4af6c367603869a30fddb5ffb0aba2b9477ba92e"
++source = "git+https://github.com/shravanrn/nix/?rev=4af6c367603869a30fddb5ffb0aba2b9477ba92e#4af6c367603869a30fddb5ffb0aba2b9477ba92e"
+ dependencies = [
+ "bitflags",
+ "cc",
+ "cfg-if 0.1.10",
+ "libc",
+ "void",
+ ]
+
+diff --git a/Cargo.toml b/Cargo.toml
+--- Cargo.toml
++++ Cargo.toml
+@@ -70,18 +70,18 @@ opt-level = 1
+ [profile.release.build-override]
+ opt-level = 1
+
+ [patch.crates-io]
+ chardetng = { git = "https://github.com/hsivonen/chardetng", rev="7d5e0608d3e012bdfea3bd199111e3546607dd31" }
+ libudev-sys = { path = "dom/webauthn/libudev-sys" }
+ packed_simd = { git = "https://github.com/hsivonen/packed_simd", rev="0917fe780032a6bbb23d71be545f9c1834128d75" }
+ rlbox_lucet_sandbox = { git = "https://github.com/PLSysSec/rlbox_lucet_sandbox/", rev="f3cace4fb8b53db0849c62af4fa62bade5a620f7" }
+-nix = { git = "https://github.com/shravanrn/nix/", branch = "r0.13.1", rev="4af6c367603869a30fddb5ffb0aba2b9477ba92e" }
+-spirv_cross = { git = "https://github.com/kvark/spirv_cross", branch = "wgpu4", rev = "e9eff10f964957e7a001c5f712effe17ce09aa99" }
++nix = { git = "https://github.com/shravanrn/nix/", rev="4af6c367603869a30fddb5ffb0aba2b9477ba92e" }
++spirv_cross = { git = "https://github.com/kvark/spirv_cross", branch = "wgpu4" }
+ # failure's backtrace feature might break our builds, see bug 1608157.
+ failure = { git = "https://github.com/badboy/failure", rev = "64af847bc5fdcb6d2438bec8a6030812a80519a5" }
+ failure_derive = { git = "https://github.com/badboy/failure", rev = "64af847bc5fdcb6d2438bec8a6030812a80519a5" }
+
+ [patch.crates-io.cranelift-codegen]
+ git = "https://github.com/mozilla-spidermonkey/wasmtime"
+ rev = "3334d92350da40b90d2529c147db3ea44918b558"
+
+
diff --git a/www/geckodriver/Makefile b/www/geckodriver/Makefile
index 1b28538bbcd4..6cc1a13fb129 100644
--- a/www/geckodriver/Makefile
+++ b/www/geckodriver/Makefile
@@ -2,7 +2,7 @@
PORTNAME= geckodriver
DISTVERSION= 0.26.0
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= www
MASTER_SITES= https://hg.mozilla.org/mozilla-central/archive/${DISTNAME}.zip/testing/geckodriver/?dummy=/
DISTNAME= e9783a644016aa9b317887076618425586730d73
diff --git a/www/jwt-cli/Makefile b/www/jwt-cli/Makefile
index 88f96916e828..4499d25f8e00 100644
--- a/www/jwt-cli/Makefile
+++ b/www/jwt-cli/Makefile
@@ -3,7 +3,7 @@
PORTNAME= jwt-cli
PORTVERSION= 3.2.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MAINTAINER= osa@FreeBSD.org
diff --git a/www/lychee/Makefile b/www/lychee/Makefile
index 635ba442de59..907cbedf0a2f 100644
--- a/www/lychee/Makefile
+++ b/www/lychee/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lychee
DISTVERSIONPREFIX= v
DISTVERSION= 0.5.0
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= www net
MAINTAINER= pizzamig@FreeBSD.org
diff --git a/www/miniserve/Makefile b/www/miniserve/Makefile
index a7f4ef6e86f9..9da8261d075e 100644
--- a/www/miniserve/Makefile
+++ b/www/miniserve/Makefile
@@ -3,7 +3,7 @@
PORTNAME= miniserve
DISTVERSIONPREFIX= v
DISTVERSION= 0.10.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MAINTAINER= mikael@FreeBSD.org
diff --git a/www/monolith/Makefile b/www/monolith/Makefile
index 8aa534163678..881eff24df88 100644
--- a/www/monolith/Makefile
+++ b/www/monolith/Makefile
@@ -3,7 +3,7 @@
PORTNAME= monolith
DISTVERSIONPREFIX= v
DISTVERSION= 2.4.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MAINTAINER= lcook@FreeBSD.org
diff --git a/www/newsboat/Makefile b/www/newsboat/Makefile
index f3d5ee987c90..515d119bb1e2 100644
--- a/www/newsboat/Makefile
+++ b/www/newsboat/Makefile
@@ -3,7 +3,7 @@
PORTNAME= newsboat
PORTVERSION= 2.21
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= https://newsboat.org/releases/${PORTVERSION}/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
diff --git a/www/websocat/Makefile b/www/websocat/Makefile
index cceef6679a1d..a0d46fdb24d8 100644
--- a/www/websocat/Makefile
+++ b/www/websocat/Makefile
@@ -4,7 +4,7 @@
PORTNAME= websocat
DISTVERSIONPREFIX= v
DISTVERSION= 1.6.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= www
MAINTAINER= osa@FreeBSD.org
diff --git a/www/zola/Makefile b/www/zola/Makefile
index 2bf044001c96..4bb343227512 100644
--- a/www/zola/Makefile
+++ b/www/zola/Makefile
@@ -3,6 +3,7 @@
PORTNAME= zola
DISTVERSIONPREFIX= v
DISTVERSION= 0.13.0
+PORTREVISION= 1
CATEGORIES= www
MAINTAINER= mikael@FreeBSD.org