summaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2020-11-24 12:48:53 +0000
committerMikael Urankar <mikael@FreeBSD.org>2020-11-24 12:48:53 +0000
commit4e449e031e7d6145599f30b8f3ecb850eae7c550 (patch)
treec4dd2d942c9a8dd0a293afb06a81d625bddd8b18 /www
parent4cc3f0f036dbb76b2b8057c528b3c6a41454ccfc (diff)
downloadfreebsd-ports-4e449e031e7d6145599f30b8f3ecb850eae7c550.zip
lang/rust: Update to 1.48.0
Changes: https://github.com/rust-lang/rust/releases/tag/1.48.0 Reviewed by: jbeich Tested by: bdragon, jbeich, mikael Differential Revision: https://reviews.freebsd.org/D27293
Diffstat (limited to 'www')
-rw-r--r--www/castor/Makefile1
-rw-r--r--www/cliqz/Makefile2
-rw-r--r--www/cliqz/files/patch-bug1667736106
-rw-r--r--www/deno/Makefile1
-rw-r--r--www/ffsend/Makefile1
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox-esr/files/patch-bug1667736112
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/firefox/files/patch-bug1667736112
-rw-r--r--www/geckodriver/Makefile2
-rw-r--r--www/jwt-cli/Makefile2
-rw-r--r--www/miniserve/Makefile1
-rw-r--r--www/monolith/Makefile2
-rw-r--r--www/newsboat/Makefile2
-rw-r--r--www/websocat/Makefile2
-rw-r--r--www/zola/Makefile2
16 files changed, 343 insertions, 9 deletions
diff --git a/www/castor/Makefile b/www/castor/Makefile
index 9dc90c73f874..2670bd44ec60 100644
--- a/www/castor/Makefile
+++ b/www/castor/Makefile
@@ -2,6 +2,7 @@
PORTNAME= castor
DISTVERSION= 0.8.16
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= https://git.sr.ht/~julienxx/${PORTNAME}/archive/${DISTVERSIONFULL}${EXTRACT_SUFX}?dummy=/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
diff --git a/www/cliqz/Makefile b/www/cliqz/Makefile
index 0c6df905d371..817d72ec5df2 100644
--- a/www/cliqz/Makefile
+++ b/www/cliqz/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cliqz
DISTVERSION= 1.38.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= https://s3.amazonaws.com/cdn.cliqz.com/browser-f/APT/:amazon \
http://repository.cliqz.com/dist/${CLIQZ_CHANNEL}/${DISTVERSION}/${CLIQZ_LAST_BUILD_ID}/:cliqz
diff --git a/www/cliqz/files/patch-bug1667736 b/www/cliqz/files/patch-bug1667736
new file mode 100644
index 000000000000..c620b437c0ad
--- /dev/null
+++ b/www/cliqz/files/patch-bug1667736
@@ -0,0 +1,106 @@
+2 errors:
+error[E0432]: unresolved import `crate::arch::x86_64::_mm_movemask_pi8`
+https://github.com/rust-lang/packed_simd/pull/290
+
+unresolved import `crate::arch::x86_64::__m64`
+https://github.com/rust-lang/packed_simd/pull/292/commits/57d96e45916066fa9b5cdf2bc695e190207e78af
+
+From 950903a66950eaff745b0a029f2051d305df1c22 Mon Sep 17 00:00:00 2001
+From: Justus K <justus.k@protonmail.com>
+Date: Tue, 22 Sep 2020 15:36:03 +0200
+Subject: [PATCH] Remove `x86_m8x8_sse_impl` macro
+
+---
+ src/codegen/reductions/mask/x86/sse.rs | 32 --------------------------
+ 1 file changed, 32 deletions(-)
+
+diff --git a/src/codegen/reductions/mask/x86/sse.rs b/src/codegen/reductions/mask/x86/sse.rs
+index 7482f943..eb1ef7fa 100644
+--- mozilla-release/third_party/rust/packed_simd/src/codegen/reductions/mask/x86/sse.rs
++++ mozilla-release/third_party/rust/packed_simd/src/codegen/reductions/mask/x86/sse.rs
+@@ -34,35 +34,3 @@ macro_rules! x86_m32x4_sse_impl {
+ }
+ };
+ }
+-
+-macro_rules! x86_m8x8_sse_impl {
+- ($id:ident) => {
+- impl All for $id {
+- #[inline]
+- #[target_feature(enable = "sse")]
+- unsafe fn all(self) -> bool {
+- #[cfg(target_arch = "x86")]
+- use crate::arch::x86::_mm_movemask_pi8;
+- #[cfg(target_arch = "x86_64")]
+- use crate::arch::x86_64::_mm_movemask_pi8;
+- // _mm_movemask_pi8(a) creates an 8bit mask containing the most
+- // significant bit of each byte of `a`. If all bits are set,
+- // then all 8 lanes of the mask are true.
+- _mm_movemask_pi8(crate::mem::transmute(self))
+- == u8::max_value() as i32
+- }
+- }
+- impl Any for $id {
+- #[inline]
+- #[target_feature(enable = "sse")]
+- unsafe fn any(self) -> bool {
+- #[cfg(target_arch = "x86")]
+- use crate::arch::x86::_mm_movemask_pi8;
+- #[cfg(target_arch = "x86_64")]
+- use crate::arch::x86_64::_mm_movemask_pi8;
+-
+- _mm_movemask_pi8(crate::mem::transmute(self)) != 0
+- }
+- }
+- };
+-}
+--- mozilla-release/third_party/rust/packed_simd/src/lib.rs.orig 2019-02-05 21:18:53.000000000 +0100
++++ mozilla-release/third_party/rust/packed_simd/src/lib.rs 2020-11-18 15:06:43.736722000 +0100
+@@ -210,7 +210,6 @@
+ core_intrinsics,
+ stmt_expr_attributes,
+ align_offset,
+- mmx_target_feature,
+ crate_visibility_modifier,
+ custom_inner_attributes
+ )]
+diff --git a/src/codegen/reductions/mask/x86.rs b/src/codegen/reductions/mask/x86.rs
+index 2ae4ed81..bcfb1a6e 100644
+--- mozilla-release/third_party/rust/packed_simd/src/codegen/reductions/mask/x86.rs
++++ mozilla-release/third_party/rust/packed_simd/src/codegen/reductions/mask/x86.rs
+@@ -19,13 +19,7 @@ mod avx2;
+ /// x86 64-bit m8x8 implementation
+ macro_rules! x86_m8x8_impl {
+ ($id:ident) => {
+- cfg_if! {
+- if #[cfg(all(target_arch = "x86_64", target_feature = "sse"))] {
+- x86_m8x8_sse_impl!($id);
+- } else {
+- fallback_impl!($id);
+- }
+- }
++ fallback_impl!($id);
+ };
+ }
+
+From 57d96e45916066fa9b5cdf2bc695e190207e78af Mon Sep 17 00:00:00 2001
+From: Jubilee Young <workingjubilee@gmail.com>
+Date: Wed, 23 Sep 2020 12:23:29 -0700
+Subject: [PATCH] Remove __m64 type
+
+---
+ src/api/into_bits/arch_specific.rs | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/api/into_bits/arch_specific.rs b/src/api/into_bits/arch_specific.rs
+index 6cc2fa37..7b560107 100644
+--- mozilla-release/third_party/rust/packed_simd/src/api/into_bits/arch_specific.rs
++++ mozilla-release/third_party/rust/packed_simd/src/api/into_bits/arch_specific.rs
+@@ -84,7 +84,6 @@ macro_rules! impl_arch {
+ // FIXME: 64-bit single element types
+ // FIXME: arm/aarch float16x4_t missing
+ impl_arch!(
+- [x86["x86"]: __m64], [x86_64["x86_64"]: __m64],
+ [arm["arm"]: int8x8_t, uint8x8_t, poly8x8_t, int16x4_t, uint16x4_t,
+ poly16x4_t, int32x2_t, uint32x2_t, float32x2_t, int64x1_t,
+ uint64x1_t],
diff --git a/www/deno/Makefile b/www/deno/Makefile
index 529b8b99831e..8c7b83853b4e 100644
--- a/www/deno/Makefile
+++ b/www/deno/Makefile
@@ -3,6 +3,7 @@
PORTNAME= deno
DISTVERSIONPREFIX= v
DISTVERSION= 1.5.3
+PORTREVISION= 1
CATEGORIES= www
MAINTAINER= mikael@FreeBSD.org
diff --git a/www/ffsend/Makefile b/www/ffsend/Makefile
index 0381347c7f7a..0af2cfaf6d2a 100644
--- a/www/ffsend/Makefile
+++ b/www/ffsend/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ffsend
DISTVERSIONPREFIX= v
DISTVERSION= 0.2.68
+PORTREVISION= 1
CATEGORIES= www
MAINTAINER= 0mp@FreeBSD.org
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index f381b56ca616..84d5f1dfe139 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -3,7 +3,7 @@
PORTNAME= firefox
DISTVERSION= 78.5.0
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox-esr/files/patch-bug1667736 b/www/firefox-esr/files/patch-bug1667736
new file mode 100644
index 000000000000..07a68b781926
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug1667736
@@ -0,0 +1,112 @@
+2 errors:
+error[E0432]: unresolved import `crate::arch::x86_64::_mm_movemask_pi8`
+https://github.com/rust-lang/packed_simd/pull/290
+
+unresolved import `crate::arch::x86_64::__m64`
+https://github.com/rust-lang/packed_simd/pull/292/commits/57d96e45916066fa9b5cdf2bc695e190207e78af
+
+
+
+From 950903a66950eaff745b0a029f2051d305df1c22 Mon Sep 17 00:00:00 2001
+From: Justus K <justus.k@protonmail.com>
+Date: Tue, 22 Sep 2020 15:36:03 +0200
+Subject: [PATCH] Remove `x86_m8x8_sse_impl` macro
+
+---
+ src/codegen/reductions/mask/x86/sse.rs | 32 --------------------------
+ 1 file changed, 32 deletions(-)
+
+diff --git a/src/codegen/reductions/mask/x86/sse.rs b/src/codegen/reductions/mask/x86/sse.rs
+index 7482f943..eb1ef7fa 100644
+--- third_party/rust/packed_simd/src/codegen/reductions/mask/x86/sse.rs
++++ third_party/rust/packed_simd/src/codegen/reductions/mask/x86/sse.rs
+@@ -34,35 +34,3 @@ macro_rules! x86_m32x4_sse_impl {
+ }
+ };
+ }
+-
+-macro_rules! x86_m8x8_sse_impl {
+- ($id:ident) => {
+- impl All for $id {
+- #[inline]
+- #[target_feature(enable = "sse")]
+- unsafe fn all(self) -> bool {
+- #[cfg(target_arch = "x86")]
+- use crate::arch::x86::_mm_movemask_pi8;
+- #[cfg(target_arch = "x86_64")]
+- use crate::arch::x86_64::_mm_movemask_pi8;
+- // _mm_movemask_pi8(a) creates an 8bit mask containing the most
+- // significant bit of each byte of `a`. If all bits are set,
+- // then all 8 lanes of the mask are true.
+- _mm_movemask_pi8(crate::mem::transmute(self))
+- == u8::max_value() as i32
+- }
+- }
+- impl Any for $id {
+- #[inline]
+- #[target_feature(enable = "sse")]
+- unsafe fn any(self) -> bool {
+- #[cfg(target_arch = "x86")]
+- use crate::arch::x86::_mm_movemask_pi8;
+- #[cfg(target_arch = "x86_64")]
+- use crate::arch::x86_64::_mm_movemask_pi8;
+-
+- _mm_movemask_pi8(crate::mem::transmute(self)) != 0
+- }
+- }
+- };
+-}
+
+diff --git a/src/codegen/reductions/mask/x86.rs b/src/codegen/reductions/mask/x86.rs
+index 2ae4ed81..bcfb1a6e 100644
+--- third_party/rust/packed_simd/src/codegen/reductions/mask/x86.rs
++++ third_party/rust/packed_simd/src/codegen/reductions/mask/x86.rs
+@@ -19,13 +19,7 @@ mod avx2;
+ /// x86 64-bit m8x8 implementation
+ macro_rules! x86_m8x8_impl {
+ ($id:ident) => {
+- cfg_if! {
+- if #[cfg(all(target_arch = "x86_64", target_feature = "sse"))] {
+- x86_m8x8_sse_impl!($id);
+- } else {
+- fallback_impl!($id);
+- }
+- }
++ fallback_impl!($id);
+ };
+ }
+
+--- third_party/rust/packed_simd/src/lib.rs.orig 2019-02-05 21:18:53.000000000 +0100
++++ third_party/rust/packed_simd/src/lib.rs 2020-11-18 15:06:43.736722000 +0100
+@@ -210,7 +210,6 @@
+ core_intrinsics,
+ stmt_expr_attributes,
+ align_offset,
+- mmx_target_feature,
+ crate_visibility_modifier,
+ custom_inner_attributes
+ )]
+
+
+
+From 57d96e45916066fa9b5cdf2bc695e190207e78af Mon Sep 17 00:00:00 2001
+From: Jubilee Young <workingjubilee@gmail.com>
+Date: Wed, 23 Sep 2020 12:23:29 -0700
+Subject: [PATCH] Remove __m64 type
+
+---
+ src/api/into_bits/arch_specific.rs | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/api/into_bits/arch_specific.rs b/src/api/into_bits/arch_specific.rs
+index 6cc2fa37..7b560107 100644
+--- third_party/rust/packed_simd/src/api/into_bits/arch_specific.rs
++++ third_party/rust/packed_simd/src/api/into_bits/arch_specific.rs
+@@ -84,7 +84,6 @@ macro_rules! impl_arch {
+ // FIXME: 64-bit single element types
+ // FIXME: arm/aarch float16x4_t missing
+ impl_arch!(
+- [x86["x86"]: __m64], [x86_64["x86_64"]: __m64],
+ [arm["arm"]: int8x8_t, uint8x8_t, poly8x8_t, int16x4_t, uint16x4_t,
+ poly16x4_t, int32x2_t, uint32x2_t, float32x2_t, int64x1_t,
+ uint64x1_t],
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index d1f06b075b2f..34a4f6304002 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -3,7 +3,7 @@
PORTNAME= firefox
DISTVERSION= 83.0
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
diff --git a/www/firefox/files/patch-bug1667736 b/www/firefox/files/patch-bug1667736
new file mode 100644
index 000000000000..07a68b781926
--- /dev/null
+++ b/www/firefox/files/patch-bug1667736
@@ -0,0 +1,112 @@
+2 errors:
+error[E0432]: unresolved import `crate::arch::x86_64::_mm_movemask_pi8`
+https://github.com/rust-lang/packed_simd/pull/290
+
+unresolved import `crate::arch::x86_64::__m64`
+https://github.com/rust-lang/packed_simd/pull/292/commits/57d96e45916066fa9b5cdf2bc695e190207e78af
+
+
+
+From 950903a66950eaff745b0a029f2051d305df1c22 Mon Sep 17 00:00:00 2001
+From: Justus K <justus.k@protonmail.com>
+Date: Tue, 22 Sep 2020 15:36:03 +0200
+Subject: [PATCH] Remove `x86_m8x8_sse_impl` macro
+
+---
+ src/codegen/reductions/mask/x86/sse.rs | 32 --------------------------
+ 1 file changed, 32 deletions(-)
+
+diff --git a/src/codegen/reductions/mask/x86/sse.rs b/src/codegen/reductions/mask/x86/sse.rs
+index 7482f943..eb1ef7fa 100644
+--- third_party/rust/packed_simd/src/codegen/reductions/mask/x86/sse.rs
++++ third_party/rust/packed_simd/src/codegen/reductions/mask/x86/sse.rs
+@@ -34,35 +34,3 @@ macro_rules! x86_m32x4_sse_impl {
+ }
+ };
+ }
+-
+-macro_rules! x86_m8x8_sse_impl {
+- ($id:ident) => {
+- impl All for $id {
+- #[inline]
+- #[target_feature(enable = "sse")]
+- unsafe fn all(self) -> bool {
+- #[cfg(target_arch = "x86")]
+- use crate::arch::x86::_mm_movemask_pi8;
+- #[cfg(target_arch = "x86_64")]
+- use crate::arch::x86_64::_mm_movemask_pi8;
+- // _mm_movemask_pi8(a) creates an 8bit mask containing the most
+- // significant bit of each byte of `a`. If all bits are set,
+- // then all 8 lanes of the mask are true.
+- _mm_movemask_pi8(crate::mem::transmute(self))
+- == u8::max_value() as i32
+- }
+- }
+- impl Any for $id {
+- #[inline]
+- #[target_feature(enable = "sse")]
+- unsafe fn any(self) -> bool {
+- #[cfg(target_arch = "x86")]
+- use crate::arch::x86::_mm_movemask_pi8;
+- #[cfg(target_arch = "x86_64")]
+- use crate::arch::x86_64::_mm_movemask_pi8;
+-
+- _mm_movemask_pi8(crate::mem::transmute(self)) != 0
+- }
+- }
+- };
+-}
+
+diff --git a/src/codegen/reductions/mask/x86.rs b/src/codegen/reductions/mask/x86.rs
+index 2ae4ed81..bcfb1a6e 100644
+--- third_party/rust/packed_simd/src/codegen/reductions/mask/x86.rs
++++ third_party/rust/packed_simd/src/codegen/reductions/mask/x86.rs
+@@ -19,13 +19,7 @@ mod avx2;
+ /// x86 64-bit m8x8 implementation
+ macro_rules! x86_m8x8_impl {
+ ($id:ident) => {
+- cfg_if! {
+- if #[cfg(all(target_arch = "x86_64", target_feature = "sse"))] {
+- x86_m8x8_sse_impl!($id);
+- } else {
+- fallback_impl!($id);
+- }
+- }
++ fallback_impl!($id);
+ };
+ }
+
+--- third_party/rust/packed_simd/src/lib.rs.orig 2019-02-05 21:18:53.000000000 +0100
++++ third_party/rust/packed_simd/src/lib.rs 2020-11-18 15:06:43.736722000 +0100
+@@ -210,7 +210,6 @@
+ core_intrinsics,
+ stmt_expr_attributes,
+ align_offset,
+- mmx_target_feature,
+ crate_visibility_modifier,
+ custom_inner_attributes
+ )]
+
+
+
+From 57d96e45916066fa9b5cdf2bc695e190207e78af Mon Sep 17 00:00:00 2001
+From: Jubilee Young <workingjubilee@gmail.com>
+Date: Wed, 23 Sep 2020 12:23:29 -0700
+Subject: [PATCH] Remove __m64 type
+
+---
+ src/api/into_bits/arch_specific.rs | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/api/into_bits/arch_specific.rs b/src/api/into_bits/arch_specific.rs
+index 6cc2fa37..7b560107 100644
+--- third_party/rust/packed_simd/src/api/into_bits/arch_specific.rs
++++ third_party/rust/packed_simd/src/api/into_bits/arch_specific.rs
+@@ -84,7 +84,6 @@ macro_rules! impl_arch {
+ // FIXME: 64-bit single element types
+ // FIXME: arm/aarch float16x4_t missing
+ impl_arch!(
+- [x86["x86"]: __m64], [x86_64["x86_64"]: __m64],
+ [arm["arm"]: int8x8_t, uint8x8_t, poly8x8_t, int16x4_t, uint16x4_t,
+ poly16x4_t, int32x2_t, uint32x2_t, float32x2_t, int64x1_t,
+ uint64x1_t],
diff --git a/www/geckodriver/Makefile b/www/geckodriver/Makefile
index 44bc8f10aae0..7c17b35d0119 100644
--- a/www/geckodriver/Makefile
+++ b/www/geckodriver/Makefile
@@ -2,7 +2,7 @@
PORTNAME= geckodriver
DISTVERSION= 0.26.0
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= www
MASTER_SITES= https://hg.mozilla.org/mozilla-central/archive/${DISTNAME}.zip/testing/geckodriver/?dummy=/
DISTNAME= e9783a644016aa9b317887076618425586730d73
diff --git a/www/jwt-cli/Makefile b/www/jwt-cli/Makefile
index f45d08c66369..1bb82d1b3fee 100644
--- a/www/jwt-cli/Makefile
+++ b/www/jwt-cli/Makefile
@@ -3,7 +3,7 @@
PORTNAME= jwt-cli
PORTVERSION= 3.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MAINTAINER= osa@FreeBSD.org
diff --git a/www/miniserve/Makefile b/www/miniserve/Makefile
index 206d9d723754..5ec7d7a1b551 100644
--- a/www/miniserve/Makefile
+++ b/www/miniserve/Makefile
@@ -3,6 +3,7 @@
PORTNAME= miniserve
DISTVERSIONPREFIX= v
DISTVERSION= 0.10.3
+PORTREVISION= 1
CATEGORIES= www
MAINTAINER= mikael@FreeBSD.org
diff --git a/www/monolith/Makefile b/www/monolith/Makefile
index 5e1fc16e713e..7662053d9a6e 100644
--- a/www/monolith/Makefile
+++ b/www/monolith/Makefile
@@ -3,7 +3,7 @@
PORTNAME= monolith
DISTVERSIONPREFIX= v
DISTVERSION= 2.3.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MAINTAINER= vulcan@wired.sh
diff --git a/www/newsboat/Makefile b/www/newsboat/Makefile
index 03e358eb9c35..7c1dcecf4ff5 100644
--- a/www/newsboat/Makefile
+++ b/www/newsboat/Makefile
@@ -3,7 +3,7 @@
PORTNAME= newsboat
PORTVERSION= 2.21
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= https://newsboat.org/releases/${PORTVERSION}/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
diff --git a/www/websocat/Makefile b/www/websocat/Makefile
index ae24a5bd8f71..dc77d5082302 100644
--- a/www/websocat/Makefile
+++ b/www/websocat/Makefile
@@ -4,7 +4,7 @@
PORTNAME= websocat
DISTVERSIONPREFIX= v
DISTVERSION= 1.6.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MAINTAINER= osa@FreeBSD.org
diff --git a/www/zola/Makefile b/www/zola/Makefile
index d3d150c19ffb..a34133e94ffa 100644
--- a/www/zola/Makefile
+++ b/www/zola/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zola
DISTVERSIONPREFIX= v
DISTVERSION= 0.12.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MAINTAINER= mikael@FreeBSD.org