summaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-12-29 14:29:18 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-12-29 14:29:18 +0000
commitf1749e4ab1795953ad8807b40fcb138ad425a53f (patch)
treec09c83633fb69d859c6df4ea95f7abf5603e7106 /textproc
parent704bb9e9971d46ab880545798ed4514ef748f80a (diff)
downloadfreebsd-ports-f1749e4ab1795953ad8807b40fcb138ad425a53f.zip
- Remove bogus (in presence of USE_GITHUB) USES=tar*
- While here, minor cosmetic and license fixes Approved by: portmgr blanket
Diffstat (limited to 'textproc')
-rw-r--r--textproc/codespell/Makefile13
-rw-r--r--textproc/pecl-ctemplate/Makefile5
-rw-r--r--textproc/php-mecab/Makefile4
-rw-r--r--textproc/templates_parser/Makefile7
4 files changed, 16 insertions, 13 deletions
diff --git a/textproc/codespell/Makefile b/textproc/codespell/Makefile
index 65e85271b3d1..dae471052df6 100644
--- a/textproc/codespell/Makefile
+++ b/textproc/codespell/Makefile
@@ -8,8 +8,9 @@ MAINTAINER= gjb@FreeBSD.org
COMMENT= Source code spelling checker
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
-USES= python:3 tar:xz
+USES= python:3
USE_GITHUB= yes
GH_ACCOUNT= lucasdemarchi
@@ -18,25 +19,29 @@ GH_TAGNAME= 4cb7fe3
OPTIONS_DEFINE= DOCS EXAMPLES
PLIST_FILES= bin/codespell
-PORTDOCS= COPYING NEWS TODO
+PORTDOCS= NEWS TODO
PORTEXAMPLES= *
+NO_ARCH= yes
+
SUB_FILES+= pkg-message
do-build:
- ${REINPLACE_CMD} 's|#!/usr/bin/env python3|#!${PYTHON_CMD}|' \
+ @${REINPLACE_CMD} 's|#!/usr/bin/env python3|#!${PYTHON_CMD}|' \
${WRKSRC}/codespell.py
- ${REINPLACE_CMD} "s|^default_dictionary = .*|default_dictionary = '${EXAMPLESDIR}/data/dictionary.txt'|" \
+ @${REINPLACE_CMD} "s|^default_dictionary = .*|default_dictionary = '${EXAMPLESDIR}/data/dictionary.txt'|" \
${WRKSRC}/codespell.py
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/codespell.py ${STAGEDIR}${PREFIX}/bin/codespell
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
. for i in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
. endfor
+do-install-EXAMPLES-on:
.for i in data example
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/${i}
${INSTALL_DATA} ${WRKSRC}/${i}/* ${STAGEDIR}${EXAMPLESDIR}/${i}
diff --git a/textproc/pecl-ctemplate/Makefile b/textproc/pecl-ctemplate/Makefile
index 41da5b03b677..aa55cb911930 100644
--- a/textproc/pecl-ctemplate/Makefile
+++ b/textproc/pecl-ctemplate/Makefile
@@ -13,15 +13,12 @@ COMMENT= PECL extension for ctemplate library
LIB_DEPENDS= libctemplate.so:textproc/google-ctemplate
-USES= php:ext tar:xz
+USES= php:ext localbase:ldflags
USE_GITHUB= yes
GH_ACCOUNT= vanillahsu
GH_PROJECT= pecl-ctemplate
IGNORE_WITH_PHP= 70
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib ${EXTRA_LIBS}
-
CONFIGURE_ARGS= --with-cTemplate=${LOCALBASE}
.include <bsd.port.mk>
diff --git a/textproc/php-mecab/Makefile b/textproc/php-mecab/Makefile
index 5a3e4ae1164a..66af20db3e3c 100644
--- a/textproc/php-mecab/Makefile
+++ b/textproc/php-mecab/Makefile
@@ -18,8 +18,8 @@ USE_GITHUB= yes
GH_ACCOUNT= rsky
WRKSRC_SUBDIR= mecab
-CONFIGURE_ARGS+= --with-mecab=${LOCALBASE}/bin/mecab-config
-USES= php:ext tar:tgz
+CONFIGURE_ARGS= --with-mecab=${LOCALBASE}/bin/mecab-config
+USES= php:ext
PHP_MODNAME= mecab
.include <bsd.port.mk>
diff --git a/textproc/templates_parser/Makefile b/textproc/templates_parser/Makefile
index 7eee4a491faf..0fe334e55c45 100644
--- a/textproc/templates_parser/Makefile
+++ b/textproc/templates_parser/Makefile
@@ -8,13 +8,14 @@ CATEGORIES= textproc
MAINTAINER= marino@FreeBSD.org
COMMENT= Web page template engine module for the Ada Web Server
-LICENSE= GPLv3
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING3
BUILD_DEPENDS= gprbuild:devel/gprbuild \
xmlada>=4.4:textproc/xmlada
RUN_DEPENDS= xmlada>=4.4:textproc/xmlada
-USES= ada:run gmake tar:bzip2
+USES= ada:run gmake
USE_GITHUB= yes
GH_ACCOUNT= AdaCore
GH_PROJECT= templates-parser
@@ -22,7 +23,7 @@ GH_TAGNAME= 1d62939
DESTINC= ${STAGEDIR}${PREFIX}/include/templates_parser
PLIST_SUB= LIBVER=${PORTVERSION:R}
-MAKE_ARGS+= PROCESSORS=${MAKE_JOBS_NUMBER} \
+MAKE_ARGS= PROCESSORS=${MAKE_JOBS_NUMBER} \
ENABLE_SHARED=true \
HOST=${CONFIGURE_TARGET} \
TARGET=${CONFIGURE_TARGET} \