summaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-06-28 14:00:45 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-06-28 14:00:45 +0000
commitdca255c3cec21c0c66003eb626763c7fdc2cb59a (patch)
treee6eac391e081f99a997be8b0d8e036d22d5fe2a9 /textproc
parent4973e5b396de5fdc84495adcdcb1f40854c8ebcd (diff)
downloadfreebsd-ports-dca255c3cec21c0c66003eb626763c7fdc2cb59a.zip
Convert USE_PHP*=yes into USES=php*
PR: 210529 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D6936
Diffstat (limited to 'textproc')
-rw-r--r--textproc/libmrss-php/Makefile4
-rw-r--r--textproc/mysqlviz/Makefile4
-rw-r--r--textproc/pecl-cld/Makefile6
-rw-r--r--textproc/pecl-ctemplate/Makefile4
-rw-r--r--textproc/pecl-doublemetaphone/Makefile5
-rw-r--r--textproc/pecl-enchant/Makefile5
-rw-r--r--textproc/pecl-html_parse/Makefile5
-rw-r--r--textproc/pecl-stem/Makefile4
-rw-r--r--textproc/pecl-syck/Makefile6
-rw-r--r--textproc/pecl-wbxml/Makefile4
-rw-r--r--textproc/pecl-xdiff/Makefile4
-rw-r--r--textproc/pecl-xslcache/Makefile6
-rw-r--r--textproc/pecl-yaml/Makefile5
-rw-r--r--textproc/php-mecab/Makefile12
-rw-r--r--textproc/redland-bindings/Makefile2
-rw-r--r--textproc/zorba/Makefile2
16 files changed, 21 insertions, 57 deletions
diff --git a/textproc/libmrss-php/Makefile b/textproc/libmrss-php/Makefile
index 2bf364d80c8d..e7c6ccf7ca0f 100644
--- a/textproc/libmrss-php/Makefile
+++ b/textproc/libmrss-php/Makefile
@@ -20,11 +20,9 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USES= libtool
+USES= libtool php:ext
USE_LDCONFIG= yes
-USE_PHP= yes
-USE_PHPEXT= yes
PHP_MODNAME= mrss
IGNORE_WITH_PHP= 70
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/phpmrss
diff --git a/textproc/mysqlviz/Makefile b/textproc/mysqlviz/Makefile
index 89154a708dcd..b8fd949ce124 100644
--- a/textproc/mysqlviz/Makefile
+++ b/textproc/mysqlviz/Makefile
@@ -12,9 +12,7 @@ COMMENT= MySQL and SQLite Database Visualisation Tool
LICENSE= GPLv3
NO_BUILD= yes
-USES= tar:bzip2
-USE_PHP= yes
-WANT_PHP_CLI= yes
+USES= php:cli tar:bzip2
PLIST_FILES= bin/${PORTNAME}
diff --git a/textproc/pecl-cld/Makefile b/textproc/pecl-cld/Makefile
index 505689ed9c78..833b54b904c0 100644
--- a/textproc/pecl-cld/Makefile
+++ b/textproc/pecl-cld/Makefile
@@ -16,11 +16,7 @@ LICENSE= BSD2CLAUSE
LIB_DEPENDS= libcld.so:devel/cld
CONFIGURE_ARGS= --enable-cld --with-libcld-dir=${LOCALBASE}/lib
-USES= tar:tgz
-USE_PHP= yes
-USE_PHP_BUILD= yes
-USE_PHPIZE= yes
-USE_PHPEXT= yes
+USES= php:ext tar:tgz
IGNORE_WITH_PHP= 70
post-install:
diff --git a/textproc/pecl-ctemplate/Makefile b/textproc/pecl-ctemplate/Makefile
index d783285c1b36..fce74cb398e9 100644
--- a/textproc/pecl-ctemplate/Makefile
+++ b/textproc/pecl-ctemplate/Makefile
@@ -13,9 +13,7 @@ COMMENT= PECL extension for ctemplate library
LIB_DEPENDS= libctemplate.so:textproc/google-ctemplate
-USES= tar:xz
-USE_PHP= yes
-USE_PHPEXT= yes
+USES= php:ext tar:xz
USE_GITHUB= yes
GH_ACCOUNT= vanillahsu
GH_PROJECT= pecl-ctemplate
diff --git a/textproc/pecl-doublemetaphone/Makefile b/textproc/pecl-doublemetaphone/Makefile
index 7206f8fbf120..02b8e90aecaf 100644
--- a/textproc/pecl-doublemetaphone/Makefile
+++ b/textproc/pecl-doublemetaphone/Makefile
@@ -14,10 +14,7 @@ COMMENT= PECL extension which implements the Double Metaphone algorithm
LICENSE= PHP301
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= tar:tgz
-USE_PHP= yes
-USE_PHP_BUILD= yes
-USE_PHPEXT= yes
+USES= php:ext tar:tgz
IGNORE_WITH_PHP= 70
CONFIGURE_ARGS= --enable-doublemetaphone
diff --git a/textproc/pecl-enchant/Makefile b/textproc/pecl-enchant/Makefile
index b0dd2fc71106..206b2db3a48c 100644
--- a/textproc/pecl-enchant/Makefile
+++ b/textproc/pecl-enchant/Makefile
@@ -15,10 +15,7 @@ LICENSE= PHP30
LIB_DEPENDS= libenchant.so:textproc/enchant
-USES= tar:tgz
-USE_PHP= yes
-USE_PHPEXT= yes
-PHP_MODNAME= ${PORTNAME}
+USES= php:ext tar:tgz
IGNORE_WITH_PHP= 56 70
CONFIGURE_ARGS+= --with-enchant=${LOCALBASE}
diff --git a/textproc/pecl-html_parse/Makefile b/textproc/pecl-html_parse/Makefile
index 54f3e287819b..d90723bfed75 100644
--- a/textproc/pecl-html_parse/Makefile
+++ b/textproc/pecl-html_parse/Makefile
@@ -16,10 +16,7 @@ LICENSE= PHP30
BUILD_DEPENDS= ${LOCALBASE}/lib/libekhtml.a:textproc/ekhtml
RUN_DEPENDS= ${LOCALBASE}/lib/libekhtml.a:textproc/ekhtml
-USES= tar:tgz
-USE_PHP= yes
-USE_PHP_BUILD= yes
-USE_PHPEXT= yes
+USES= php:ext tar:tgz
IGNORE_WITH_PHP= 56 70
CONFIGURE_ARGS= --enable-html_parse
diff --git a/textproc/pecl-stem/Makefile b/textproc/pecl-stem/Makefile
index a39bba79c03c..9927f55a7de2 100644
--- a/textproc/pecl-stem/Makefile
+++ b/textproc/pecl-stem/Makefile
@@ -14,9 +14,7 @@ COMMENT= PECL extension which provides word stemming
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= tar:tgz
-USE_PHP= yes
-USE_PHPEXT= yes
+USES= php:ext tar:tgz
IGNORE_WITH_PHP= 70
post-configure:
diff --git a/textproc/pecl-syck/Makefile b/textproc/pecl-syck/Makefile
index e76506b6b09e..53b715f634c5 100644
--- a/textproc/pecl-syck/Makefile
+++ b/textproc/pecl-syck/Makefile
@@ -18,10 +18,8 @@ BROKEN_powerpc64= Does not build
BUILD_DEPENDS= ${LOCALBASE}/lib/libsyck.a:textproc/syck
-USES= tar:tgz
-USE_PHP= spl hash
-USE_PHP_BUILD= yes
-USE_PHPEXT= yes
+USES= php:ext tar:tgz
+USE_PHP= spl:build hash:build
IGNORE_WITH_PHP= 70
CONFIGURE_ARGS= --enable-syck
diff --git a/textproc/pecl-wbxml/Makefile b/textproc/pecl-wbxml/Makefile
index 3509541e14ea..d91c736f5fa1 100644
--- a/textproc/pecl-wbxml/Makefile
+++ b/textproc/pecl-wbxml/Makefile
@@ -14,12 +14,10 @@ COMMENT= PECL extension that provides WBXML conversion capabilities
LIB_DEPENDS= libwbxml2.so:textproc/wbxml2
-USES=tar:tgz
+USES= php:ext tar:tgz
CONFIGURE_ARGS= --with-wbxml=${LOCALBASE} \
--with-libexpat-dir=${LOCALBASE}
-USE_PHP= yes
-USE_PHPEXT= yes
IGNORE_WITH_PHP= 70
post-patch:
diff --git a/textproc/pecl-xdiff/Makefile b/textproc/pecl-xdiff/Makefile
index 83eb1017a606..800bcf6b0039 100644
--- a/textproc/pecl-xdiff/Makefile
+++ b/textproc/pecl-xdiff/Makefile
@@ -15,9 +15,7 @@ LICENSE= PHP301
LIB_DEPENDS= libxdiff.so:textproc/libxdiff
-USES= tar:tgz
-USE_PHP= yes
-USE_PHPEXT= yes
+USES= php:ext tar:tgz
IGNORE_WITH_PHP= 70
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/textproc/pecl-xslcache/Makefile b/textproc/pecl-xslcache/Makefile
index 82e2c363cdd4..450565f027f3 100644
--- a/textproc/pecl-xslcache/Makefile
+++ b/textproc/pecl-xslcache/Makefile
@@ -13,10 +13,8 @@ COMMENT= Caches the parsed XSL stylesheet between sessions
LICENSE= PHP301
-USES= tar:tgz
-USE_PHP= dom xml xsl
-USE_PHP_BUILD= yes
-USE_PHPEXT= yes
+USES= php:ext tar:tgz
+USE_PHP= dom:build xml:build xsl:build
IGNORE_WITH_PHP= 70
.include <bsd.port.mk>
diff --git a/textproc/pecl-yaml/Makefile b/textproc/pecl-yaml/Makefile
index c9a4589a21c1..0e7195615c5d 100644
--- a/textproc/pecl-yaml/Makefile
+++ b/textproc/pecl-yaml/Makefile
@@ -16,10 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libyaml.so:textproc/libyaml
-USES= tar:tgz
-USE_PHP= yes
-USE_PHP_BUILD= yes
-USE_PHPEXT= yes
+USES= php:ext tar:tgz
IGNORE_WITH_PHP= 70
.include <bsd.port.mk>
diff --git a/textproc/php-mecab/Makefile b/textproc/php-mecab/Makefile
index 65bf0af64924..3abcd6c7dee2 100644
--- a/textproc/php-mecab/Makefile
+++ b/textproc/php-mecab/Makefile
@@ -1,11 +1,10 @@
# Created by: Gasol Wu <gasol.wu@gmail.com>
# $FreeBSD$
-PORTNAME= mecab
+PORTNAME= php-mecab
PORTVERSION= 0.6.0
DISTVERSIONPREFIX= v
CATEGORIES= textproc
-PKGNAMEPREFIX= php-
MAINTAINER= gasol.wu@gmail.com
COMMENT= PHP bindings of the MeCab
@@ -16,13 +15,10 @@ LIB_DEPENDS= libmecab.so:japanese/mecab
USE_GITHUB= yes
GH_ACCOUNT= rsky
-GH_PROJECT= ${PKGNAMEPREFIX}${PORTNAME}
-WRKSRC= ${WRKDIR}/${GH_PROJECT}-${GH_TAGNAME_EXTRACT}/mecab
+WRKSRC_SUBDIR= mecab
CONFIGURE_ARGS+= --with-mecab=${LOCALBASE}/bin/mecab-config
-USE_PHP= yes
-USE_PHPIZE= yes
-USE_PHPEXT= yes
-USES= tar:tgz
+USES= php:ext tar:tgz
+PHP_MODNAME= mecab
.include <bsd.port.mk>
diff --git a/textproc/redland-bindings/Makefile b/textproc/redland-bindings/Makefile
index 14e7bdd03aaf..9c7ecab21df0 100644
--- a/textproc/redland-bindings/Makefile
+++ b/textproc/redland-bindings/Makefile
@@ -28,7 +28,7 @@ PERL_CONFIGURE_WITH= perl
PERL_USES= perl5
PERL_USE= PERL5=build,run
PHP_CONFIGURE_WITH= php
-PHP_USE= PHP=yes PHP_BUILD=yes
+PHP_USES= php:build
PYTHON_CONFIGURE_WITH= python
PYTHON_USES= python
RUBY_CONFIGURE_WITH= ruby
diff --git a/textproc/zorba/Makefile b/textproc/zorba/Makefile
index 4189de4dd558..b2462a592e9a 100644
--- a/textproc/zorba/Makefile
+++ b/textproc/zorba/Makefile
@@ -64,7 +64,7 @@ LOC_EXECINFO= ${LOCALBASE}/lib/libexecinfo.so
.if ${PORT_OPTIONS:MPHP}
USE_PHP= tokenizer
-USE_PHP_BUILD= yes
+USES+= php:build
WITH_SWIG= yes
CMAKE_ARGS+= -DPHP5_INSTALL_PATH:FILEPATH="lib/php/${PHP_EXT_DIR}"
PLIST_SUB+= PHP_EXTLIBDIR="lib/php/${PHP_EXT_DIR}"