summaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-04-14 15:49:36 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-04-14 15:49:36 +0000
commitbeb1c1fe19992999ef068d0dcb07c0d02f4aea71 (patch)
tree464f76d8fe2b9fd7499e26491ee739bfe0a5444e /textproc
parent496124accdd4d4221bb883770cd6fe27184bfc96 (diff)
downloadfreebsd-ports-beb1c1fe19992999ef068d0dcb07c0d02f4aea71.zip
USES=lua gained flavors.
Ports using USES=lua:module or lua:flavors will be flavored. A range of supported lua versions can be set using XX-YY (or XX-, or -YY, or simply ZZ) for ports not supporting all lua versions. USES=lua sets LUA_FLAVOR that needs to be used on all dependencies of flavored lua ports, in a similar way as PHP or Python flavors. PR: 245038 Submitted by: andrew tao11 riddles org uk Reviewed by: mat, kevans, russ haley gmail com Approved by: mat (portmgr) Differential Revision: https://reviews.freebsd.org/D16494
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/lua-lyaml/Makefile3
-rw-r--r--textproc/luaexpat-51/Makefile6
-rw-r--r--textproc/luaexpat/Makefile4
4 files changed, 4 insertions, 10 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 93a15bdf3359..ff1e86c26ecc 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -414,7 +414,6 @@
SUBDIR += ltxml
SUBDIR += lua-lyaml
SUBDIR += luaexpat
- SUBDIR += luaexpat-51
SUBDIR += lucene
SUBDIR += lucene4
SUBDIR += lucene5
diff --git a/textproc/lua-lyaml/Makefile b/textproc/lua-lyaml/Makefile
index 1d8b1bf9184f..4e657cba429c 100644
--- a/textproc/lua-lyaml/Makefile
+++ b/textproc/lua-lyaml/Makefile
@@ -4,6 +4,7 @@
PORTNAME= lyaml
PORTVERSION= 6.2.4
DISTVERSIONPREFIX=v
+PORTREVISION= 1
CATEGORIES= textproc
PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
@@ -15,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libyaml.so:textproc/libyaml
-USES= lua
+USES= lua:module
USE_GITHUB= yes
GH_ACCOUNT= gvvaughan
diff --git a/textproc/luaexpat-51/Makefile b/textproc/luaexpat-51/Makefile
deleted file mode 100644
index 229b4433ea3f..000000000000
--- a/textproc/luaexpat-51/Makefile
+++ /dev/null
@@ -1,6 +0,0 @@
-# $FreeBSD$
-
-MASTERDIR= ${.CURDIR}/../luaexpat
-USES= lua:51
-
-.include "${MASTERDIR}/Makefile"
diff --git a/textproc/luaexpat/Makefile b/textproc/luaexpat/Makefile
index ee4319ddb1d1..1e9797ef3c95 100644
--- a/textproc/luaexpat/Makefile
+++ b/textproc/luaexpat/Makefile
@@ -3,7 +3,7 @@
PORTNAME= luaexpat
PORTVERSION= 1.3.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= textproc
MASTER_SITES= http://matthewwild.co.uk/projects/luaexpat/ \
http://redundancy.redundancy.org/mirror/
@@ -16,7 +16,7 @@ LICENSE= MIT
LIB_DEPENDS= libexpat.so:textproc/expat2
-USES?= lua
+USES= lua:module
USES+= gmake
ALL_TARGET= lib