summaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-04-30 04:35:10 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-04-30 04:35:10 +0000
commitb5fc89bb284dee7e82a0c8124f79cc3af137ce87 (patch)
treec73f3892748518ee8dd2d7ac016d939814658a36 /textproc
parent510c2f235504914622c02f1f931f1830e9c4a5ef (diff)
downloadfreebsd-ports-b5fc89bb284dee7e82a0c8124f79cc3af137ce87.zip
Provide more descriptive error messages for ports failing on powerpc64.
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/kenlm/Makefile4
-rw-r--r--textproc/luceneplusplus/Makefile4
-rw-r--r--textproc/randlm/Makefile6
-rw-r--r--textproc/senna/Makefile7
-rw-r--r--textproc/topic/Makefile2
-rw-r--r--textproc/turboxsl/Makefile5
-rw-r--r--textproc/wiggle/Makefile4
7 files changed, 15 insertions, 17 deletions
diff --git a/textproc/kenlm/Makefile b/textproc/kenlm/Makefile
index af498b1bb673..11d386a7be53 100644
--- a/textproc/kenlm/Makefile
+++ b/textproc/kenlm/Makefile
@@ -20,8 +20,8 @@ USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
MAKE_ENV+= BOOST_BUILD_PATH=${WRKSRC}/jam-files/boost-build
-BROKEN_aarch64= Fails to compile: target architecture was not detected as supported by Double-Conversion
-BROKEN_powerpc64= Does not build
+BROKEN_aarch64= fails to compile: target architecture was not detected as supported by Double-Conversion
+BROKEN_powerpc64= fails to compile: error: in QuantTrieAll: difference{inf} between static_cast<double> and static_cast<double> exceeds 0.001%
do-build:
(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${LOCALBASE}/bin/bjam --toolset=${CHOSEN_COMPILER_TYPE} --with-boost=${LOCALBASE} ${_MAKE_JOBS})
diff --git a/textproc/luceneplusplus/Makefile b/textproc/luceneplusplus/Makefile
index bdaa113f5f6c..441e1c427015 100644
--- a/textproc/luceneplusplus/Makefile
+++ b/textproc/luceneplusplus/Makefile
@@ -12,10 +12,10 @@ COMMENT= C++ port of the Lucene library
LICENSE= LGPL3
LICENSE_FILE= ${WRKSRC}/LGPL.license
-BROKEN_powerpc64= Does not build
-
LIB_DEPENDS= libboost_system.so:devel/boost-libs
+BROKEN_powerpc64= Does not build: Warning: end of file not at end of a line; newline inserted
+
USE_GITHUB= yes
GH_ACCOUNT= luceneplusplus
GH_PROJECT= LucenePlusPlus
diff --git a/textproc/randlm/Makefile b/textproc/randlm/Makefile
index 03ff11b91088..e70d58ef4639 100644
--- a/textproc/randlm/Makefile
+++ b/textproc/randlm/Makefile
@@ -24,9 +24,9 @@ CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-BROKEN_aarch64= Fails to compile: invalid output constraint =a in asm
-BROKEN_armv6= Fails to compile: invalid output constraint =a in asm
-BROKEN_powerpc64= Does not build
+BROKEN_aarch64= fails to compile: invalid output constraint =a in asm
+BROKEN_armv6= fails to compile: invalid output constraint =a in asm
+BROKEN_powerpc64= fails to compile: error: 'itr' does not name a type
post-patch:
cd ${WRKSRC}/hadoop && ${MV} strings.cpp strings.cc && ${MV} strings.h s.h
diff --git a/textproc/senna/Makefile b/textproc/senna/Makefile
index 403b2a937551..46d73b51a08e 100644
--- a/textproc/senna/Makefile
+++ b/textproc/senna/Makefile
@@ -10,7 +10,8 @@ MASTER_SITES= SFJP/senna/46945
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Embeddable Fulltext Search Engine
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= does not build: relocation truncated to fit: R_PPC64_TOC16_DS
+BROKEN_sparc64= does not build
GNU_CONFIGURE= YES
USE_GCC= any
@@ -31,10 +32,6 @@ NFKC_DESC= use nfkc based utf8 normalization
.include <bsd.port.options.mk>
-.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ${ARCH}
-.endif
-
.if ${PORT_OPTIONS:MMECAB}
CONFIGURE_ARGS+= --with-mecab
LIB_DEPENDS+= libmecab.so:japanese/mecab
diff --git a/textproc/topic/Makefile b/textproc/topic/Makefile
index 83a8f9421c69..d4e59d5de81d 100644
--- a/textproc/topic/Makefile
+++ b/textproc/topic/Makefile
@@ -11,7 +11,7 @@ COMMENT= Topic markup parser
LICENSE= BSD2CLAUSE
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= Does not build: warning: comparison is always false due to limited range of data type
PLIST_FILES= bin/topic \
man/man1/topic.1.gz
diff --git a/textproc/turboxsl/Makefile b/textproc/turboxsl/Makefile
index 49ae1574afa1..fa3ce5bf71fd 100644
--- a/textproc/turboxsl/Makefile
+++ b/textproc/turboxsl/Makefile
@@ -14,8 +14,9 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libck.so:devel/concurrencykit \
libmemcached.so:databases/libmemcached
-BROKEN_powerpc64= Does not build
-ONLY_FOR_ARCHS= amd64 ia64 powerpc64 sparc64
+BROKEN_powerpc64= Does not build: ld: skipping incompatible /usr/local/lib/libck.so when searching for -lck
+ONLY_FOR_ARCHS= amd64 powerpc64 sparc64
+
USES= autoreconf libtool pathfix pkgconfig
USE_LDCONFIG= yes
USE_GITHUB= yes
diff --git a/textproc/wiggle/Makefile b/textproc/wiggle/Makefile
index d3d2c06398d0..14ba1b8119b3 100644
--- a/textproc/wiggle/Makefile
+++ b/textproc/wiggle/Makefile
@@ -12,10 +12,10 @@ COMMENT= Apply rejected patches and perform word-wise diffs
LICENSE= GPLv2
-BROKEN_powerpc64= Does not build
-
BUILD_DEPENDS= bash:shells/bash
+BROKEN_powerpc64= Does not build: error: nested functions are disabled, use -fnested-functions to re-enable
+
USES= compiler:nestedfct gmake ncurses
MAKE_ARGS+= CFLAGS="${CFLAGS} -I. -Wall -Wstrict-prototypes -Wextra -Wno-unused-parameter"