summaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 23:03:45 +0800
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 23:15:28 +0800
commit91a76eec79233629276165870d5c3bc76573532d (patch)
treeb18d5713ce88426b6954f577792b1629c4f51f2a /textproc
parent04e8d6e30a276fe64a23259406c6fe905f58044c (diff)
downloadfreebsd-ports-91a76eec79233629276165870d5c3bc76573532d.zip
textproc/py-sphinx-markdown-tables: Fix runtime with py-markdown 3.4+
- Update version requirement of RUN_DEPENDS: Make sure py-markdown 3.4+ is used - Bump PORTREVISION for package change Obtained from: https://github.com/ryanfox/sphinx-markdown-tables/commit/7d0bbd2c851efcc9ba25b1a851924333b923c023
Diffstat (limited to 'textproc')
-rw-r--r--textproc/py-sphinx-markdown-tables/Makefile3
-rw-r--r--textproc/py-sphinx-markdown-tables/files/patch-markdown13
2 files changed, 15 insertions, 1 deletions
diff --git a/textproc/py-sphinx-markdown-tables/Makefile b/textproc/py-sphinx-markdown-tables/Makefile
index 1585ba6e9bce..5f32eaf70f82 100644
--- a/textproc/py-sphinx-markdown-tables/Makefile
+++ b/textproc/py-sphinx-markdown-tables/Makefile
@@ -1,5 +1,6 @@
PORTNAME= sphinx-markdown-tables
PORTVERSION= 0.0.15
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= textproc python
MASTER_SITES= PYPI
@@ -12,7 +13,7 @@ WWW= https://github.com/ryanfox/sphinx-markdown-tables
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}markdown>=0:textproc/py-markdown@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}markdown>=3.4:textproc/py-markdown@${PY_FLAVOR}
USES= dos2unix python
USE_PYTHON= autoplist distutils concurrent
diff --git a/textproc/py-sphinx-markdown-tables/files/patch-markdown b/textproc/py-sphinx-markdown-tables/files/patch-markdown
new file mode 100644
index 000000000000..0e96c3cebafa
--- /dev/null
+++ b/textproc/py-sphinx-markdown-tables/files/patch-markdown
@@ -0,0 +1,13 @@
+Obtained from: https://github.com/ryanfox/sphinx-markdown-tables/commit/7d0bbd2c851efcc9ba25b1a851924333b923c023
+
+--- sphinx_markdown_tables/__init__.py.orig 2022-08-16 13:25:15 UTC
++++ sphinx_markdown_tables/__init__.py
+@@ -21,7 +21,7 @@ def process_tables(app, docname, source):
+ """
+ import markdown
+ md = markdown.Markdown(extensions=['markdown.extensions.tables'])
+- table_processor = markdown.extensions.tables.TableProcessor(md.parser)
++ table_processor = markdown.extensions.tables.TableProcessor(md.parser, {})
+
+ raw_markdown = source[0]
+ blocks = re.split(r'(\n{2,})', raw_markdown)