summaryrefslogtreecommitdiff
path: root/textproc/yodl
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2018-07-24 13:24:09 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2018-07-24 13:24:09 +0000
commit4e49856d1958ba652c012026682630876d435cdd (patch)
tree7debcef62878c7af116368d3ca0d949b09da2c63 /textproc/yodl
parentafa138a81e684316de1d5ddf84c7b7afedabe7ab (diff)
downloadfreebsd-ports-4e49856d1958ba652c012026682630876d435cdd.zip
textproc/yodl: Fix patches
Diffstat (limited to 'textproc/yodl')
-rw-r--r--textproc/yodl/Makefile1
-rw-r--r--textproc/yodl/files/patch-src_verbinsert_main.cc (renamed from textproc/yodl/files/patch-src_verbinsert_verbinsert.cc)16
2 files changed, 9 insertions, 8 deletions
diff --git a/textproc/yodl/Makefile b/textproc/yodl/Makefile
index 70d9e04cbda2..7e729ea89824 100644
--- a/textproc/yodl/Makefile
+++ b/textproc/yodl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= yodl
PORTVERSION= 3.10.00
+PORTREVISION= 1
CATEGORIES= textproc
MAINTAINER= bofh@FreeBSD.org
diff --git a/textproc/yodl/files/patch-src_verbinsert_verbinsert.cc b/textproc/yodl/files/patch-src_verbinsert_main.cc
index fb370ef327ed..04a5ac5d87e2 100644
--- a/textproc/yodl/files/patch-src_verbinsert_verbinsert.cc
+++ b/textproc/yodl/files/patch-src_verbinsert_main.cc
@@ -1,34 +1,34 @@
---- src/verbinsert/verbinsert.cc.orig 2014-09-23 19:16:48 UTC
-+++ src/verbinsert/verbinsert.cc
+--- src/verbinsert/main.cc.orig 2018-07-22 13:07:15 UTC
++++ src/verbinsert/main.cc
@@ -2,6 +2,7 @@
#include <fstream>
#include <iomanip>
#include <string>
+#include <cstdlib>
#include <unistd.h>
+ #include <regex>
- using namespace std;
-@@ -37,19 +38,19 @@ int main(int argc, char **argv)
+@@ -43,19 +44,19 @@ int main(int argc, char **argv)
continue;
case 's':
- indent.append(stoul(optarg), ' ');
-+ indent.append(strtoul(optarg, NULL, 0), ' ');
++ indent.append(stoul(optarg, NULL, 0), ' ');
continue;
case 't':
- indent.insert(0, stoul(optarg), '\t');
-+ indent.insert(0, strtoul(optarg, NULL, 0), '\t');
++ indent.insert(0, stoul(optarg, NULL, 0), '\t');
continue;
case 'S':
- vindent.append(stoul(optarg), ' ');
-+ vindent.append(strtoul(optarg, NULL, 0), ' ');
++ vindent.append(stoul(optarg, NULL, 0), ' ');
continue;
case 'T':
- vindent.insert(0, stoul(optarg), '\t');
-+ vindent.insert(0, strtoul(optarg, NULL, 0), '\t');
++ vindent.insert(0, stoul(optarg, NULL, 0), '\t');
continue;
case 'N':