summaryrefslogtreecommitdiff
path: root/textproc/xalan-c/Makefile.inc-sample-src
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-24 01:27:50 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-24 01:27:50 +0000
commit71f5eabfe124b8e288ffd0984c42f97efaa31fdb (patch)
treeb91d389c4c56f6ad65d019fc41db3225123ed9ad /textproc/xalan-c/Makefile.inc-sample-src
parent7eabc93e44142122e6e06dfc83a25ef1bbd50340 (diff)
downloadfreebsd-ports-71f5eabfe124b8e288ffd0984c42f97efaa31fdb.zip
New port: xalan-c v. 1.4 (XSLT engine and XPath implementation)
lan-C++ is an implementation of XSL Transformations (XSLT) and XML Path Language (XPath). It works hand in hand with the XML parser Xerces-C++ version 2. For mor information please visit the homepage: WWW: http://xml.apache.org/xalan-c/index.html PR: ports/44430 Submitted by: Christopher Kelly <christopher.kelly@uk.yahoo-inc.com>,Bjoern A. Zeeb <bzeeb+freebsdports@zabbadoz.net>
Diffstat (limited to 'textproc/xalan-c/Makefile.inc-sample-src')
-rw-r--r--textproc/xalan-c/Makefile.inc-sample-src112
1 files changed, 112 insertions, 0 deletions
diff --git a/textproc/xalan-c/Makefile.inc-sample-src b/textproc/xalan-c/Makefile.inc-sample-src
new file mode 100644
index 000000000000..226b311fd332
--- /dev/null
+++ b/textproc/xalan-c/Makefile.inc-sample-src
@@ -0,0 +1,112 @@
+ ${MKDIR} ${EXAMPLESDIR}/ApacheModuleXSLT
+ ${INSTALL_DATA} \
+ ${WRKSRC}/samples/ApacheModuleXSLT/mod_xslt.c \
+ ${EXAMPLESDIR}/ApacheModuleXSLT/
+ ${MKDIR} ${EXAMPLESDIR}/ApacheModuleXSLT/xslt
+ ${INSTALL_DATA} \
+ ${WRKSRC}/samples/ApacheModuleXSLT/xslt/apachemod.xml \
+ ${WRKSRC}/samples/ApacheModuleXSLT/xslt/apachemod.xsl \
+ ${WRKSRC}/samples/ApacheModuleXSLT/xslt/foo.xml \
+ ${WRKSRC}/samples/ApacheModuleXSLT/xslt/foo.xsl \
+ ${EXAMPLESDIR}/ApacheModuleXSLT/xslt/
+ ${MKDIR} ${EXAMPLESDIR}/CompileStylesheet
+ ${INSTALL_DATA} \
+ ${WRKSRC}/samples/CompileStylesheet/CompileStylesheet.cpp \
+ ${WRKSRC}/samples/CompileStylesheet/foo.xml \
+ ${WRKSRC}/samples/CompileStylesheet/foo.xsl \
+ ${WRKSRC}/samples/CompileStylesheet/foo1.xml \
+ ${WRKSRC}/samples/CompileStylesheet/foo10.xml \
+ ${WRKSRC}/samples/CompileStylesheet/foo2.xml \
+ ${WRKSRC}/samples/CompileStylesheet/foo3.xml \
+ ${WRKSRC}/samples/CompileStylesheet/foo4.xml \
+ ${WRKSRC}/samples/CompileStylesheet/foo5.xml \
+ ${WRKSRC}/samples/CompileStylesheet/foo6.xml \
+ ${WRKSRC}/samples/CompileStylesheet/foo7.xml \
+ ${WRKSRC}/samples/CompileStylesheet/foo8.xml \
+ ${WRKSRC}/samples/CompileStylesheet/foo9.xml \
+ ${EXAMPLESDIR}/CompileStylesheet/
+ ${MKDIR} ${EXAMPLESDIR}/DocumentBuilder
+ ${INSTALL_DATA} \
+ ${WRKSRC}/samples/DocumentBuilder/DocumentBuilder.cpp \
+ ${WRKSRC}/samples/DocumentBuilder/foo.xsl \
+ ${EXAMPLESDIR}/DocumentBuilder/
+ ${MKDIR} ${EXAMPLESDIR}/ExternalFunction
+ ${INSTALL_DATA} \
+ ${WRKSRC}/samples/ExternalFunction/ExternalFunction.cpp \
+ ${WRKSRC}/samples/ExternalFunction/foo.xml \
+ ${WRKSRC}/samples/ExternalFunction/foo.xsl \
+ ${EXAMPLESDIR}/ExternalFunction/
+ ${MKDIR} ${EXAMPLESDIR}/ParsedSourceWrappers
+ ${INSTALL_DATA} \
+ ${WRKSRC}/samples/ParsedSourceWrappers/ParsedSourceWrappers.cpp \
+ ${WRKSRC}/samples/ParsedSourceWrappers/foo.xml \
+ ${WRKSRC}/samples/ParsedSourceWrappers/foo.xsl \
+ ${EXAMPLESDIR}/ParsedSourceWrappers/
+ ${MKDIR} ${EXAMPLESDIR}/SerializeNodeSet
+ ${INSTALL_DATA} \
+ ${WRKSRC}/samples/SerializeNodeSet/SerializeNodeSet.cpp \
+ ${WRKSRC}/samples/SerializeNodeSet/foo.xml \
+ ${EXAMPLESDIR}/SerializeNodeSet/
+ ${MKDIR} ${EXAMPLESDIR}/SimpleTransform
+ ${INSTALL_DATA} \
+ ${WRKSRC}/samples/SimpleTransform/SimpleTransform.cpp \
+ ${WRKSRC}/samples/SimpleTransform/foo.xml \
+ ${WRKSRC}/samples/SimpleTransform/foo.xsl \
+ ${EXAMPLESDIR}/SimpleTransform/
+ ${MKDIR} ${EXAMPLESDIR}/SimpleXPathAPI
+ ${INSTALL_DATA} \
+ ${WRKSRC}/samples/SimpleXPathAPI/SimpleXPathAPI.cpp \
+ ${WRKSRC}/samples/SimpleXPathAPI/foo.xml \
+ ${EXAMPLESDIR}/SimpleXPathAPI/
+ ${MKDIR} ${EXAMPLESDIR}/SimpleXPathCAPI
+ ${INSTALL_DATA} \
+ ${WRKSRC}/samples/SimpleXPathCAPI/SimpleXPathCAPI.c \
+ ${WRKSRC}/samples/SimpleXPathCAPI/foo.xml \
+ ${EXAMPLESDIR}/SimpleXPathCAPI/
+ ${MKDIR} ${EXAMPLESDIR}/StreamTransform
+ ${INSTALL_DATA} \
+ ${WRKSRC}/samples/StreamTransform/StreamTransform.cpp \
+ ${EXAMPLESDIR}/StreamTransform/
+ ${MKDIR} ${EXAMPLESDIR}/ThreadSafe
+ ${INSTALL_DATA} \
+ ${WRKSRC}/samples/ThreadSafe/ThreadSafe.cpp \
+ ${WRKSRC}/samples/ThreadSafe/birds.xml \
+ ${WRKSRC}/samples/ThreadSafe/birds.xsl \
+ ${EXAMPLESDIR}/ThreadSafe/
+ ${MKDIR} ${EXAMPLESDIR}/TraceListen
+ ${INSTALL_DATA} \
+ ${WRKSRC}/samples/TraceListen/TraceListen.cpp \
+ ${WRKSRC}/samples/TraceListen/birds.xml \
+ ${WRKSRC}/samples/TraceListen/birds.xsl \
+ ${EXAMPLESDIR}/TraceListen/
+ ${MKDIR} ${EXAMPLESDIR}/TransformToXercesDOM
+ ${INSTALL_DATA} \
+ ${WRKSRC}/samples/TransformToXercesDOM/TransformToXercesDOM.cpp \
+ ${WRKSRC}/samples/TransformToXercesDOM/birds.xml \
+ ${WRKSRC}/samples/TransformToXercesDOM/birds.xsl \
+ ${EXAMPLESDIR}/TransformToXercesDOM/
+ ${MKDIR} ${EXAMPLESDIR}/UseStylesheetParam
+ ${INSTALL_DATA} \
+ ${WRKSRC}/samples/UseStylesheetParam/UseStylesheetParam.cpp \
+ ${WRKSRC}/samples/UseStylesheetParam/foo.xml \
+ ${WRKSRC}/samples/UseStylesheetParam/foo.xsl \
+ ${EXAMPLESDIR}/UseStylesheetParam/
+ ${MKDIR} ${EXAMPLESDIR}/XPathWrapper
+ ${INSTALL_DATA} \
+ ${WRKSRC}/samples/XPathWrapper/TestDriver.cpp \
+ ${WRKSRC}/samples/XPathWrapper/XPathWrapper.cpp \
+ ${WRKSRC}/samples/XPathWrapper/XPathWrapper.hpp \
+ ${WRKSRC}/samples/XPathWrapper/foo.xml \
+ ${EXAMPLESDIR}/XPathWrapper/
+ ${MKDIR} ${EXAMPLESDIR}/XalanTransform
+ ${INSTALL_DATA} \
+ ${WRKSRC}/samples/XalanTransform/XalanTransform.cpp \
+ ${WRKSRC}/samples/XalanTransform/foo.xml \
+ ${WRKSRC}/samples/XalanTransform/foo.xsl \
+ ${EXAMPLESDIR}/XalanTransform/
+ ${MKDIR} ${EXAMPLESDIR}/XalanTransformerCallback
+ ${INSTALL_DATA} \
+ ${WRKSRC}/samples/XalanTransformerCallback/XalanTransformerCallback.cpp \
+ ${WRKSRC}/samples/XalanTransformerCallback/foo.xml \
+ ${WRKSRC}/samples/XalanTransformerCallback/foo.xsl \
+ ${EXAMPLESDIR}/XalanTransformerCallback/