summaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2023-03-15 10:04:40 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2023-03-15 10:04:40 +0000
commit1c91b0de39b03b844be454d99a0202cf5f0e0e26 (patch)
tree3b9d46e18811201619ad4ebb8d87ec0da3a11bcd /sysutils
parentcc1d4272059b2e22c37cc669936ded51c5f289eb (diff)
downloadfreebsd-ports-1c91b0de39b03b844be454d99a0202cf5f0e0e26.zip
sysutils/containerd: Update to 1.7.0
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/containerd/Makefile3
-rw-r--r--sysutils/containerd/distinfo6
-rw-r--r--sysutils/containerd/files/patch-LinuxContainersOnFreeBSD155
3 files changed, 4 insertions, 160 deletions
diff --git a/sysutils/containerd/Makefile b/sysutils/containerd/Makefile
index d9c717abd41d..e67399544612 100644
--- a/sysutils/containerd/Makefile
+++ b/sysutils/containerd/Makefile
@@ -1,7 +1,6 @@
PORTNAME= containerd
DISTVERSIONPREFIX=v
-DISTVERSION= 1.6.19
-PORTREVISION= 1
+DISTVERSION= 1.7.0
CATEGORIES= sysutils
MAINTAINER= decke@FreeBSD.org
diff --git a/sysutils/containerd/distinfo b/sysutils/containerd/distinfo
index 7ad589cc69e7..74306e9f0abe 100644
--- a/sysutils/containerd/distinfo
+++ b/sysutils/containerd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1677748658
-SHA256 (containerd-containerd-v1.6.19_GH0.tar.gz) = 7a90dc72f44e230eb5228ebac23b37e91f7d26d175d563099a8e1c0592047a28
-SIZE (containerd-containerd-v1.6.19_GH0.tar.gz) = 8706434
+TIMESTAMP = 1678874063
+SHA256 (containerd-containerd-v1.7.0_GH0.tar.gz) = c80b1c7f04057108059fdec9c936fc1ec0dccafa45c00a1d54f14dceb6500552
+SIZE (containerd-containerd-v1.7.0_GH0.tar.gz) = 9648706
diff --git a/sysutils/containerd/files/patch-LinuxContainersOnFreeBSD b/sysutils/containerd/files/patch-LinuxContainersOnFreeBSD
deleted file mode 100644
index 876c8527e4c5..000000000000
--- a/sysutils/containerd/files/patch-LinuxContainersOnFreeBSD
+++ /dev/null
@@ -1,155 +0,0 @@
-Linux containers on FreeBSD
-
-Obtained from: https://github.com/containerd/containerd/pull/7000
---- oci/spec_opts.go.orig 2022-06-06 17:19:23 UTC
-+++ oci/spec_opts.go
-@@ -365,6 +365,7 @@ func WithImageConfigArgs(image Image, args []string) S
- return fmt.Errorf("unknown image config media type %s", ic.MediaType)
- }
-
-+ appendOSMounts(s, ociimage.OS)
- setProcess(s)
- if s.Linux != nil {
- defaults := config.Env
---- oci/spec_opts_darwin.go.orig 2022-06-11 11:16:33 UTC
-+++ oci/spec_opts_darwin.go
-@@ -0,0 +1,21 @@
-+/*
-+ Copyright The containerd Authors.
-+
-+ Licensed under the Apache License, Version 2.0 (the "License");
-+ you may not use this file except in compliance with the License.
-+ You may obtain a copy of the License at
-+
-+ http://www.apache.org/licenses/LICENSE-2.0
-+
-+ Unless required by applicable law or agreed to in writing, software
-+ distributed under the License is distributed on an "AS IS" BASIS,
-+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-+ See the License for the specific language governing permissions and
-+ limitations under the License.
-+*/
-+
-+package oci
-+
-+func appendOSMounts(s *Spec, os string) error {
-+ return nil
-+}
---- oci/spec_opts_freebsd.go.orig 2022-06-11 11:16:33 UTC
-+++ oci/spec_opts_freebsd.go
-@@ -0,0 +1,50 @@
-+/*
-+ Copyright The containerd Authors.
-+
-+ Licensed under the Apache License, Version 2.0 (the "License");
-+ you may not use this file except in compliance with the License.
-+ You may obtain a copy of the License at
-+
-+ http://www.apache.org/licenses/LICENSE-2.0
-+
-+ Unless required by applicable law or agreed to in writing, software
-+ distributed under the License is distributed on an "AS IS" BASIS,
-+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-+ See the License for the specific language governing permissions and
-+ limitations under the License.
-+*/
-+
-+package oci
-+
-+import (
-+ specs "github.com/opencontainers/runtime-spec/specs-go"
-+)
-+
-+// appendOSMounts modifies the mount spec to mount emulated Linux filesystems on FreeBSD,
-+// as per: https://wiki.freebsd.org/LinuxJails
-+func appendOSMounts(s *Spec, os string) error {
-+ // No-op for FreeBSD containers
-+ if os != "linux" {
-+ return nil
-+ }
-+ /* The nosuid noexec options are for consistency with Linux mounts: on FreeBSD it is
-+ by default impossible to execute anything from these filesystems.
-+ */
-+ var mounts = []specs.Mount{
-+ {
-+ Destination: "/proc",
-+ Type: "linprocfs",
-+ Source: "linprocfs",
-+ Options: []string{"nosuid", "noexec"},
-+ },
-+ {
-+ Destination: "/sys",
-+ Type: "linsysfs",
-+ Source: "linsysfs",
-+ Options: []string{"nosuid", "noexec", "nodev"},
-+ },
-+ }
-+
-+ s.Mounts = append(mounts, s.Mounts...)
-+ return nil
-+}
---- oci/spec_opts_linux.go.orig 2022-06-06 17:19:23 UTC
-+++ oci/spec_opts_linux.go
-@@ -153,3 +153,7 @@ func WithRdt(closID, l3CacheSchema, memBwSchema string
- return nil
- }
- }
-+
-+func appendOSMounts(s *Spec, os string) error {
-+ return nil
-+}
---- platforms/defaults_freebsd.go.orig 2022-06-11 11:16:33 UTC
-+++ platforms/defaults_freebsd.go
-@@ -0,0 +1,42 @@
-+/*
-+ Copyright The containerd Authors.
-+
-+ Licensed under the Apache License, Version 2.0 (the "License");
-+ you may not use this file except in compliance with the License.
-+ You may obtain a copy of the License at
-+
-+ http://www.apache.org/licenses/LICENSE-2.0
-+
-+ Unless required by applicable law or agreed to in writing, software
-+ distributed under the License is distributed on an "AS IS" BASIS,
-+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-+ See the License for the specific language governing permissions and
-+ limitations under the License.
-+*/
-+
-+package platforms
-+
-+import (
-+ specs "github.com/opencontainers/image-spec/specs-go/v1"
-+ "runtime"
-+)
-+
-+// DefaultSpec returns the current platform's default platform specification.
-+func DefaultSpec() specs.Platform {
-+ return specs.Platform{
-+ OS: runtime.GOOS,
-+ Architecture: runtime.GOARCH,
-+ // The Variant field will be empty if arch != ARM.
-+ Variant: cpuVariant(),
-+ }
-+}
-+
-+// Default returns the default matcher for the platform.
-+func Default() MatchComparer {
-+ return Ordered(DefaultSpec(), specs.Platform{
-+ OS: "linux",
-+ Architecture: runtime.GOARCH,
-+ // The Variant field will be empty if arch != ARM.
-+ Variant: cpuVariant(),
-+ })
-+}
---- platforms/defaults_unix.go.orig 2022-06-06 17:19:23 UTC
-+++ platforms/defaults_unix.go
-@@ -1,5 +1,5 @@
--//go:build !windows && !darwin
--// +build !windows,!darwin
-+//go:build !windows && !darwin && !freebsd
-+// +build !windows,!darwin,!freebsd
-
- /*
- Copyright The containerd Authors.