summaryrefslogtreecommitdiff
path: root/sysutils/racktables/Makefile
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-04-16 18:10:47 +0200
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-04-16 20:09:23 +0200
commit0ac3a69555cdc6ac1603f4ac7d6f85c5be19e3ea (patch)
tree1ba37b5ce2bb8e5f358541fdf40a7cdf781a5388 /sysutils/racktables/Makefile
parent16a52a343d9d58d5949eb5992daa13cee54cd59d (diff)
downloadfreebsd-ports-0ac3a69555cdc6ac1603f4ac7d6f85c5be19e3ea.zip
*/*: Remove merged or non-existent USE_PHP directives
- Remove USE_PHP=hash which is available in default php installation of all versions of php * security/pear-Horde_Crypt_Blowfish: Remove OPTION MHASH - Remove USE_PHP=json which is available in default php installation of all versions of php * devel/pear-PHPTAL: Remove OPTION JSON * www/ilias: Remove OPTION SCORM2004 - Remove USE_PHP=mssql which is no longer available in php from php80 and later and has been replaced with sqlsrv module which is Windows only * www/codeigniter: Remove OPTION MSSQL * www/moodle311: Remove OPTION MSSQL * www/moodle39: Remove OPTION MSSQL * www/moodle40: Remove OPTION MSSQL * www/moodle41: Remove OPTION MSSQL - Remove USE_PHP=openssl which is available in default php installation of all versions of php * databases/phpmyadmin: Remove OPTION OPENSSL * databases/phpmyadmin5: Remove OPTION OPENSSL * security/pear-Horde_Crypt_Blowfish: Remove OPTION OPENSSL * www/nextcloud: Remove OPTION SSL * www/owncloud: Remove OPTION SSL - Remove USE_PHP=pcre which is available in default php installation of all versions of php * sysutils/racktables: Remove OPTION PCRE - Remove USE_PHP=postgresql which should be USE_PHP=pgsql and update following ports * www/typo3-11 * www/typo3-12 - Remove USE_PHP=pdf which is no longer available as php module * databases/phpmyadmin: Remove OPTION PDF - Remove USE_PHP=spl which is available in default php installation of all versions of php - Remove USE_PHP=sqlsrv which was never imported into FreeBSD as that is Windows only php module * www/typo3-11: Remove OPTION SQLSRV * www/typo3-12: Remove OPTION SQLSRV - Bump where DEFAULT OPTIONS are affected Sponsored by: Bounce Experts Approved by: portmgr(blanket)
Diffstat (limited to 'sysutils/racktables/Makefile')
-rw-r--r--sysutils/racktables/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/sysutils/racktables/Makefile b/sysutils/racktables/Makefile
index c5cc27cc6bce..5429bbd9a98d 100644
--- a/sysutils/racktables/Makefile
+++ b/sysutils/racktables/Makefile
@@ -23,20 +23,18 @@ USE_PERL5= run
SHEBANG_FILES= gateways/*
CPE_VENDOR= racktables_project
-USE_PHP= bcmath gd json mbstring mysqli pdo_mysql session
+USE_PHP= bcmath gd mbstring mysqli pdo_mysql session
SUB_FILES= pkg-message
PLIST_SUB= WWWDIR_REL=${WWWDIR_REL} WWWDIR=${WWWDIR}
WWWUSER?= www
WWWGRP?= www
-OPTIONS_DEFINE= LDAP SNMP CURL PCNTL PCRE EXAMPLES
-PCRE_DESC= Regular Expression Support
+OPTIONS_DEFINE= LDAP SNMP CURL PCNTL EXAMPLES
PCNTL_DESC= pcntl Support
LDAP_USE= PHP=ldap
SNMP_USE= PHP=snmp
CURL_USE= PHP=curl
PCNTL_USE= PHP=pcntl
-PCRE_USE= PHP=pcre
post-patch:
@${FIND} ${WRKSRC} -name \*.orig -type f -delete