summaryrefslogtreecommitdiff
path: root/shells/bash
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2017-03-01 15:19:06 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2017-03-01 15:19:06 +0000
commit4cb2ee99e377137eb3b5a1bb4a38fac20b84f201 (patch)
tree6b21919de6442f3150f4e63a42fae6477f627db6 /shells/bash
parentcbbe2f203bf7a44ef6e286946707841a9f3cb897 (diff)
downloadfreebsd-ports-4cb2ee99e377137eb3b5a1bb4a38fac20b84f201.zip
Default path includes the string %%LOCALBASE%%. This was intended to be replaced
with the real value of LOCALBASE by the port Makefile at some point, but it isn't at the moment. Set this value in the Makefile by defining CPPFLAGS accordingly. PR: 217451 Submitted by: Dan McGregor <dan.mcgregor@usask.ca> MFH: 2017Q1 (blanket)
Diffstat (limited to 'shells/bash')
-rw-r--r--shells/bash/Makefile5
-rw-r--r--shells/bash/files/patch-config-top.h15
2 files changed, 5 insertions, 15 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index f729711305c2..b726f4ce6ce7 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -4,7 +4,7 @@
PORTNAME= bash
PATCHLEVEL= 12
PORTVERSION= 4.4.${PATCHLEVEL:S/^0//g}
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= shells
MASTER_SITES= GNU/${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION:R}
@@ -65,6 +65,9 @@ CONFIGURE_ARGS+= --disable-static-link
# "enable -f". (Plugins are not supported for bash-static.)
CFLAGS+= -Wl,-export-dynamic
.endif
+STANDARD_PATH= /sbin:/bin:/usr/sbin:/usr/bin
+CPPFLAGS+= -DDEFAULT_PATH_VALUE='\"${STANDARD_PATH}:${LOCALBASE}/sbin:${LOCALBASE}/bin\"' \
+ -DSTANDARD_UTILS_PATH='\"${STANDARD_PATH}\"'
post-patch:
# Ensure y.tab.c is regenerated
diff --git a/shells/bash/files/patch-config-top.h b/shells/bash/files/patch-config-top.h
index 08f330f61fb5..b80078cd81cf 100644
--- a/shells/bash/files/patch-config-top.h
+++ b/shells/bash/files/patch-config-top.h
@@ -1,19 +1,6 @@
--- config-top.h.orig 2016-05-19 18:34:02 UTC
+++ config-top.h
-@@ -63,18 +63,18 @@
- /* The default value of the PATH variable. */
- #ifndef DEFAULT_PATH_VALUE
- #define DEFAULT_PATH_VALUE \
-- "/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin:."
-+ "/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:%%LOCALBASE%%/sbin:%%LOCALBASE%%/bin"
- #endif
-
- /* The value for PATH when invoking `command -p'. This is only used when
- the Posix.2 confstr () function, or CS_PATH define are not present. */
- #ifndef STANDARD_UTILS_PATH
- #define STANDARD_UTILS_PATH \
-- "/bin:/usr/bin:/sbin:/usr/sbin:/etc:/usr/etc"
-+ "/sbin:/bin:/usr/sbin:/usr/bin:/usr/games"
+@@ -74,7 +74,7 @@
#endif
/* Default primary and secondary prompt strings. */