summaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2019-12-14 09:24:17 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2019-12-14 09:24:17 +0000
commitb23825e75737254cf91bc3c7c6c742df5cf9ee6f (patch)
treecb87500d1ffba208b28c1b9cb4c0f8262a0a4289 /security
parentb992db8b05175f66542ec87e8f7f0737ba69b38e (diff)
downloadfreebsd-ports-b23825e75737254cf91bc3c7c6c742df5cf9ee6f.zip
Mark BROKEN with recent versions of python and deprecate
PR: 233770
Diffstat (limited to 'security')
-rw-r--r--security/morphis/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/security/morphis/Makefile b/security/morphis/Makefile
index 8cbb13a2e31a..8536026245a3 100644
--- a/security/morphis/Makefile
+++ b/security/morphis/Makefile
@@ -13,6 +13,9 @@ COMMENT= Peer-to-peer high-performance distributed datastore and mail
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Fails to build with recent versions of python, upstream git repository is gone
+EXPIRATION_DATE= 2020-02-14
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlalchemy11>0:databases/py-sqlalchemy11@${PY_FLAVOR}
@@ -44,4 +47,10 @@ do-install:
${INSTALL_SCRIPT} ${WRKDIR}/morphis-cmd ${STAGEDIR}${PREFIX}/bin/morphis
${INSTALL_SCRIPT} ${WRKDIR}/morphis-service ${STAGEDIR}${PREFIX}/etc/rc.d/morphis
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} >= 3700
+BROKEN= fails to build
+.endif
+
+.include <bsd.port.post.mk>