summaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2017-04-28 19:40:28 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2017-04-28 19:40:28 +0000
commit7b7b8cc02b5dfa86ac3ddf43815f0fc63f06d6fc (patch)
tree6d71c52786bfa82458bda0e6aeb9d8abfbc4732f /security
parent8feb17ea57342a273ea2fb424e8c690942618e34 (diff)
downloadfreebsd-ports-7b7b8cc02b5dfa86ac3ddf43815f0fc63f06d6fc.zip
Create rails version 5 ports to avoid conflicts.
Approved by: swills (mentor, implicit)
Diffstat (limited to 'security')
-rw-r--r--security/Makefile2
-rw-r--r--security/rubygem-devise-two-factor-rails5/Makefile26
-rw-r--r--security/rubygem-devise-two-factor-rails5/distinfo3
-rw-r--r--security/rubygem-devise-two-factor-rails5/files/patch-gemspec11
-rw-r--r--security/rubygem-devise-two-factor-rails5/pkg-descr3
-rw-r--r--security/rubygem-doorkeeper-rails5/Makefile21
-rw-r--r--security/rubygem-doorkeeper-rails5/distinfo3
-rw-r--r--security/rubygem-doorkeeper-rails5/pkg-descr4
8 files changed, 73 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index ef2eb3b1c40f..984f8ef35d51 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1004,8 +1004,10 @@
SUBDIR += rubygem-bcrypt
SUBDIR += rubygem-bcrypt-ruby
SUBDIR += rubygem-devise-two-factor
+ SUBDIR += rubygem-devise-two-factor-rails5
SUBDIR += rubygem-digest-crc
SUBDIR += rubygem-doorkeeper
+ SUBDIR += rubygem-doorkeeper-rails5
SUBDIR += rubygem-encryptor
SUBDIR += rubygem-ezcrypto
SUBDIR += rubygem-googleauth
diff --git a/security/rubygem-devise-two-factor-rails5/Makefile b/security/rubygem-devise-two-factor-rails5/Makefile
new file mode 100644
index 000000000000..e833d0f48aed
--- /dev/null
+++ b/security/rubygem-devise-two-factor-rails5/Makefile
@@ -0,0 +1,26 @@
+# Created by: Torsten Zuhlsdorff <ports@toco-domains.de>
+# $FreeBSD$
+
+PORTNAME= devise-two-factor
+PORTVERSION= 3.0.0
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= -rails5
+
+MAINTAINER= jrm@FreeBSD.org
+COMMENT= Barebones two-factor authentication with Devise
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-activesupport5>=0:devel/rubygem-activesupport5 \
+ rubygem-attr_encrypted>=1.3:security/rubygem-attr_encrypted \
+ rubygem-devise-rails5>0:devel/rubygem-devise-rails5 \
+ rubygem-railties5>=0:www/rubygem-railties5 \
+ rubygem-rotp>=2.0:devel/rubygem-rotp
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-devise-two-factor-rails5/distinfo b/security/rubygem-devise-two-factor-rails5/distinfo
new file mode 100644
index 000000000000..3b0db20d3c62
--- /dev/null
+++ b/security/rubygem-devise-two-factor-rails5/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1469115414
+SHA256 (rubygem/devise-two-factor-3.0.0.gem) = fa116fcd6e0a94d5a0581e230a9ac286eee8c17299d54e36ad443d5a346f74de
+SIZE (rubygem/devise-two-factor-3.0.0.gem) = 27648
diff --git a/security/rubygem-devise-two-factor-rails5/files/patch-gemspec b/security/rubygem-devise-two-factor-rails5/files/patch-gemspec
new file mode 100644
index 000000000000..33b2f7571c11
--- /dev/null
+++ b/security/rubygem-devise-two-factor-rails5/files/patch-gemspec
@@ -0,0 +1,11 @@
+--- devise-two-factor.gemspec.orig 2016-12-31 23:56:23 UTC
++++ devise-two-factor.gemspec
+@@ -28,7 +28,7 @@ Gem::Specification.new do |s|
+ s.add_runtime_dependency(%q<activesupport>.freeze, [">= 0"])
+ s.add_runtime_dependency(%q<attr_encrypted>.freeze, ["!= 2", "< 4", ">= 1.3"])
+ s.add_runtime_dependency(%q<devise>.freeze, ["~> 4.0"])
+- s.add_runtime_dependency(%q<rotp>.freeze, ["~> 2.0"])
++ s.add_runtime_dependency(%q<rotp>.freeze, [">= 2.0"])
+ s.add_development_dependency(%q<activemodel>.freeze, [">= 0"])
+ s.add_development_dependency(%q<bundler>.freeze, ["> 1.0"])
+ s.add_development_dependency(%q<rspec>.freeze, ["> 3"])
diff --git a/security/rubygem-devise-two-factor-rails5/pkg-descr b/security/rubygem-devise-two-factor-rails5/pkg-descr
new file mode 100644
index 000000000000..314c84f06bb5
--- /dev/null
+++ b/security/rubygem-devise-two-factor-rails5/pkg-descr
@@ -0,0 +1,3 @@
+Barebones two-factor authentication with Devise
+
+WWW: https://github.com/tinfoil/devise-two-factor
diff --git a/security/rubygem-doorkeeper-rails5/Makefile b/security/rubygem-doorkeeper-rails5/Makefile
new file mode 100644
index 000000000000..2e69d10b6586
--- /dev/null
+++ b/security/rubygem-doorkeeper-rails5/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= doorkeeper
+PORTVERSION= 4.2.5
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= -rails5
+
+MAINTAINER= jrm@FreeBSD.org
+COMMENT= Doorkeeper is an OAuth 2 provider for Rails and Grape
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS= rubygem-railties5>0:www/rubygem-railties5
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-doorkeeper-rails5/distinfo b/security/rubygem-doorkeeper-rails5/distinfo
new file mode 100644
index 000000000000..11e6bd217f6a
--- /dev/null
+++ b/security/rubygem-doorkeeper-rails5/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1491215697
+SHA256 (rubygem/doorkeeper-4.2.5.gem) = e774f6e1a528fbca30038e57b3b4fcad5a195a75fd050176f041a590fb42dd40
+SIZE (rubygem/doorkeeper-4.2.5.gem) = 105984
diff --git a/security/rubygem-doorkeeper-rails5/pkg-descr b/security/rubygem-doorkeeper-rails5/pkg-descr
new file mode 100644
index 000000000000..05c77e09e5d2
--- /dev/null
+++ b/security/rubygem-doorkeeper-rails5/pkg-descr
@@ -0,0 +1,4 @@
+Doorkeeper is a Ruby gem that makes it easy to introduce OAuth 2
+provider functionality to a Rails or Grape application.
+
+WWW: https://github.com/doorkeeper-gem/doorkeeper