summaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-09-21 16:08:11 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-09-21 16:08:11 +0000
commit17e550ca2fd180b150f6645ced5f3bb45bc32292 (patch)
treee856fa025c5b15bbef21f621e347c51780662a47 /security
parentb4599e3d63c3a94b17026b18d1f8ac27faac53fc (diff)
downloadfreebsd-ports-17e550ca2fd180b150f6645ced5f3bb45bc32292.zip
Explicitly depend on p5-Digest-MD5 only if PERL_LEVEL < 500703
Explicitly depend on p5-Digest-SHA only if PERL_LEVEL < 501000
Diffstat (limited to 'security')
-rw-r--r--security/cp2fwb/Makefile12
-rw-r--r--security/ftimes/Makefile2
-rw-r--r--security/p5-Authen-Simple/Makefile15
-rw-r--r--security/p5-Crypt-SaltedHash/Makefile19
-rw-r--r--security/p5-Crypt-Simple/Makefile5
-rw-r--r--security/p5-Module-Signature/Makefile14
6 files changed, 49 insertions, 18 deletions
diff --git a/security/cp2fwb/Makefile b/security/cp2fwb/Makefile
index 23d8dfe7014c..1efcbc61b3d0 100644
--- a/security/cp2fwb/Makefile
+++ b/security/cp2fwb/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cp2fwb
PORTVERSION= 0.6
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}uilder/${PORTNAME}uilder/${PORTNAME}-${PORTVERSION}
EXTRACT_SUFX= .tgz
@@ -14,15 +15,20 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Checkpoint FW1 to Firewall Builder ruleset converter
-RUN_DEPENDS= ${SITE_PERL}/XML/Writer.pm:${PORTSDIR}/textproc/p5-XML-Writer \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+RUN_DEPENDS= ${SITE_PERL}/XML/Writer.pm:${PORTSDIR}/textproc/p5-XML-Writer
PLIST_FILES= bin/cp2fwbuilder
USE_PERL5= yes
NO_BUILD= yes
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/cp2fwbuilder ${PREFIX}/bin
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/ftimes/Makefile b/security/ftimes/Makefile
index e57ac1c9ad09..0956419c7a21 100644
--- a/security/ftimes/Makefile
+++ b/security/ftimes/Makefile
@@ -29,7 +29,9 @@ OPTIONS= DIG_TOOLS "install dig tools" on \
.include <bsd.port.pre.mk>
.if defined(WITH_DIG_TOOLS) || defined(WITH_MAP_TOOLS)
+. if ${PERL_LEVEL} < 500703
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+. endif
.endif
.if defined(WITH_DIG_TOOLS)
diff --git a/security/p5-Authen-Simple/Makefile b/security/p5-Authen-Simple/Makefile
index eb2cc2efff56..57c434e66542 100644
--- a/security/p5-Authen-Simple/Makefile
+++ b/security/p5-Authen-Simple/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Authen-Simple
PORTVERSION= 0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,12 +15,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple authentication framework
-BUILD_DEPENDS= ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+RUN_DEPENDS= ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
${SITE_PERL}/Crypt/PasswdMD5.pm:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
- ${SITE_PERL}/${PERL_ARCH}/Digest/SHA.pm:${PORTSDIR}/security/p5-Digest-SHA \
p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
MAN3= Authen::Simple.3 \
Authen::Simple::Adapter.3 \
@@ -30,4 +29,10 @@ MAN3= Authen::Simple.3 \
PERL_MODBUILD= 5.8.0+
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-SaltedHash/Makefile b/security/p5-Crypt-SaltedHash/Makefile
index 6c4ec3279713..d5c239ec9c40 100644
--- a/security/p5-Crypt-SaltedHash/Makefile
+++ b/security/p5-Crypt-SaltedHash/Makefile
@@ -5,6 +5,7 @@
PORTNAME= Crypt-SaltedHash
PORTVERSION= 0.05
+PORTREVISION= 1
CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -12,12 +13,20 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Perl extension to work with salted hashes
-RUN_DEPENDS= ${SITE_PERL}/Digest.pm:${PORTSDIR}/security/p5-Digest
-BUILD_DEPENDS= ${RUN_DEPENDS}
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-
PERL_MODBUILD= yes
MAN3= Crypt::SaltedHash.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-Digest>=1.16:${PORTSDIR}/security/p5-Digest
+BUILD_DEPENDS+= p5-Digest>=1.16:${PORTSDIR}/security/p5-Digest
+.endif
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+BUILD_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-Simple/Makefile b/security/p5-Crypt-Simple/Makefile
index 5ec0647954c1..e409e9dbe8f4 100644
--- a/security/p5-Crypt-Simple/Makefile
+++ b/security/p5-Crypt-Simple/Makefile
@@ -17,7 +17,6 @@ COMMENT= Perl encrypt stuff simply
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Crypt/Blowfish.pm:${PORTSDIR}/security/p5-Crypt-Blowfish \
${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/FreezeThaw.pm:${PORTSDIR}/devel/p5-FreezeThaw
BUILD_DEPENDS= ${RUN_DEPENDS}
@@ -27,6 +26,10 @@ MAN3= Crypt::Simple.3
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
.if ${PERL_LEVEL} < 500903
RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
.endif
diff --git a/security/p5-Module-Signature/Makefile b/security/p5-Module-Signature/Makefile
index 1521de9e6980..99d909422924 100644
--- a/security/p5-Module-Signature/Makefile
+++ b/security/p5-Module-Signature/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Module-Signature
PORTVERSION= 0.64
+PORTREVISION= 1
CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,14 +15,19 @@ PKGNAMEPREFIX= p5-
MAINTAINER= clsung@FreeBSD.org
COMMENT= Module signature file manipulation
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA.pm:${PORTSDIR}/security/p5-Digest-SHA \
- ${SITE_PERL}/PAR/Dist.pm:${PORTSDIR}/devel/p5-PAR-Dist \
+RUN_DEPENDS= ${SITE_PERL}/PAR/Dist.pm:${PORTSDIR}/devel/p5-PAR-Dist \
${LOCALBASE}/bin/gpgv:${PORTSDIR}/security/gnupg1
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
MAN1= cpansign.1
MAN3= Module::Signature.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
+.endif
+
+.include <bsd.port.post.mk>