summaryrefslogtreecommitdiff
path: root/security/rsaref/files
diff options
context:
space:
mode:
authorScott Mace <smace@FreeBSD.org>1998-09-14 22:33:48 +0000
committerScott Mace <smace@FreeBSD.org>1998-09-14 22:33:48 +0000
commit380961dbc946a3e622eed4fcca90dea47f5d65c2 (patch)
tree5a3169f3203a71ff240d59bccf869586610ebf40 /security/rsaref/files
parentf74a079f9c9fb5055313b9b80853a960ceb23b23 (diff)
downloadfreebsd-ports-380961dbc946a3e622eed4fcca90dea47f5d65c2.zip
Convert to Elf.
Diffstat (limited to 'security/rsaref/files')
-rw-r--r--security/rsaref/files/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/security/rsaref/files/Makefile b/security/rsaref/files/Makefile
index 1ad713a527d9..ffc2d0f29ac4 100644
--- a/security/rsaref/files/Makefile
+++ b/security/rsaref/files/Makefile
@@ -8,7 +8,7 @@ LIB= ar
${CC} -fpic -DPIC ${CFLAGS} -c ${.IMPSRC} -o ${.TARGET}
RSAREFLIB=librsaref.a
-SORSAREFLIB=librsaref.so.2.0
+SORSAREFLIB=librsaref.so.2
all: ${RSAREFLIB} ${SORSAREFLIB}
@@ -21,5 +21,5 @@ $(RSAREFLIB) : desc.$(O) digit.$(O) md2c.$(O) md5c.$(O) nn.$(O) prime.$(O)\
$(SORSAREFLIB) : desc.$(SO) digit.$(SO) md2c.$(SO) md5c.$(SO) nn.$(SO) prime.$(SO)\
rsa.$(SO) r_encode.$(SO) r_dh.$(SO) r_enhanc.$(SO) r_keygen.$(SO) r_random.$(SO)\
r_stdlib.$(SO)
- ld -Bshareable -x -o $@ $>
+ ${CC} -o $@ -shared -Wl,-rpath,${PREFIX}/lib -Wl,-soname,$@ $>