summaryrefslogtreecommitdiff
path: root/security/ftimes
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /security/ftimes
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadfreebsd-ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Diffstat (limited to 'security/ftimes')
-rw-r--r--security/ftimes/Makefile2
-rw-r--r--security/ftimes/pkg-plist3
2 files changed, 1 insertions, 4 deletions
diff --git a/security/ftimes/Makefile b/security/ftimes/Makefile
index 0897a3109aa4..7ff52f7f39db 100644
--- a/security/ftimes/Makefile
+++ b/security/ftimes/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ftimes
PORTVERSION= 3.11.0
+PORTREVISION= 1
CATEGORIES= security sysutils
MASTER_SITES= SF
@@ -126,7 +127,6 @@ CONFIGURE_ARGS+= --disable-xmagic
.if ${INSTALL_PERL5_LIBS}
PLIST_SUB+= FTIMES_PERL5_LIBS=""
-USE_PERL5+= fixpacklist
.else
PLIST_SUB+= FTIMES_PERL5_LIBS="@comment "
.endif
diff --git a/security/ftimes/pkg-plist b/security/ftimes/pkg-plist
index 772cc986740a..3971f7f998ab 100644
--- a/security/ftimes/pkg-plist
+++ b/security/ftimes/pkg-plist
@@ -41,7 +41,6 @@ bin/ftimes
etc/ftimes-dig.cfg.sample
etc/ftimes-get.cfg.sample
etc/ftimes-map.cfg.sample
-%%FTIMES_PERL5_LIBS%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/FTimes/.packlist
%%FTIMES_PERL5_LIBS%%%%SITE_PERL%%/FTimes/EadRoutines.pm
%%FTIMES_PERL5_LIBS%%%%SITE_PERL%%/FTimes/Properties.pm
man/man1/ftimes.1.gz
@@ -85,5 +84,3 @@ man/man1/ftimes.1.gz
%%MAP_TOOLS%%man/man1/zipmap.1.gz
%%FTIMES_PERL5_LIBS%%man/man3/FTimes::EadRoutines.3.gz
%%FTIMES_PERL5_LIBS%%man/man3/FTimes::Properties.3.gz
-%%FTIMES_PERL5_LIBS%%@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/FTimes
-%%FTIMES_PERL5_LIBS%%@dirrm %%SITE_PERL%%/FTimes