summaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-12-17 10:01:42 -0800
committerYuri Victorovich <yuri@FreeBSD.org>2023-12-17 11:01:48 -0800
commitf47c4702d35c68b06f643f35c9cb97aa064e4bb5 (patch)
tree76ff8a4039340dec36e0c446201eb36ab0d591a3 /science
parent4da4a21c347360da0913b2bfc3ffec3474f0f20e (diff)
downloadfreebsd-ports-f47c4702d35c68b06f643f35c9cb97aa064e4bb5.zip
science/py-trx-python: New port: Experiments with new file format for tractography
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/py-trx-python/Makefile34
-rw-r--r--science/py-trx-python/distinfo3
-rw-r--r--science/py-trx-python/pkg-descr2
4 files changed, 40 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 54349ac30d32..7652e118ab37 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -442,6 +442,7 @@
SUBDIR += py-thewalrus
SUBDIR += py-tobler
SUBDIR += py-trainstation
+ SUBDIR += py-trx-python
SUBDIR += py-tweedledum
SUBDIR += py-vedo
SUBDIR += py-veusz
diff --git a/science/py-trx-python/Makefile b/science/py-trx-python/Makefile
new file mode 100644
index 000000000000..affec6e6d4b7
--- /dev/null
+++ b/science/py-trx-python/Makefile
@@ -0,0 +1,34 @@
+PORTNAME= trx-python # this project is planned to be merged into DIPY (science/py-dipy)
+DISTVERSION= 0.2.9
+CATEGORIES= science python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Experiments with new file format for tractography
+WWW= https://tee-ar-ex.github.io/trx-python/
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}deepdiff>0:devel/py-deepdiff@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}nibabel>0:science/py-nibabel@${PY_FLAVOR} \
+ ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>=19.0:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm_git_archive>0:devel/py-setuptools_scm_git_archive@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR} # mistaken dependency, see https://github.com/tee-ar-ex/trx-python/issues/73
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flake8>=0:devel/py-flake8@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}psutil>0:sysutils/py-psutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-console-scripts>0:devel/py-pytest-console-scripts@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= pep517 cython autoplist pytest # few tests fail due to missing files
+
+#USE_GITHUB= yes
+#GH_ACCOUNT= tee-ar-ex
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/science/py-trx-python/distinfo b/science/py-trx-python/distinfo
new file mode 100644
index 000000000000..6ad4dbd64b8f
--- /dev/null
+++ b/science/py-trx-python/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1702835339
+SHA256 (trx-python-0.2.9.tar.gz) = 16b4104d7c991879c601f60e8d587decac50ce60388aae8d0c754a92136d1caf
+SIZE (trx-python-0.2.9.tar.gz) = 86016
diff --git a/science/py-trx-python/pkg-descr b/science/py-trx-python/pkg-descr
new file mode 100644
index 000000000000..ca7ed7ee4295
--- /dev/null
+++ b/science/py-trx-python/pkg-descr
@@ -0,0 +1,2 @@
+trx is a Python implementation of the trx file-format
+for tractography data.