summaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-15 10:02:15 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-15 10:02:15 +0000
commit1bdd845e2e8db02ebcb58c84b08f7eb298de327c (patch)
tree338a371d01e627863d294c58ec24b97f73fc9e21 /science
parentde96e1d6a9079c25ff6d27de037046ac137267ff (diff)
downloadfreebsd-ports-1bdd845e2e8db02ebcb58c84b08f7eb298de327c.zip
add xloops-ginac 0.1.3
A program calculating Feynman diagrams
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/xloops-ginac/Makefile26
-rw-r--r--science/xloops-ginac/distinfo1
-rw-r--r--science/xloops-ginac/files/patch-ginsh_lexer.ll11
-rw-r--r--science/xloops-ginac/files/patch-ginsh_parser.yy19
-rw-r--r--science/xloops-ginac/pkg-comment1
-rw-r--r--science/xloops-ginac/pkg-descr3
-rw-r--r--science/xloops-ginac/pkg-plist8
8 files changed, 70 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index fd60fbeafed5..2ce613a6c1dc 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -16,6 +16,7 @@
SUBDIR += oases
SUBDIR += p5-Chemistry-Elements
SUBDIR += vis5d+
+ SUBDIR += xloops-ginac
SUBDIR += xmakemol
.include <bsd.port.subdir.mk>
diff --git a/science/xloops-ginac/Makefile b/science/xloops-ginac/Makefile
new file mode 100644
index 000000000000..921c04e977aa
--- /dev/null
+++ b/science/xloops-ginac/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: xloops
+# Date created: Oct 15, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= xloops
+PORTVERSION= 0.1.3
+CATEGORIES= science
+MASTER_SITES= http://wwwthep.physik.uni-mainz.de/~xloops/
+PKGNAMESUFFIX= -ginac
+DISTNAME= ${PORTNAME}-ginac-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= ginac:${PORTSDIR}/math/GiNaC
+
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+
+post-install:
+ @${RMDIR} ${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/science/xloops-ginac/distinfo b/science/xloops-ginac/distinfo
new file mode 100644
index 000000000000..fcc913a5f4b9
--- /dev/null
+++ b/science/xloops-ginac/distinfo
@@ -0,0 +1 @@
+MD5 (xloops-ginac-0.1.3.tar.gz) = 20067ef5c2145892ac349937ffb96439
diff --git a/science/xloops-ginac/files/patch-ginsh_lexer.ll b/science/xloops-ginac/files/patch-ginsh_lexer.ll
new file mode 100644
index 000000000000..bd99bda63645
--- /dev/null
+++ b/science/xloops-ginac/files/patch-ginsh_lexer.ll
@@ -0,0 +1,11 @@
+--- ginsh/ginsh_lexer.ll.orig Tue Oct 15 17:19:57 2002
++++ ginsh/ginsh_lexer.ll Tue Oct 15 17:20:27 2002
+@@ -32,6 +32,8 @@
+ #include "ginsh.h"
+ #include "ginsh_parser.h"
+
++extern YYSTYPE yylval;
++
+ #define YY_INPUT(buf, result, max_size) (result = ginsh_input(buf, max_size))
+
+ // Table of all used symbols
diff --git a/science/xloops-ginac/files/patch-ginsh_parser.yy b/science/xloops-ginac/files/patch-ginsh_parser.yy
new file mode 100644
index 000000000000..80fe08e52859
--- /dev/null
+++ b/science/xloops-ginac/files/patch-ginsh_parser.yy
@@ -0,0 +1,19 @@
+--- ginsh/ginsh_parser.yy.orig Tue Oct 15 17:15:25 2002
++++ ginsh/ginsh_parser.yy Tue Oct 15 17:18:14 2002
+@@ -29,6 +29,7 @@
+ %{
+ #include "config.h"
+
++#include <sys/time.h>
+ #include <sys/resource.h>
+
+ #if HAVE_UNISTD_H
+@@ -796,6 +797,8 @@
+ /*
+ * Main program
+ */
++
++int yyparse();
+
+ int main(int argc, char **argv)
+ {
diff --git a/science/xloops-ginac/pkg-comment b/science/xloops-ginac/pkg-comment
new file mode 100644
index 000000000000..4e9ec080f32f
--- /dev/null
+++ b/science/xloops-ginac/pkg-comment
@@ -0,0 +1 @@
+A program calculating Feynman diagrams
diff --git a/science/xloops-ginac/pkg-descr b/science/xloops-ginac/pkg-descr
new file mode 100644
index 000000000000..f5061b1ba681
--- /dev/null
+++ b/science/xloops-ginac/pkg-descr
@@ -0,0 +1,3 @@
+A Program Package calculating One- and Two-Loop Feynman Diagrams
+
+WWW: http://wwwthep.physik.uni-mainz.de/~xloops/
diff --git a/science/xloops-ginac/pkg-plist b/science/xloops-ginac/pkg-plist
new file mode 100644
index 000000000000..4f1fbb1f91c0
--- /dev/null
+++ b/science/xloops-ginac/pkg-plist
@@ -0,0 +1,8 @@
+bin/ginsh-xloops
+include/xloops/oneloop.h
+include/xloops/po_redux.h
+include/xloops/r.h
+include/xloops/twoloop.h
+include/xloops/xloops.h
+@dirrm include/xloops
+lib/libxloops.a