summaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2023-01-10 10:09:52 -0700
committerAdam Weinberger <adamw@FreeBSD.org>2023-01-10 10:13:15 -0700
commit07b61611e9a26854900a8db50235c0b7880e025e (patch)
tree57b197f9ffa72a4a176b60d7f701c3b139dd84ef /science
parente494d5c39583e86dddd6d8e1c47eff68512d9b8a (diff)
downloadfreebsd-ports-07b61611e9a26854900a8db50235c0b7880e025e.zip
multiple: Fix msgpack cmake package name
msgpack-c's cmake package name changed to `msgpackc' msgpack-cxx's cmake package named to `msgpackc-cxx' because I guess that's how msgpack's developers roll. Fix the two instances I could find where a CMakeLists.txt was looking for msgpack through its cmake package name. There are probably others.
Diffstat (limited to 'science')
-rw-r--r--science/mmtf-cpp/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/science/mmtf-cpp/Makefile b/science/mmtf-cpp/Makefile
index 01db9e8db41f..fa17eaebe812 100644
--- a/science/mmtf-cpp/Makefile
+++ b/science/mmtf-cpp/Makefile
@@ -30,6 +30,8 @@ post-patch: # correct paths of test data to be accessible to the test executable
s|\.\./submodules/mmtf_spec|${WRKSRC}/submodules/mmtf_spec|g; \
s|\.\./temporary_test_data|${WRKSRC}/temporary_test_data|g' \
${WRKSRC}/tests/mmtf_tests.cpp
+ @${REINPLACE_CMD} -e '/find_package/s|msgpack|msgpackc-cxx|' \
+ ${WRKSRC}/CMakeLists.txt
do-install:
cd ${WRKSRC} && ${COPYTREE_SHARE} include ${STAGEDIR}${PREFIX}