summaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2021-03-23 19:12:53 +0000
committerChris Rees <crees@FreeBSD.org>2021-03-23 19:12:53 +0000
commitee356e8cc6b7e2119d9b94fbd738367fd11cfffc (patch)
tree1c31e9ad1c550be5ca1bcd0a3f5af3e03f68e979 /print
parent55bba85570e79dd3d7164cfc96ef95e2e27d5170 (diff)
downloadfreebsd-ports-ee356e8cc6b7e2119d9b94fbd738367fd11cfffc.zip
print/pdflib: License allows distribution
Add LICENSE and details. There is no need for this port to be restricted- it is freely redistributable. https://lists.freebsd.org/pipermail/freebsd-ports/2021-March/120412.html While here, a few style fixes and updates Reported by: Patrick M. Hausen <hausen@punkt.de> Approved by: maintainer timeout (ale, >14 days) Differential Revision: https://reviews.freebsd.org/D29059
Diffstat (limited to 'print')
-rw-r--r--print/pdflib/Makefile39
-rw-r--r--print/pdflib/distinfo3
2 files changed, 23 insertions, 19 deletions
diff --git a/print/pdflib/Makefile b/print/pdflib/Makefile
index 684b27b1ea0b..3a8658035e54 100644
--- a/print/pdflib/Makefile
+++ b/print/pdflib/Makefile
@@ -5,19 +5,21 @@ PORTNAME= pdflib
PORTVERSION= 7.0.5
PORTREVISION= 6
CATEGORIES= print perl5 java
-MASTER_SITES= LOCAL/ale
+MASTER_SITES= LOCAL/ale:src \
+ LOCAL/crees:license
DISTNAME= PDFlib-Lite-${PORTVERSION}p3
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:src PDFlib-Lite-license.txt.gz:license
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ale@FreeBSD.org
COMMENT= C library for dynamically generating PDF
-BUILD_DEPENDS= gsed:textproc/gsed
-
-RESTRICTED= Many odd restrictions on usage and distribution
+LICENSE= PDFlib-Lite
+LICENSE_NAME= PDFlib-Lite
+LICENSE_FILE= ${WRKDIR}/LICENSE
+LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
-OPTIONS_DEFINE= PERL JAVA DOCS
-PERL_DESC= Build perl bindings
-JAVA_DESC= Build Java bindings
+BUILD_DEPENDS= gsed:textproc/gsed
USES= gmake libtool
USE_LDCONFIG= yes
@@ -25,31 +27,30 @@ GNU_CONFIGURE= yes
BINARY_ALIAS= sed=${LOCALBASE}/bin/gsed
CONFIGURE_ARGS= --with-py=no --with-ruby=no --with-tcl=no
+OPTIONS_DEFINE= PERL JAVA DOCS
+OPTIONS_SUB= yes
+PERL_DESC= Build perl bindings
+JAVA_DESC= Build Java bindings
+PERL_CONFIGURE_WITH= perl=${PERL}
+
PORTDOCS= *
PERL_USES= perl5
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MPERL}
-PLIST_SUB+= PERL=""
-CONFIGURE_ARGS+=--with-perl=${PERL}
-.else
-CONFIGURE_ARGS+=--with-perl=no
-PLIST_SUB+= PERL="@comment "
-.endif
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MJAVA}
USE_JAVA= yes
JAVA_BUILD= yes
JAVA_RUN= yes
-PLIST_SUB+= JAVA=""
CONFIGURE_ARGS+=--with-java=${JAVA_HOME}
.else
CONFIGURE_ARGS+=--with-java=no
-PLIST_SUB+= JAVA="@comment "
.endif
+post-extract:
+ ${GZCAT} ${DISTDIR}/PDFlib-Lite-license.txt.gz > ${WRKDIR}/LICENSE
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/pdfimage ${STAGEDIR}${PREFIX}/bin/text2pdf \
${STAGEDIR}${PREFIX}/lib/libpdf.so.6.0.5
@@ -63,4 +64,4 @@ post-install-DOCS-on:
post-install-JAVA-on:
${INSTALL_DATA} ${WRKSRC}/bind/pdflib/java/pdflib.jar ${STAGEDIR}${JAVAJARDIR}/pdflib.jar
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/pdflib/distinfo b/print/pdflib/distinfo
index 84d201cb2dae..f29efbc9716e 100644
--- a/print/pdflib/distinfo
+++ b/print/pdflib/distinfo
@@ -1,2 +1,5 @@
+TIMESTAMP = 1614866181
SHA256 (PDFlib-Lite-7.0.5p3.tar.gz) = e5fb30678165d28b2bf066f78d5f5787e73a2a28d4902b63e3e07ce1678616c9
SIZE (PDFlib-Lite-7.0.5p3.tar.gz) = 8179201
+SHA256 (PDFlib-Lite-license.txt.gz) = fedc1ef76e3df5f40cf5740a0fc06df5a7844a968cf72dba3e073716f779a91b
+SIZE (PDFlib-Lite-license.txt.gz) = 2869