summaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2018-12-14 17:41:40 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2018-12-14 17:41:40 +0000
commit399abe0750f4ae5c25b3fe1a431a2a71ed0ae67c (patch)
tree640253287f63e99e883b24d7996ea94e4017fb46 /print
parentb5ed8826341d6d48880375495c5bd34e9d897337 (diff)
downloadfreebsd-ports-399abe0750f4ae5c25b3fe1a431a2a71ed0ae67c.zip
- Update to 1.21.5.
- Fix support for cups_browsed_flags in the cups_browsed rc.d script. The flags were passed to daemon(8) instead of cups_browsed. [1] PR: 230951 [1] Submitted by: J.R. Oldroyd <fbsd@opal.com> [1]
Diffstat (limited to 'print')
-rw-r--r--print/cups-filters/Makefile3
-rw-r--r--print/cups-filters/distinfo6
-rw-r--r--print/cups-filters/files/cups_browsed.in15
3 files changed, 15 insertions, 9 deletions
diff --git a/print/cups-filters/Makefile b/print/cups-filters/Makefile
index 427e3b23b38c..90503c911452 100644
--- a/print/cups-filters/Makefile
+++ b/print/cups-filters/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= cups-filters
-PORTVERSION= 1.21.3
-PORTREVISION= 1
+PORTVERSION= 1.21.5
CATEGORIES= print
MASTER_SITES= http://www.openprinting.org/download/cups-filters/
diff --git a/print/cups-filters/distinfo b/print/cups-filters/distinfo
index 940c8f0dcfbf..dbb729de59da 100644
--- a/print/cups-filters/distinfo
+++ b/print/cups-filters/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1538924799
-SHA256 (cups-filters-1.21.3.tar.xz) = f5a61222148f68d0afc3bb5960eda167f9bcd0055dcd4c5c4a6909f1a79126e0
-SIZE (cups-filters-1.21.3.tar.xz) = 1474152
+TIMESTAMP = 1544808087
+SHA256 (cups-filters-1.21.5.tar.xz) = 389ba80917e9a2157a3af8c0b7d8b80db34a22e22beffab67928783c8f4cf82b
+SIZE (cups-filters-1.21.5.tar.xz) = 1474388
diff --git a/print/cups-filters/files/cups_browsed.in b/print/cups-filters/files/cups_browsed.in
index 62035d871e6d..1a8ff408d8bf 100644
--- a/print/cups-filters/files/cups_browsed.in
+++ b/print/cups-filters/files/cups_browsed.in
@@ -19,11 +19,18 @@ rcvar=cups_browsed_enable
load_rc_config ${name}
- : ${cups_browsed_enable:=NO}
+: ${cups_browsed_enable:=NO}
+: ${cups_browsed_flags:=}
-command=/usr/sbin/daemon
pidfile=/var/run/cups-browsed.pid
-command_args="-p ${pidfile} %%PREFIX%%/sbin/cups-browsed"
-procname="%%PREFIX%%/sbin/cups-browsed"
+command="%%PREFIX%%/sbin/cups-browsed"
+
+start_cmd="${name}_start"
+
+cups_browsed_start()
+{
+ echo -n "Starting ${name}."
+ /usr/sbin/daemon -p ${pidfile} ${command} ${cups_browsed_flags}
+}
run_rc_command "$1"