summaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2015-12-11 13:27:49 +0000
committerMartin Wilke <miwi@FreeBSD.org>2015-12-11 13:27:49 +0000
commite9ce85919bcedb19e482c9666efefb9335d31426 (patch)
tree0282d3b890868f0128c3d8e50d66129e71f9d7a0 /net
parentcb17eafaa6666e746f80245c91340d4ed9348892 (diff)
downloadfreebsd-ports-e9ce85919bcedb19e482c9666efefb9335d31426.zip
Official command-line client for RIPE Atlas. RIPE Atlas is a global network
of probes that measure Internet connectivity and reachability, providing an unprecedented understanding of the state of the Internet in real time. WWW: https://github.com/RIPE-NCC/ripe-atlas-tools PR: 204784 Submitted by: Massimiliano Stucchi <mstucchi@ripe.net> Approved by: mat (mentor) Differential Revision: D4505
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-ripe.atlas.tools/Makefile28
-rw-r--r--net/py-ripe.atlas.tools/distinfo2
-rw-r--r--net/py-ripe.atlas.tools/pkg-descr5
4 files changed, 36 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 568c3d668af1..6334f4c9a1c4 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -977,6 +977,7 @@
SUBDIR += py-raet
SUBDIR += py-ripe.atlas.cousteau
SUBDIR += py-ripe.atlas.sagan
+ SUBDIR += py-ripe.atlas.tools
SUBDIR += py-s3cmd
SUBDIR += py-simplesoap
SUBDIR += py-smbpasswd
diff --git a/net/py-ripe.atlas.tools/Makefile b/net/py-ripe.atlas.tools/Makefile
new file mode 100644
index 000000000000..c5d8c2a91be2
--- /dev/null
+++ b/net/py-ripe.atlas.tools/Makefile
@@ -0,0 +1,28 @@
+# Created by: Massimiliano Stucchi <mstucchi@ripe.net>
+# $FreeBSD$
+
+PORTNAME= ripe.atlas.tools
+PORTVERSION= 1.1.0
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= mstucchi@ripe.net
+COMMENT= Official command-line client for RIPE Atlas
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>0:${PORTSDIR}/devel/py-dateutil \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.7.0:${PORTSDIR}/www/py-requests \
+ ${PYTHON_PKGNAMEPREFIX}ripe.atlas.cousteau>=1.0.4:${PORTSDIR}/net/py-ripe.atlas.cousteau \
+ ${PYTHON_PKGNAMEPREFIX}ripe.atlas.sagan>=1.1.4:${PORTSDIR}/net/py-ripe.atlas.sagan \
+ ${PYTHON_PKGNAMEPREFIX}tzlocal>0:${PORTSDIR}/devel/py-tzlocal \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=0.13:${PORTSDIR}/security/py-openssl
+
+USES= python
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net/py-ripe.atlas.tools/distinfo b/net/py-ripe.atlas.tools/distinfo
new file mode 100644
index 000000000000..f6469a679a6e
--- /dev/null
+++ b/net/py-ripe.atlas.tools/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ripe.atlas.tools-1.1.0.tar.gz) = ad0e4e27ac0f67b42262ed2f66566887e55151ed5250b6aab9285858b29ebc6e
+SIZE (ripe.atlas.tools-1.1.0.tar.gz) = 50573
diff --git a/net/py-ripe.atlas.tools/pkg-descr b/net/py-ripe.atlas.tools/pkg-descr
new file mode 100644
index 000000000000..13489d1bff5a
--- /dev/null
+++ b/net/py-ripe.atlas.tools/pkg-descr
@@ -0,0 +1,5 @@
+Official command-line client for RIPE Atlas. RIPE Atlas is a global network
+of probes that measure Internet connectivity and reachability, providing
+an unprecedented understanding of the state of the Internet in real time.
+
+WWW: https://github.com/RIPE-NCC/ripe-atlas-tools