summaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-10-15 22:23:25 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-10-15 22:23:25 +0000
commitd894e365fe83a695850869cd43b9ff91d9c2323a (patch)
tree7a18870cedbd144cff76a826ef41b266e5dc5835 /net
parent92de6ccebceda884546e94d61280d86bf0d94eec (diff)
downloadfreebsd-ports-d894e365fe83a695850869cd43b9ff91d9c2323a.zip
BROKEN on 5.x: does not compile
Diffstat (limited to 'net')
-rw-r--r--net/gnewtellium/Makefile8
-rw-r--r--net/libnids/Makefile8
-rw-r--r--net/tvark/Makefile8
3 files changed, 21 insertions, 3 deletions
diff --git a/net/gnewtellium/Makefile b/net/gnewtellium/Makefile
index dd6cb3dc1917..79defb18f3cb 100644
--- a/net/gnewtellium/Makefile
+++ b/net/gnewtellium/Makefile
@@ -19,4 +19,10 @@ USE_GNOME= gtk12
GNU_CONFIGURE= yes
USE_AUTOCONF= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/libnids/Makefile b/net/libnids/Makefile
index e8dce58e212b..e134ff12c723 100644
--- a/net/libnids/Makefile
+++ b/net/libnids/Makefile
@@ -20,9 +20,15 @@ GNU_CONFIGURE= yes
MAN3= libnids.3
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
do-install:
${INSTALL_DATA} ${WRKSRC}/src/nids.h ${PREFIX}/include
${INSTALL_DATA} ${WRKSRC}/src/libnids.a ${PREFIX}/lib
${INSTALL_DATA} ${WRKSRC}/src/libnids.3 ${PREFIX}/man/man3
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/tvark/Makefile b/net/tvark/Makefile
index 2a8f056cc220..899d37ae6fe0 100644
--- a/net/tvark/Makefile
+++ b/net/tvark/Makefile
@@ -19,9 +19,15 @@ LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
USE_X_PREFIX= yes
USE_GNOME= gtk12
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
post-patch:
@${PERL} -pi -e "s|/usr/local/bin|${PREFIX}/bin|" ${WRKSRC}/Makefile
@${PERL} -pi -e "s|gtk-config|${GTK_CONFIG}|" ${WRKSRC}/Makefile
@${PERL} -pi -e "s|-ggdb|${CFLAGS}|" ${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>