summaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorJosh Paetzel <jpaetzel@FreeBSD.org>2010-12-17 17:40:21 +0000
committerJosh Paetzel <jpaetzel@FreeBSD.org>2010-12-17 17:40:21 +0000
commit2a9499b688779609d7665cf62b4471fe62926a69 (patch)
tree91bc5fc7f1c3d0b713e5b4e6345bbebdfcff9c7c /net
parent242b83883020b5ddf2150675a77af7997090395a (diff)
downloadfreebsd-ports-2a9499b688779609d7665cf62b4471fe62926a69.zip
Add missing files.
PR: ports/153191 Submitted by: Richard Neese <r.neese@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/freeswitch-core/Makefile1
-rw-r--r--net/freeswitch-core/files/patch-libs-freetdm-Makefile.am9
-rw-r--r--net/freeswitch-core/files/patch-libs-freetdm-mod_freetdm-Makefile.in12
-rw-r--r--net/freeswitch-core/files/patch-libs-freetdm-src-ftmod-ftmod_zt-ftmod_zt.c73
4 files changed, 95 insertions, 0 deletions
diff --git a/net/freeswitch-core/Makefile b/net/freeswitch-core/Makefile
index 1268722c2dee..ca3cc13b8b02 100644
--- a/net/freeswitch-core/Makefile
+++ b/net/freeswitch-core/Makefile
@@ -7,6 +7,7 @@
PORTNAME= freeswitch-core
PORTVERSION= 201044
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.secure-computing.net/pub/freeswitch/ \
ftp://ftp2.secure-computing.net/pub/freeswitch/ \
diff --git a/net/freeswitch-core/files/patch-libs-freetdm-Makefile.am b/net/freeswitch-core/files/patch-libs-freetdm-Makefile.am
new file mode 100644
index 000000000000..818ce765eeca
--- /dev/null
+++ b/net/freeswitch-core/files/patch-libs-freetdm-Makefile.am
@@ -0,0 +1,9 @@
+--- libs/freetdm/Makefile.am
++++ libs/freetdm/Makefile.am
+@@ -320,5 +320,5 @@ mod_freetdm-clean:
+ install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(PREFIX)
+ $(mkinstalldirs) $(DESTDIR)@confdir@
+- @[ -f "$(DESTDIR)@confdir@/freetdm.conf" ] || ( cp conf/*.conf $(DESTDIR)@confdir@)
++ @for i in conf/*.conf; do cp $$i $$i.sample; done; cp -f conf/*.conf.sample $(DESTDIR)@confdir@
+ @echo FreeTDM Installed
diff --git a/net/freeswitch-core/files/patch-libs-freetdm-mod_freetdm-Makefile.in b/net/freeswitch-core/files/patch-libs-freetdm-mod_freetdm-Makefile.in
new file mode 100644
index 000000000000..cf0e4a1840e8
--- /dev/null
+++ b/net/freeswitch-core/files/patch-libs-freetdm-mod_freetdm-Makefile.in
@@ -0,0 +1,12 @@
+--- libs/freetdm/mod_freetdm/Makefile.in
++++ libs/freetdm/mod_freetdm/Makefile.in
+@@ -15,8 +15,7 @@ $(FTLA): $(FT_DIR)/.update
+
+ local_install:
+ cd $(FT_DIR) && $(MAKE) install
+- [ -f $(DESTDIR)@confdir@/autoload_configs/freetdm.conf.xml ] || cp -f $(FT_DIR)/conf/freetdm.conf.xml $(DESTDIR)@confdir@/autoload_configs
+-
++ @for i in $(FT_DIR)/conf/*.xml; do cp $$i $$i.sample; done; cp -f $(FT_DIR)/conf/*.xml.sample $(DESTDIR)@confdir@/autoload_configs
+ local_clean:
+ cd $(FT_DIR) && $(MAKE) clean
+
diff --git a/net/freeswitch-core/files/patch-libs-freetdm-src-ftmod-ftmod_zt-ftmod_zt.c b/net/freeswitch-core/files/patch-libs-freetdm-src-ftmod-ftmod_zt-ftmod_zt.c
new file mode 100644
index 000000000000..42c498acfc7b
--- /dev/null
+++ b/net/freeswitch-core/files/patch-libs-freetdm-src-ftmod-ftmod_zt-ftmod_zt.c
@@ -0,0 +1,73 @@
+--- libs/freetdm/src/ftmod/ftmod_zt/ftmod_zt.c
++++ libs/freetdm/src/ftmod/ftmod_zt/ftmod_zt.c
+@@ -52,38 +52,38 @@ static struct {
+ * \brief General IOCTL codes
+ */
+ struct ioctl_codes {
+- int GET_BLOCKSIZE;
+- int SET_BLOCKSIZE;
+- int FLUSH;
+- int SYNC;
+- int GET_PARAMS;
+- int SET_PARAMS;
+- int HOOK;
+- int GETEVENT;
+- int IOMUX;
+- int SPANSTAT;
+- int MAINT;
+- int GETCONF;
+- int SETCONF;
+- int CONFLINK;
+- int CONFDIAG;
+- int GETGAINS;
+- int SETGAINS;
+- int SPANCONFIG;
+- int CHANCONFIG;
+- int SET_BUFINFO;
+- int GET_BUFINFO;
+- int AUDIOMODE;
+- int ECHOCANCEL;
+- int HDLCRAWMODE;
+- int HDLCFCSMODE;
+- int SPECIFY;
+- int SETLAW;
+- int SETLINEAR;
+- int GETCONFMUTE;
+- int ECHOTRAIN;
+- int SETTXBITS;
+- int GETRXBITS;
++ long GET_BLOCKSIZE;
++ long SET_BLOCKSIZE;
++ long FLUSH;
++ long SYNC;
++ long GET_PARAMS;
++ long SET_PARAMS;
++ long HOOK;
++ long GETEVENT;
++ long IOMUX;
++ long SPANSTAT;
++ long MAINT;
++ long GETCONF;
++ long SETCONF;
++ long CONFLINK;
++ long CONFDIAG;
++ long GETGAINS;
++ long SETGAINS;
++ long SPANCONFIG;
++ long CHANCONFIG;
++ long SET_BUFINFO;
++ long GET_BUFINFO;
++ long AUDIOMODE;
++ long ECHOCANCEL;
++ long HDLCRAWMODE;
++ long HDLCFCSMODE;
++ long SPECIFY;
++ long SETLAW;
++ long SETLINEAR;
++ long GETCONFMUTE;
++ long ECHOTRAIN;
++ long SETTXBITS;
++ long GETRXBITS;
+ };
+
+ /**