summaryrefslogtreecommitdiff
path: root/net/tcserver/Makefile
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>1999-11-10 23:53:56 +0000
committerChris Piazza <cpiazza@FreeBSD.org>1999-11-10 23:53:56 +0000
commitb7965a9c73ea957f5737d10e5c788b527dac5a56 (patch)
tree68a797c7ffc2c9506ccdf9241887911287d0fb68 /net/tcserver/Makefile
parent40fad679df9cfed8bf4e41cf0496375e148585f2 (diff)
downloadfreebsd-ports-b7965a9c73ea957f5737d10e5c788b527dac5a56.zip
Streaming Quicktime server for FreeBSD.
Elsa is a standards-based Quicktime server based on the RTSP (RFC 2326) and RTP (RFC 1889) standards. This version is a beta which is currently free for non-commercial use. The server can serve media from QuickTime 4.0 "hinted" files which transparently support multiple media formats (e.g. QuickTime, AVI, MP3, WAV, AU, etc.). PR: 14172 Submitted by: Chris D. Faulhaber <jedgar@fxp.org>
Diffstat (limited to 'net/tcserver/Makefile')
-rw-r--r--net/tcserver/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/net/tcserver/Makefile b/net/tcserver/Makefile
new file mode 100644
index 000000000000..406fe5828e3c
--- /dev/null
+++ b/net/tcserver/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: elsa
+# Version required: 1.0
+# Date created: 06 October 1999
+# Whom: Chris D. Faulhaber <jedgar@fxp.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= elsa-freebsd_x86
+PKGNAME= elsa-1.0b
+CATEGORIES= net
+MASTER_SITES= ""
+
+MAINTAINER= jedgar@fxp.org
+
+ONLY_FOR_ARCHS= i386
+RESTRICTED= "LIC: redistribution not allowed"
+
+WRKSRC= ${WRKDIR}/ELSA-1_0b-016-freebsd_x86
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE='The source to this port may not be automatically fetched due to licensing restrictions. You MUST fetch the source manually after registering at: http://streaming.entera.com/orderform.shtml Once ${DISTFILES} has been downloaded, move it to ${DISTDIR} and then restart this build.'
+.endif
+
+do-configure:
+ @${MV} ${WRKSRC}/elsa.cfg ${WRKSRC}/elsa.cfg.orig
+ @${SED} -e 's|CHANGE_ME|${PREFIX}/share/elsa|' \
+ < ${WRKSRC}/elsa.cfg.orig > ${WRKSRC}/elsa.cfg
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/elsa/content
+ ${MKDIR} /var/log/elsa
+ ${INSTALL_SCRIPT} ${WRKSRC}/elsa ${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/elsa.cfg ${PREFIX}/etc
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${PREFIX}/share/elsa
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/elsa
+ ${INSTALL_DATA} ${WRKSRC}/content/elsa-test.mov ${PREFIX}/share/elsa/content
+
+post-install:
+ @if [ ! -f ${PREFIX}/etc/rc.d/elsa.sh ]; then \
+ ${ECHO} "Installing ${PREFIX}/etc/rc.d/elsa.sh startup file."; \
+ ${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/elsa.sh; \
+ ${ECHO} "[ -x ${PREFIX}/sbin/elsa ] && ${PREFIX}/sbin/elsa -d ${PREFIX}/etc > /dev/null & && ${ECHO} -n ' elsa'" >> ${PREFIX}/etc/rc.d/elsa.sh; \
+ ${CHMOD} 555 ${PREFIX}/etc/rc.d/elsa.sh; \
+ fi
+
+.include <bsd.port.post.mk>