summaryrefslogtreecommitdiff
path: root/net/p5-URI-OpenURL
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-02-18 10:01:38 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-02-18 10:01:38 +0000
commiteb58cbcef8191d932c3ddd6a7a9448f85115356c (patch)
treea56ae8a657b6af28f40e08803bbd1630ce8fbf8a /net/p5-URI-OpenURL
parentc7855a37ddda7bb9074aef460004714ccec6dcaa (diff)
downloadfreebsd-ports-eb58cbcef8191d932c3ddd6a7a9448f85115356c.zip
Adding port net/p5-URI-OpenURL which implements (at least in part) the OpenURL encoding standard.
Committed by: aaron Approved by: tobez (implicit)
Diffstat (limited to 'net/p5-URI-OpenURL')
-rw-r--r--net/p5-URI-OpenURL/Makefile31
-rw-r--r--net/p5-URI-OpenURL/distinfo3
-rw-r--r--net/p5-URI-OpenURL/pkg-descr22
-rw-r--r--net/p5-URI-OpenURL/pkg-plist5
4 files changed, 61 insertions, 0 deletions
diff --git a/net/p5-URI-OpenURL/Makefile b/net/p5-URI-OpenURL/Makefile
new file mode 100644
index 000000000000..9cefff39f424
--- /dev/null
+++ b/net/p5-URI-OpenURL/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: URI-OpenURL
+# Date created: 18 Feb 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= URI-OpenURL
+PORTVERSION= 0.4.6
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= URI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Parse and construct OpenURL's (NISO Z39.88-2004)
+
+BUILD_DEPENDS= ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+MAN3= URI::OpenURL.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= uses the utf8 pragma and therefore requires at least Perl5.8
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-URI-OpenURL/distinfo b/net/p5-URI-OpenURL/distinfo
new file mode 100644
index 000000000000..39fe684e360f
--- /dev/null
+++ b/net/p5-URI-OpenURL/distinfo
@@ -0,0 +1,3 @@
+MD5 (URI-OpenURL-0.4.6.tar.gz) = b64093ce6aa75b092cc907d3852d007f
+SHA256 (URI-OpenURL-0.4.6.tar.gz) = 35b4ef83a81fa5cceba47de6a7f9620bd4bde7a1b77b5385e0d19c2449b3ad12
+SIZE (URI-OpenURL-0.4.6.tar.gz) = 8315
diff --git a/net/p5-URI-OpenURL/pkg-descr b/net/p5-URI-OpenURL/pkg-descr
new file mode 100644
index 000000000000..6e3cc7607be6
--- /dev/null
+++ b/net/p5-URI-OpenURL/pkg-descr
@@ -0,0 +1,22 @@
+This module provides an implementation of OpenURLs encoded as URIs
+(Key/Encoded-Value (KEV) Format), this forms only a part of the OpenURL
+spec. It does not check that OpenURLs constructed are sane according to
+the OpenURL specification (to a large extent sanity will depend on the
+community of use).
+
+From the implementation guidelines:
+
+The description of a referenced resource, and the descriptions of the
+associated resources that comprise the context of the reference, bundled
+together are called a ContextObject. It is a ContextObject that is
+transported when a user makes a request by clicking a link. A KEV OpenURL
+may contain only one ContextObject.
+
+The ContextObject may contain up to six Entities. One of these, the
+Referent, conveys information about the referenced item. It must always be
+included in a ContextObject. The other five entities - ReferringEntity,
+Requester, Resolver, ServiceType and Referrer - hold information about the
+context of the reference and are optional.
+
+WWW: http://search.cpan.org/dist/URI-OpenURL
+Author: Tim Brody <tdb01r@ecs.soton.ac.uk>
diff --git a/net/p5-URI-OpenURL/pkg-plist b/net/p5-URI-OpenURL/pkg-plist
new file mode 100644
index 000000000000..2fe0c6da063e
--- /dev/null
+++ b/net/p5-URI-OpenURL/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/URI/OpenURL.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/URI/OpenURL/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/URI/OpenURL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/URI
+@dirrmtry %%SITE_PERL%%/URI