summaryrefslogtreecommitdiff
path: root/net/freerdp
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-08-27 18:12:35 +0000
committerSteve Wills <swills@FreeBSD.org>2018-08-27 18:12:35 +0000
commit1c02d9877b8315cc14b3ac0cbf14fdf2cced8978 (patch)
tree2c9ac756d9ccb22043b6ae19fd20b475d023020d /net/freerdp
parentb89426e44d06f365f9b0989253811ce1242597d6 (diff)
downloadfreebsd-ports-1c02d9877b8315cc14b3ac0cbf14fdf2cced8978.zip
net/freerdp: Fix build failure
PR: 230954 Submitted by: kevans (maintainer) Reported by: rozhuk.im@gmail.com
Diffstat (limited to 'net/freerdp')
-rw-r--r--net/freerdp/Makefile5
-rw-r--r--net/freerdp/files/patch-CMakeLists.txt14
2 files changed, 3 insertions, 16 deletions
diff --git a/net/freerdp/Makefile b/net/freerdp/Makefile
index 4f87d6ffcc26..33cadedd803b 100644
--- a/net/freerdp/Makefile
+++ b/net/freerdp/Makefile
@@ -13,6 +13,8 @@ COMMENT= Free implementation of Remote Desktop Protocol
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
+LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim
+
USES= alias cmake:outsource compiler:c++11-lib cpe gettext localbase pathfix pkgconfig ssl
USE_LDCONFIG= yes
CPE_VENDOR= freerdp_project
@@ -73,8 +75,7 @@ SSE_CMAKE_BOOL= WITH_SSE2
WAYLAND_DESC= Build FreeRDP Wayland client
WAYLAND_BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:multimedia/v4l_compat
-WAYLAND_LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
- libwayland-client.so:graphics/wayland \
+WAYLAND_LIB_DEPENDS= libwayland-client.so:graphics/wayland \
libwayland-cursor.so:graphics/wayland \
libxkbcommon.so:x11/libxkbcommon
WAYLAND_CMAKE_BOOL= WITH_WAYLAND
diff --git a/net/freerdp/files/patch-CMakeLists.txt b/net/freerdp/files/patch-CMakeLists.txt
deleted file mode 100644
index 2766465d4df8..000000000000
--- a/net/freerdp/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
---- CMakeLists.txt.orig 2016-11-24 13:19:47 UTC
-+++ CMakeLists.txt
-@@ -156,6 +156,11 @@ if(${CMAKE_SYSTEM_NAME} MATCHES "BSD")
- endif()
- endif()
-
-+if(${CMAKE_SYSTEM_NAME} MATCHES "DragonFly")
-+ set(BSD TRUE)
-+ set(FREEBSD TRUE)
-+endif()
-+
- # Configure MSVC Runtime
- if(MSVC)
- include(MSVCRuntime)