summaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-07-08 22:29:18 +0200
committerAdriaan de Groot <adridg@FreeBSD.org>2021-07-08 22:43:17 +0200
commitc47397b58e8a612f3bbe987b97fb40665b70df53 (patch)
tree8cda1ca64675c0091e895e987c6fa8e4943acb16 /net-p2p
parentbf089b31aaf7c53237fc8ee1a8c988fb10be5767 (diff)
downloadfreebsd-ports-c47397b58e8a612f3bbe987b97fb40665b70df53.zip
net-p2p/*ktorrent: tidy up dependencies
- Boost is a build-dep (wasn't listed explicitly for ktorrent, because it was dragged in implicitly by other KDE frameworks), - ECM is a build-dep (either listed as runtime-dep, or missing and implicit from being a runtime-dep for something else). While here, remove comment about keeping things in sync which is no longer relevant since ktorrent and libktorrent are part of the KDE release service.
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/Makefile16
-rw-r--r--net-p2p/libktorrent/Makefile14
2 files changed, 14 insertions, 16 deletions
diff --git a/net-p2p/ktorrent/Makefile b/net-p2p/ktorrent/Makefile
index 9b8c8ffd6758..3065b1bca206 100644
--- a/net-p2p/ktorrent/Makefile
+++ b/net-p2p/ktorrent/Makefile
@@ -1,33 +1,33 @@
PORTNAME= ktorrent
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-p2p kde kde-applications
-# Since libktorrent is released with ktorrent, it lives in a
-# strange download directory; keep this in-sync with net-p2p/libktorrent.
-
MAINTAINER= kde@FreeBSD.org
COMMENT= BitTorrent client for KDE
CONFLICTS_BUILD= libtorrent
-USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
-
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/concept_check.hpp:devel/boost-libs
LIB_DEPENDS= libKF5Torrent.so:net-p2p/libktorrent \
libgcrypt.so:security/libgcrypt \
libgmp.so:math/gmp \
libtag.so:audio/taglib
+
+USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= archive auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons dnssd i18n iconthemes itemviews \
jobwidgets kcmutils kio kross notifications \
notifyconfig parts plotting service \
solid sonnet syndication textwidgets widgetsaddons \
- windowsystem xmlgui
+ windowsystem xmlgui \
+ ecm_build
USE_QT= concurrent core dbus gui network phonon4 script widgets xml \
buildtools_build qmake_build
-OPTIONS_DEFINE= DOCS WORKSPACE
+OPTIONS_DEFINE= DOCS WORKSPACE
OPTIONS_DEFAULT= WORKSPACE
-OPTIONS_SUB= yes
+OPTIONS_SUB= yes
WORKSPACE_USE= KDE=plasma-workspace
WORKSPACE_DESC= Shutdown on completion support
diff --git a/net-p2p/libktorrent/Makefile b/net-p2p/libktorrent/Makefile
index b47d3c710cd9..2c2c0fda88b9 100644
--- a/net-p2p/libktorrent/Makefile
+++ b/net-p2p/libktorrent/Makefile
@@ -1,23 +1,21 @@
PORTNAME= libktorrent
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= net-p2p kde kde-applications
-# Since libktorrent is released with ktorrent, it lives in a
-# strange download directory; keep this in-sync with net-p2p/ktorrent.
-
MAINTAINER= kde@FreeBSD.org
COMMENT= Torrent library from KTorrent project
BUILD_DEPENDS= ${LOCALBASE}/include/boost/concept_check.hpp:devel/boost-libs
-
LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
libgmp.so:math/gmp
USES= cmake compiler:c++11-lang gettext kde:5 qca qt:5 tar:xz
-USE_KDE= archive completion config coreaddons crash ecm i18n \
- jobwidgets kio service solid widgetsaddons
-USE_QT= core gui network testlib xml \
- buildtools_build qmake_build
+USE_KDE= archive completion config coreaddons crash i18n \
+ jobwidgets kio service solid widgetsaddons \
+ ecm_build
+USE_QT= core gui network xml \
+ buildtools_build qmake_build testlib_build
OPTIONS_DEFINE= DOCS