summaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-01-26 03:25:32 +0800
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-01-26 03:51:16 +0800
commitb120a15fb70ee9eea782409e6d3a4e789e258828 (patch)
tree74ed4401ee8e702351f1653525044b71f830f40f /net-p2p
parentccfbdfbdffb7d502026a2c3b1bf77aed96127211 (diff)
downloadfreebsd-ports-b120a15fb70ee9eea782409e6d3a4e789e258828.zip
net-p2p/py-transmission-rpc: Allow build with py-typing-extensions 4.0.1
Reference: https://github.com/Trim21/transmission-rpc/commit/af38c4faf685cda70ef6643c018a1408318ecbf8
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/py-transmission-rpc/Makefile2
-rw-r--r--net-p2p/py-transmission-rpc/files/patch-setup.py11
2 files changed, 12 insertions, 1 deletions
diff --git a/net-p2p/py-transmission-rpc/Makefile b/net-p2p/py-transmission-rpc/Makefile
index 7d4921f826cd..44991223629f 100644
--- a/net-p2p/py-transmission-rpc/Makefile
+++ b/net-p2p/py-transmission-rpc/Makefile
@@ -10,7 +10,7 @@ COMMENT= Python module for Transmission bittorent client RPC protocol
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=3.7.4.2<4.0.0.0:devel/py-typing-extensions@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=3.7.4.2<4.0.2.0:devel/py-typing-extensions@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.23.0<3.0.0:www/py-requests@${PY_FLAVOR}
USES= python:3.6+
diff --git a/net-p2p/py-transmission-rpc/files/patch-setup.py b/net-p2p/py-transmission-rpc/files/patch-setup.py
new file mode 100644
index 000000000000..dbd71436462f
--- /dev/null
+++ b/net-p2p/py-transmission-rpc/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2021-09-29 06:26:44 UTC
++++ setup.py
+@@ -8,7 +8,7 @@ package_data = \
+ {'': ['*']}
+
+ install_requires = \
+-['requests>=2.23.0,<3.0.0', 'typing_extensions>=3.7.4.2,<4.0.0.0']
++['requests>=2.23.0,<3.0.0', 'typing_extensions>=3.7.4.2,<4.0.2.0']
+
+ extras_require = \
+ {'docs': ['sphinx==4.2.0', 'sphinx-rtd-theme==1.0.0']}