summaryrefslogtreecommitdiff
path: root/net-p2p/xmrig
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2020-11-19 17:43:47 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2020-11-19 17:43:47 +0000
commit6d3474f51345c2394a81b74e7d05dc0e798be81b (patch)
tree8641669d9b01066a8425bdf366425f8ae6cc103f /net-p2p/xmrig
parente5fd1ed281755236001bdc7d644d78662e79834f (diff)
downloadfreebsd-ports-6d3474f51345c2394a81b74e7d05dc0e798be81b.zip
Use options helpers for cmake options. While here pacify portfmt/portclippy.
Diffstat (limited to 'net-p2p/xmrig')
-rw-r--r--net-p2p/xmrig/Makefile16
1 files changed, 4 insertions, 12 deletions
diff --git a/net-p2p/xmrig/Makefile b/net-p2p/xmrig/Makefile
index 9b19cd073c36..d65341c51261 100644
--- a/net-p2p/xmrig/Makefile
+++ b/net-p2p/xmrig/Makefile
@@ -4,6 +4,7 @@
PORTNAME= xmrig
PORTVERSION= 6.5.3
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= net-p2p
MAINTAINER= ehaupt@FreeBSD.org
@@ -32,25 +33,16 @@ HWLOC_DESC= Portable hardware locality
MICROHTTPD_DESC= Build with libmicrohttpd support
HWLOC_LIB_DEPENDS+= libhwloc.so:devel/hwloc
+HWLOC_CMAKE_OFF= -DWITH_HWLOC=OFF
MICROHTTPD_LIB_DEPENDS+= libmicrohttpd.so:www/libmicrohttpd \
libuv.so:devel/libuv
+MICROHTTPD_CMAKE_OFF= -DWITH_HTTPD=OFF
STATIC_PREVENTS= HWLOC MICROHTTPD
STATIC_PREVENTS_MSG= hwloc and libmicrohttpd support cannot be built static
STATIC_BUILD_DEPENDS+= ${LOCALBASE}/lib/libuv.a:devel/libuv
-
-post-patch-HWLOC-off:
- @${REINPLACE_CMD} -e 's|\(.*WITH_HWLOC.*\)\(ON\)|\1OFF|' \
- ${WRKSRC}/CMakeLists.txt
-
-post-patch-MICROHTTPD-off:
- @${REINPLACE_CMD} -e 's|\(.*WITH_HTTPD.*\)\(ON\)|\1OFF|' \
- ${WRKSRC}/CMakeLists.txt
-
-post-patch-STATIC-on:
- @${REINPLACE_CMD} -e 's|\(.*BUILD_STATIC.*\)\(OFF\)|\1ON|' \
- ${WRKSRC}/CMakeLists.txt
+STATIC_CMAKE_ON= -DBUILD_STATIC=ON
do-install:
${INSTALL_PROGRAM} ${WRKDIR}/.build/${PORTNAME} ${STAGEDIR}${PREFIX}/bin