summaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2020-12-04 17:57:32 +0000
committerMikael Urankar <mikael@FreeBSD.org>2020-12-04 17:57:32 +0000
commit7ae624bdafc911d45d24f242cafd6b2d79ad6073 (patch)
treef240180e77289219b86b0fe938ccb7cc4bdbdf7c /net-mgmt
parent08dc2a15fdef0bd61ffe80e77f24976034f48729 (diff)
downloadfreebsd-ports-7ae624bdafc911d45d24f242cafd6b2d79ad6073.zip
net-mgmt/zabbix52-agent: Add support for Modbus items
PR: 251423 Submitted by: Christian Ullrich Approved by: pg@pakhom.spb.ru (maintainer)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/zabbix52-agent/Makefile2
-rw-r--r--net-mgmt/zabbix52-server/Makefile4
2 files changed, 5 insertions, 1 deletions
diff --git a/net-mgmt/zabbix52-agent/Makefile b/net-mgmt/zabbix52-agent/Makefile
index f970aa3e783a..a42c35184c9b 100644
--- a/net-mgmt/zabbix52-agent/Makefile
+++ b/net-mgmt/zabbix52-agent/Makefile
@@ -8,7 +8,7 @@ PKGNAMESUFFIX= -agent
MASTERDIR= ${.CURDIR}/../zabbix52-server
PLIST= ${PKGDIR}/pkg-plist.agent
-OPTIONS_DEFINE= CURL IPV6
+OPTIONS_DEFINE= CURL IPV6 MODBUS
OPTIONS_DEFAULT= CURL OPENSSL
.include "${MASTERDIR}/Makefile"
diff --git a/net-mgmt/zabbix52-server/Makefile b/net-mgmt/zabbix52-server/Makefile
index 455af7f1fad4..d325dd8f6124 100644
--- a/net-mgmt/zabbix52-server/Makefile
+++ b/net-mgmt/zabbix52-server/Makefile
@@ -128,6 +128,10 @@ NMAP_RUN_DEPENDS= nmap:security/nmap \
LIBXML2_CONFIGURE_WITH= libxml2=${LOCALBASE}
LIBXML2_LIB_DEPENDS= libxml2.so:textproc/libxml2
+MODBUS_DESC= Support for Modbus checks
+MODBUS_CONFIGURE_WITH= libmodbus
+MODBUS_LIB_DEPENDS= libmodbus.so:comms/libmodbus
+
OPENSSL_CONFIGURE_WITH= openssl
OPENSSL_USES= ssl
OPENSSL_VARS= BROKEN_SSL="libressl libressl-devel" \