summaryrefslogtreecommitdiff
path: root/net-mgmt/phpip
diff options
context:
space:
mode:
authorBabak Farrokhi <farrokhi@FreeBSD.org>2006-11-08 20:22:54 +0000
committerBabak Farrokhi <farrokhi@FreeBSD.org>2006-11-08 20:22:54 +0000
commitb559a8c73de17b9428f4a9c4a1f642a2636ab12c (patch)
tree3e982ddf9707623923f4fe72c7e09556615c5b0e /net-mgmt/phpip
parent4864009aa47e7eb230207936e05245c01faa4118 (diff)
downloadfreebsd-ports-b559a8c73de17b9428f4a9c4a1f642a2636ab12c.zip
phpIP Management is a complete IPv4 IPAM (IP address management) suite, built to handle the complexity of managing today's IP address space. phpIP Management was built to scale and address the full lifecycle of IP address space using techniques that are not administratively intensive.
PR: ports/104886 Submitted by: self Approved by: miwi (mentor)
Diffstat (limited to 'net-mgmt/phpip')
-rw-r--r--net-mgmt/phpip/Makefile32
-rw-r--r--net-mgmt/phpip/distinfo3
-rw-r--r--net-mgmt/phpip/pkg-descr11
-rw-r--r--net-mgmt/phpip/pkg-plist104
4 files changed, 150 insertions, 0 deletions
diff --git a/net-mgmt/phpip/Makefile b/net-mgmt/phpip/Makefile
new file mode 100644
index 000000000000..0c1499abb0a8
--- /dev/null
+++ b/net-mgmt/phpip/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: phpip
+# Date created: 2006-10-28
+# Whom: Babak Farrokhi <babak@farrokhi.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= phpip
+PORTVERSION= 4.3.${SNAPSHOT}
+CATEGORIES= www net-mgmt
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= phpip
+DISTNAME= ${PORTNAME}-4.3-build-${SNAPSHOT}
+
+MAINTAINER= farrokhi@FreeBSD.org
+COMMENT= A complete IPv4 IPAM (IP address management) suite
+
+SNAPSHOT= 200610162352
+NO_BUILD= YES
+USE_PHP= mysql
+WANT_PHP_WEB= YES
+
+PHPIP?= www/phpip
+PLIST_SUB+= PHPIP=${PHPIP}
+
+do-install:
+ @${MKDIR} ${PREFIX}/${PHPIP}
+ @${CP} -R ${WRKSRC}/ ${PREFIX}/${PHPIP}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${PHPIP}
+ @${CHMOD} -R 755 ${PREFIX}/${PHPIP}
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/phpip/distinfo b/net-mgmt/phpip/distinfo
new file mode 100644
index 000000000000..f47263ab6866
--- /dev/null
+++ b/net-mgmt/phpip/distinfo
@@ -0,0 +1,3 @@
+MD5 (phpip-4.3-build-200610162352.tar.gz) = d8954d0cabe5d24b343826c62a965b67
+SHA256 (phpip-4.3-build-200610162352.tar.gz) = 9aaf8cd14e28d585e829ae8975c3550e0dfa9a169eea7490e5d4d26e989e552d
+SIZE (phpip-4.3-build-200610162352.tar.gz) = 130503
diff --git a/net-mgmt/phpip/pkg-descr b/net-mgmt/phpip/pkg-descr
new file mode 100644
index 000000000000..793b7aa33101
--- /dev/null
+++ b/net-mgmt/phpip/pkg-descr
@@ -0,0 +1,11 @@
+phpIP Management is a complete IPv4 IPAM (IP address management)
+suite, built to handle the complexity of managing today's
+IP address space.
+phpIP Management was built to scale and address the full
+lifecycle of IP address space using techniques that are not
+administratively intensive.
+
+WWW: http://www.phpip.net/
+
+- Babak Farrokhi
+babak@farrokhi.net
diff --git a/net-mgmt/phpip/pkg-plist b/net-mgmt/phpip/pkg-plist
new file mode 100644
index 000000000000..ffacf9d87eab
--- /dev/null
+++ b/net-mgmt/phpip/pkg-plist
@@ -0,0 +1,104 @@
+%%PHPIP%%/COPYING
+%%PHPIP%%/ChangeLog
+%%PHPIP%%/INSTALL
+%%PHPIP%%/Net/IPv4.php
+%%PHPIP%%/Net/PEAR.php
+%%PHPIP%%/Net/index.php
+%%PHPIP%%/README
+%%PHPIP%%/TODO
+%%PHPIP%%/boxes/box_CidrMenu.php
+%%PHPIP%%/boxes/box_help_links.php
+%%PHPIP%%/boxes/box_install_links.php
+%%PHPIP%%/boxes/box_main_links.php
+%%PHPIP%%/boxes/index.php
+%%PHPIP%%/check_option.php
+%%PHPIP%%/cidr_add.php
+%%PHPIP%%/cidr_desc.php
+%%PHPIP%%/cidr_remove.php
+%%PHPIP%%/classes/clsEmail.php
+%%PHPIP%%/classes/clsFunctions.php
+%%PHPIP%%/classes/clsMetaContent.php
+%%PHPIP%%/classes/clsParseXML.php
+%%PHPIP%%/classes/index.php
+%%PHPIP%%/classes/xPandMenu.js
+%%PHPIP%%/classes/xPandMenu.php
+%%PHPIP%%/common.php
+%%PHPIP%%/console.php
+%%PHPIP%%/css/bg.gif
+%%PHPIP%%/css/default.css
+%%PHPIP%%/css/green.css
+%%PHPIP%%/css/index.php
+%%PHPIP%%/css/red.css
+%%PHPIP%%/css/white.css
+%%PHPIP%%/css/xPandMenu.css
+%%PHPIP%%/default.php
+%%PHPIP%%/defaultlayout.php
+%%PHPIP%%/display.php
+%%PHPIP%%/group_add.php
+%%PHPIP%%/group_remove.php
+%%PHPIP%%/group_update.php
+%%PHPIP%%/help.php
+%%PHPIP%%/helplayout.php
+%%PHPIP%%/i/4.gif
+%%PHPIP%%/i/add.jpg
+%%PHPIP%%/i/arrow.gif
+%%PHPIP%%/i/box_closed.gif
+%%PHPIP%%/i/box_open.gif
+%%PHPIP%%/i/doc.gif
+%%PHPIP%%/i/favicon.ico
+%%PHPIP%%/i/folderclose.gif
+%%PHPIP%%/i/folderopen.gif
+%%PHPIP%%/i/index.php
+%%PHPIP%%/i/install.jpg
+%%PHPIP%%/i/l1.jpg
+%%PHPIP%%/i/l11.jpg
+%%PHPIP%%/i/l2.jpg
+%%PHPIP%%/i/l3.jpg
+%%PHPIP%%/i/l4.jpg
+%%PHPIP%%/i/l5.jpg
+%%PHPIP%%/i/lb.gif
+%%PHPIP%%/i/ldiv.gif
+%%PHPIP%%/i/login.png
+%%PHPIP%%/i/mark-cancel.gif
+%%PHPIP%%/i/mark-ok.gif
+%%PHPIP%%/i/remove.png
+%%PHPIP%%/i/reset.png
+%%PHPIP%%/i/spacer.gif
+%%PHPIP%%/i/tn_login.jpg
+%%PHPIP%%/i/top1.jpg
+%%PHPIP%%/i/top1bg.jpg
+%%PHPIP%%/i/top2bg.gif
+%%PHPIP%%/i/top3.gif
+%%PHPIP%%/i/top3bg.gif
+%%PHPIP%%/i/vline.gif
+%%PHPIP%%/includes/index.php
+%%PHPIP%%/includes/install.database.php
+%%PHPIP%%/includes/session.php
+%%PHPIP%%/index.php
+%%PHPIP%%/install.php
+%%PHPIP%%/installlayout.php
+%%PHPIP%%/iplayout.php
+%%PHPIP%%/layout.php
+%%PHPIP%%/ldap_management.php
+%%PHPIP%%/login.php
+%%PHPIP%%/loginlayout.php
+%%PHPIP%%/logout.php
+%%PHPIP%%/preference.php
+%%PHPIP%%/prefix_add.php
+%%PHPIP%%/prefix_desc.php
+%%PHPIP%%/prefix_remove.php
+%%PHPIP%%/print.php
+%%PHPIP%%/search.php
+%%PHPIP%%/sql/Upgrade_3.1_to_4.2.sql
+%%PHPIP%%/sql/index.php
+%%PHPIP%%/sql/phpip.sql
+%%PHPIP%%/subnetSummary.php
+%%PHPIP%%/user_management.php
+@dirrm %%PHPIP%%/sql
+@dirrmtry %%PHPIP%%/includes
+@dirrm %%PHPIP%%/i
+@dirrm %%PHPIP%%/css
+@dirrm %%PHPIP%%/classes
+@dirrm %%PHPIP%%/boxes
+@dirrm %%PHPIP%%/Net
+@dirrmtry %%PHPIP%%