summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2019-11-08 20:40:03 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2019-11-08 20:40:03 +0000
commitb438f1decd962604df11f646f69a886affa858b2 (patch)
treec8ac9c29261f330d88a57c7cd9bc913fa0902a9d /net-im
parent182631cc5f6701f9b863a42b07df0e4b402f7075 (diff)
downloadfreebsd-ports-b438f1decd962604df11f646f69a886affa858b2.zip
New port: net-im/beebeep
beeBEEP is a secure intra-office (LAN) chat program. It will auto- discover other beeps on the local network. There are snaps and AppImages available for Linux, so it's easy to deploy by a small team in a LAN for local encrypted chat. https://www.beebeep.net/ (Spotted on Twitter from Alan Pope, so I packaged it for FreeBSD)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/beebeep/Makefile34
-rw-r--r--net-im/beebeep/distinfo3
-rw-r--r--net-im/beebeep/pkg-descr8
4 files changed, 46 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 4e15ba582791..b43e3c433888 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -4,6 +4,7 @@
COMMENT = Instant messaging
SUBDIR += 6cord
+ SUBDIR += beebeep
SUBDIR += centerim
SUBDIR += centerim-devel
SUBDIR += chattahoochie
diff --git a/net-im/beebeep/Makefile b/net-im/beebeep/Makefile
new file mode 100644
index 000000000000..c461db0bebd4
--- /dev/null
+++ b/net-im/beebeep/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= beebeep
+DISTVERSIONPREFIX=code-
+DISTVERSION= 5.8.2
+CATEGORIES= net-im
+MASTER_SITES= SF/${PORTNAME}/Sources/
+# Weird SVN-versioned directory in the source zip
+WRKSRC= ${WRKDIR}/${PORTNAME}-code-r1352
+
+MAINTAINER= adridg@FreeBSD.org
+COMMENT= Secure office (Local-area-network) chat
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= compiler:c++17-lang pkgconfig \
+ qmake qt:5 zip
+USE_QT= core gui multimedia network widgets x11extras \
+ buildtools_build linguist_build
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${LOCALBASE}/bin ${STAGEDIR}${QT_PLUGINDIR}/
+ ${INSTALL_PROGRAM} ${WRKSRC}/test/beebeep ${STAGEDIR}${LOCALBASE}/bin/
+ ${INSTALL_LIB} ${WRKSRC}/test/libnumbertextmarker.so ${STAGEDIR}${QT_PLUGINDIR}/
+ ${INSTALL_LIB} ${WRKSRC}/test/librainbowtextmarker.so ${STAGEDIR}${QT_PLUGINDIR}/
+ ${INSTALL_LIB} ${WRKSRC}/test/libregularboldtextmarker.so ${STAGEDIR}${QT_PLUGINDIR}/
+
+PLIST_FILES= bin/beebeep \
+ lib/qt5/plugins/libnumbertextmarker.so \
+ lib/qt5/plugins/librainbowtextmarker.so \
+ lib/qt5/plugins/libregularboldtextmarker.so
+
+.include <bsd.port.mk>
diff --git a/net-im/beebeep/distinfo b/net-im/beebeep/distinfo
new file mode 100644
index 000000000000..b19093183296
--- /dev/null
+++ b/net-im/beebeep/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1573239811
+SHA256 (beebeep-code-5.8.2.zip) = eec2559d2a1bc232a8256f32b7f976a13fc63343abca1a2425ef346cc5da7a6d
+SIZE (beebeep-code-5.8.2.zip) = 7429797
diff --git a/net-im/beebeep/pkg-descr b/net-im/beebeep/pkg-descr
new file mode 100644
index 000000000000..6fdaeee521b6
--- /dev/null
+++ b/net-im/beebeep/pkg-descr
@@ -0,0 +1,8 @@
+BeeBEEP is a secure (encryption based on Rijndael Algorithm, AES)
+peer to peer office messenger. You can talk and send files with all
+your colleagues inside a local area network such of an office, home
+or internet cafe without a server. BeeBEEP works also with VPNs.
+This serverless application is indispensable in all those places
+where privacy and security an essential requirement.
+
+WWW: https://www.beebeep.net/