summaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-11-04 19:00:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-11-04 19:00:53 +0000
commit89d1bb9ab01e93b870f01933054c0acd8205ff46 (patch)
treee0f4b7d2567ee42aa9691bf31504507d0e3eaaca /multimedia
parent29439ee094406379a3bf20855d95ae8c42f20200 (diff)
downloadfreebsd-ports-89d1bb9ab01e93b870f01933054c0acd8205ff46.zip
Merge lang/qt5-qml and x11-toolkits/qt5-quick into x11-toolkits/qt5-declarative
- There was no obvious reason to split these ports, and it makes porting simpler; the set of ports using either mostly coincided. Exp-run by: antoine PR: 223687 PR: 232751
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/QtAV/Makefile4
-rw-r--r--multimedia/gstreamer1-qt/Makefile6
-rw-r--r--multimedia/kamoso/Makefile3
-rw-r--r--multimedia/kdenlive/Makefile5
-rw-r--r--multimedia/minitube/Makefile2
-rw-r--r--multimedia/mkvtoolnix/Makefile3
-rw-r--r--multimedia/qt5-multimedia/Makefile4
-rw-r--r--multimedia/shotcut/Makefile6
-rw-r--r--multimedia/webcamoid/Makefile4
-rw-r--r--multimedia/webvfx-qt5/Makefile4
10 files changed, 22 insertions, 19 deletions
diff --git a/multimedia/QtAV/Makefile b/multimedia/QtAV/Makefile
index 43aab87c2c0d..4545718a06f8 100644
--- a/multimedia/QtAV/Makefile
+++ b/multimedia/QtAV/Makefile
@@ -3,7 +3,7 @@
PORTNAME= QtAV
PORTVERSION= 1.12.0
DISTVERSIONPREFIX= v
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= multimedia
DIST_SUBDIR= KDE
@@ -18,7 +18,7 @@ LIB_DEPENDS= libass.so:multimedia/libass \
USES= qmake:outsource qt:5
USE_GL= gl
-USE_QT= core gui network opengl qml quick sql widgets \
+USE_QT= core declarative gui network opengl sql widgets \
buildtools_build qmake_build
USE_XORG= x11 xext xv
diff --git a/multimedia/gstreamer1-qt/Makefile b/multimedia/gstreamer1-qt/Makefile
index 61e789c4b7cb..030bbf59755c 100644
--- a/multimedia/gstreamer1-qt/Makefile
+++ b/multimedia/gstreamer1-qt/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gstreamer1
PORTVERSION= 1.2.0
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= multimedia
MASTER_SITES= http://gstreamer.freedesktop.org/src/qt-gstreamer/
PKGNAMESUFFIX= -${FLAVOR}
@@ -36,8 +36,8 @@ USE_QT= corelib gui opengl declarative script \
PLIST_SUB= QT4_ONLY="" QT5_ONLY="@comment "
. else
USES+= compiler:c++11-lang qt:5
-USE_QT= buildtools_build qmake_build core gui network opengl \
- qml quick testlib widgets
+USE_QT= buildtools_build qmake_build core declarative gui network opengl \
+ testlib widgets
QTVER_SUFFIX= 5
PLIST_SUB= QT4_ONLY="@comment " QT5_ONLY=""
. endif
diff --git a/multimedia/kamoso/Makefile b/multimedia/kamoso/Makefile
index f4eca119ba3d..fda3cbe7439f 100644
--- a/multimedia/kamoso/Makefile
+++ b/multimedia/kamoso/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kamoso
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= multimedia kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -15,7 +16,7 @@ USE_GSTREAMER1= yes
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons ecm i18n itemviews jobwidgets kio purpose \
service solid widgetsaddons xmlgui
-USE_QT= core dbus gui network qml quick widgets xml \
+USE_QT= core dbus declarative gui network widgets xml \
buildtools_build qmake_build
OPTIONS_DEFINE= DOCS
diff --git a/multimedia/kdenlive/Makefile b/multimedia/kdenlive/Makefile
index bca3c2bfbdff..7f67ddd696cb 100644
--- a/multimedia/kdenlive/Makefile
+++ b/multimedia/kdenlive/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kdenlive
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= multimedia kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -23,9 +24,9 @@ USE_KDE= archive attica auth bookmarks codecs completion config \
notifications notifyconfig service solid sonnet textwidgets \
widgetsaddons xmlgui \
init_run
-USE_QT= concurrent core dbus gui network xml \
+USE_QT= concurrent core dbus declarative gui network xml \
buildtools_build qmake_build \
- qml quick quickcontrols_run script svg webkit widgets
+ quickcontrols_run script svg webkit widgets
USE_XORG= x11
CFLAGS+= -I${LOCALBASE}/include # linux/input.h
CMAKE_ARGS= -DFFMPEG_SUFFIX:STRING="${FFMPEG_SUFX}"
diff --git a/multimedia/minitube/Makefile b/multimedia/minitube/Makefile
index a92fb86e377f..abd8aeac4cbb 100644
--- a/multimedia/minitube/Makefile
+++ b/multimedia/minitube/Makefile
@@ -15,7 +15,7 @@ USES= qmake qt:5
USE_GITHUB= yes
GH_ACCOUNT= flaviotordini
USE_GL= gl
-USE_QT= core dbus gui network phonon4 qml script sql widgets \
+USE_QT= core dbus declarative gui network phonon4 script sql widgets \
buildtools_build imageformats_run sql-sqlite3_run
QMAKE_ARGS= QMAKE_LRELEASE=${LRELEASE} \
DEFINES+=APP_GOOGLE_API_KEY="${MINITUBE_GOOGLE_API_KEY}"
diff --git a/multimedia/mkvtoolnix/Makefile b/multimedia/mkvtoolnix/Makefile
index 63f145437d61..52bb9ac44d31 100644
--- a/multimedia/mkvtoolnix/Makefile
+++ b/multimedia/mkvtoolnix/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mkvtoolnix
PORTVERSION= 28.2.0
+PORTREVISION= 1
CATEGORIES= multimedia audio
MASTER_SITES= http://www.bunkus.org/videotools/mkvtoolnix/sources/ \
https://mkvtoolnix.download/sources/
@@ -50,7 +51,7 @@ NLS_CONFIGURE_WITH= gettext
QT5_DESC= Build and install GUI application (Qt 5)
QT5_USES= desktop-file-utils qt:5 shared-mime-info
-QT5_USE= QT=buildtools_build,concurrent,core,gui,multimedia,network,quick,widgets
+QT5_USE= QT=buildtools_build,concurrent,core,declarative,gui,multimedia,network,widgets
QT5_CONFIGURE_ENABLE= qt
QT5_BUILD_DEPENDS= qmake:devel/qt5-qmake
QT5_LIB_DEPENDS= libcmark.so:textproc/cmark
diff --git a/multimedia/qt5-multimedia/Makefile b/multimedia/qt5-multimedia/Makefile
index 3692af97aa52..1a1e65605dea 100644
--- a/multimedia/qt5-multimedia/Makefile
+++ b/multimedia/qt5-multimedia/Makefile
@@ -2,7 +2,7 @@
PORTNAME= multimedia
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
PKGNAMEPREFIX= qt5-
@@ -15,7 +15,7 @@ USES= compiler:c++11-lang gl gnome pkgconfig qmake:norecursive \
qt-dist:5,multimedia
USE_GL= gl
USE_GNOME= glib20
-USE_QT= core gui network opengl qml quick widgets \
+USE_QT= core declarative gui network opengl widgets \
buildtools_build
USE_XORG= x11 xext xv
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
diff --git a/multimedia/shotcut/Makefile b/multimedia/shotcut/Makefile
index 6aba6de192cf..c64c3b92627c 100644
--- a/multimedia/shotcut/Makefile
+++ b/multimedia/shotcut/Makefile
@@ -3,7 +3,7 @@
PORTNAME= shotcut
PORTVERSION= ${FULLVERSION:R}
DISTVERSIONPREFIX= v
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= multimedia
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
@@ -25,9 +25,9 @@ GH_ACCOUNT= mltframework
FULLVERSION= 17.02.01
USES= pkgconfig qmake qt:5
-USE_QT= buildtools_build concurrent_build core \
+USE_QT= buildtools_build concurrent_build core declarative \
graphicaleffects_run gui multimedia network opengl \
- printsupport qml quick quickcontrols_run sql \
+ printsupport quickcontrols_run sql \
sql-sqlite3_run webkit websockets widgets x11extras xml
USE_XORG= x11
QMAKE_ARGS= ${PORTNAME:tu}_VERSION="${FULLVERSION}"
diff --git a/multimedia/webcamoid/Makefile b/multimedia/webcamoid/Makefile
index c31107d5eb45..f1e8cda20d3f 100644
--- a/multimedia/webcamoid/Makefile
+++ b/multimedia/webcamoid/Makefile
@@ -2,7 +2,7 @@
PORTNAME= webcamoid
DISTVERSION= 8.1.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= multimedia
MAINTAINER= yuri@FreeBSD.org
@@ -22,7 +22,7 @@ USE_GITHUB= yes
USE_GNOME= glib20
USE_GSTREAMER1= yes
USE_GL= gl
-USE_QT= concurrent core gui multimedia network opengl qml quick svg widgets buildtools_build quickcontrols_run
+USE_QT= concurrent core declarative gui multimedia network opengl svg widgets buildtools_build quickcontrols_run
MAKE_ENV= NOOSS=1 # NOOSS is because the OSS module attempts to use kevent on OSS devices, which is broken in the base
QMAKE_ARGS= INSTALLQMLDIR=${QT_QMLDIR} \
diff --git a/multimedia/webvfx-qt5/Makefile b/multimedia/webvfx-qt5/Makefile
index aab6e41aaf14..8e9325ff9bf0 100644
--- a/multimedia/webvfx-qt5/Makefile
+++ b/multimedia/webvfx-qt5/Makefile
@@ -2,7 +2,7 @@
PORTNAME= webvfx
DISTVERSION= 0.4.4-20160823
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= multimedia
PKGNAMESUFFIX= -qt5
@@ -19,7 +19,7 @@ GH_ACCOUNT= mltframework
GH_TAGNAME= e918ce4
USES= pkgconfig qmake qt:5
-USE_QT= 3d buildtools_build opengl qml quick webkit
+USE_QT= 3d buildtools_build declarative opengl webkit
USE_LDCONFIG= yes
PORTEXAMPLES= *