summaryrefslogtreecommitdiff
path: root/multimedia/smpeg
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2018-11-20 18:03:12 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2018-11-20 18:03:12 +0000
commit87624aab339ad670a5e6a8cc4b62c9b01074abe0 (patch)
treed0ed1f6cdace84bf88af29d676ad4c909eebcf3c /multimedia/smpeg
parentd386367ff68eb80c258fb75448eb012b41de6841 (diff)
downloadfreebsd-ports-87624aab339ad670a5e6a8cc4b62c9b01074abe0.zip
- Fix LLD for i386
- Correct order variables, while here - Regenerate patches with makepatch - Bump PORTREVISION PR: 231524 Submitted by: Nathan <ndowens _at_ yahoo.com>
Diffstat (limited to 'multimedia/smpeg')
-rw-r--r--multimedia/smpeg/Makefile17
-rw-r--r--multimedia/smpeg/files/patch-MPEGaudio.h6
-rw-r--r--multimedia/smpeg/files/patch-configure34
-rw-r--r--multimedia/smpeg/files/patch-gtv.c10
-rw-r--r--multimedia/smpeg/files/patch-smpeg.m46
-rw-r--r--multimedia/smpeg/files/patch-video__video.h6
6 files changed, 52 insertions, 27 deletions
diff --git a/multimedia/smpeg/Makefile b/multimedia/smpeg/Makefile
index f6097fa530db..f2656c853ba5 100644
--- a/multimedia/smpeg/Makefile
+++ b/multimedia/smpeg/Makefile
@@ -3,7 +3,7 @@
PORTNAME= smpeg
PORTVERSION= 0.4.4
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= multimedia
MASTER_SITES= ftp://sunsite.auc.dk/pub/os/linux/loki/open-source/smpeg/ \
GENTOO
@@ -14,23 +14,22 @@ COMMENT= Free MPEG1 video player library with sound support
LICENSE= LGPL20
LICENSE_FILE= ${WRKSRC}/COPYING
-GNU_CONFIGURE= yes
-USES= compiler:features gmake libtool
+USES= gmake libtool:build
USE_SDL= sdl
USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
CONFIGURE_ENV= GLBASE="${LOCALBASE}" \
CC="${CXX}" REAL_CC="${CC}" \
SDL_CONFIG="${SDL_CONFIG}"
-CPPFLAGS+= -I${LOCALBASE}/include
-CFLAGS+= ${COMPILER_FEATURES:Mc++11:C/.+/-Wno-error=narrowing/}
-
#If you want to try the opengl/gtk player (which doesn't seem to work)
#comment out the following line.
CONFIGURE_ARGS= --disable-opengl-player \
--disable-gtk-player \
--enable-mmx
-
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsmpeg.so
+CFLAGS+= -Wno-error-narrowing
+LDFLAGS_i386= -Wl,-znotext
+MAKE_ARGS= LIBTOOL=${LOCALBASE}/bin/libtool
+INSTALL_TARGET= install-strip
.include <bsd.port.mk>
diff --git a/multimedia/smpeg/files/patch-MPEGaudio.h b/multimedia/smpeg/files/patch-MPEGaudio.h
index b7a9d86f9c06..23bbafbfd020 100644
--- a/multimedia/smpeg/files/patch-MPEGaudio.h
+++ b/multimedia/smpeg/files/patch-MPEGaudio.h
@@ -1,6 +1,6 @@
---- MPEGaudio.h Tue Mar 20 13:40:18 2007
-+++ MPEGaudio.h Tue Mar 20 13:43:04 2007
-@@ -148,6 +148,13 @@
+--- MPEGaudio.h.orig 2001-04-04 20:42:40 UTC
++++ MPEGaudio.h
+@@ -148,6 +148,13 @@ class Mpegbitwindow (private)
char buffer[2*WINDOWSIZE];
};
diff --git a/multimedia/smpeg/files/patch-configure b/multimedia/smpeg/files/patch-configure
index 546f396c6de4..c698a2f816b0 100644
--- a/multimedia/smpeg/files/patch-configure
+++ b/multimedia/smpeg/files/patch-configure
@@ -1,6 +1,14 @@
---- configure 2002/07/02 12:33:37 1.1
-+++ configure 2002/07/02 12:34:01
-@@ -1055,7 +1055,7 @@
+--- configure.orig 2001-04-24 19:25:46 UTC
++++ configure
+@@ -58,7 +58,6 @@ ac_help="$ac_help
+ # The variables have the same names as the options, with
+ # dashes changed to underlines.
+ build=NONE
+-cache_file=./config.cache
+ exec_prefix=NONE
+ host=NONE
+ no_create=
+@@ -1055,7 +1054,7 @@ cat > conftest.$ac_ext << EOF
#line 1056 "configure"
#include "confdefs.h"
@@ -9,7 +17,25 @@
EOF
if { (eval echo configure:1061: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
ac_cv_prog_cc_works=yes
-@@ -2335,6 +2335,7 @@
+@@ -1850,7 +1849,7 @@ esac
+
+
+ # Save cache, so that ltconfig can load it
+-cat > confcache <<\EOF
++<<\EOF
+ # This file is a shell script that caches the results of configure
+ # tests run on this system so they can be shared between configure
+ # scripts and configure runs. It is not useful on other systems.
+@@ -1903,8 +1902,6 @@ CC="$CC" CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" \
+ LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
+ LN_S="$LN_S" NM="$NM" RANLIB="$RANLIB" \
+ DLLTOOL="$DLLTOOL" AS="$AS" OBJDUMP="$OBJDUMP" \
+-${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
+-$libtool_flags --no-verify $ac_aux_dir/ltmain.sh $lt_target \
+ || { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
+
+ # Reload cache, that may have been modified by ltconfig
+@@ -2335,6 +2332,7 @@ rm -f conftest*
CFLAGS="$CFLAGS $SDL_CFLAGS"
LIBS="$LIBS $SDL_LIBS"
diff --git a/multimedia/smpeg/files/patch-gtv.c b/multimedia/smpeg/files/patch-gtv.c
index dbdb5b55ab1f..c206bc8efb60 100644
--- a/multimedia/smpeg/files/patch-gtv.c
+++ b/multimedia/smpeg/files/patch-gtv.c
@@ -1,10 +1,10 @@
---- gtv.c.orig Sun Mar 26 00:18:54 2000
-+++ gtv.c Sun Mar 26 00:19:17 2000
-@@ -726,6 +726,7 @@
- memset( &info, 0, sizeof( info ) );
+--- gtv.c.orig 2001-04-16 19:08:54 UTC
++++ gtv.c
+@@ -963,6 +963,7 @@ int main( int argc, char* argv[] )
memset( &filename_buffer, 0, sizeof( gchar ) * FILENAME_BUFFER_SIZE );
+ gtk_set_locale();
gtk_init( &argc, &argv );
+ gtk_set_locale ();
window = create_gtv_window( );
- gtk_signal_connect( GTK_OBJECT( window ), "destroy",
+ gtk_drag_dest_set(window, GTK_DEST_DEFAULT_ALL, drop_types, 1, GDK_ACTION_COPY);
diff --git a/multimedia/smpeg/files/patch-smpeg.m4 b/multimedia/smpeg/files/patch-smpeg.m4
index c652e6be110e..09d856103853 100644
--- a/multimedia/smpeg/files/patch-smpeg.m4
+++ b/multimedia/smpeg/files/patch-smpeg.m4
@@ -1,6 +1,6 @@
---- smpeg.m4.orig 2001-04-05 00:28:14.000000000 +0400
-+++ smpeg.m4 2014-02-14 18:19:27.566113006 +0400
-@@ -10,7 +10,7 @@
+--- smpeg.m4.orig 2001-04-04 20:28:14 UTC
++++ smpeg.m4
+@@ -10,7 +10,7 @@ dnl AM_PATH_SMPEG([MINIMUM-VERSION, [ACTION-IF-FOUND [
ACTION-IF-NOT-FOUND]]])
dnl Test for SMPEG, and define SMPEG_CFLAGS and SMPEG_LIBS
dnl
diff --git a/multimedia/smpeg/files/patch-video__video.h b/multimedia/smpeg/files/patch-video__video.h
index da1cd1b8485f..707909bfc764 100644
--- a/multimedia/smpeg/files/patch-video__video.h
+++ b/multimedia/smpeg/files/patch-video__video.h
@@ -1,6 +1,6 @@
---- video/video.h.orig Sun Feb 8 23:39:25 2004
-+++ video/video.h Sun Feb 8 23:39:36 2004
-@@ -432,7 +432,7 @@
+--- video/video.h.orig 2001-02-10 07:36:42 UTC
++++ video/video.h
+@@ -432,7 +432,7 @@ extern unsigned int cacheMiss[8][8];
#undef LITTLE_ENDIAN_ARCHITECTURE
#define BIG_ENDIAN_ARCHITECTURE 1
#else