summaryrefslogtreecommitdiff
path: root/multimedia/openshot
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2021-10-24 20:51:36 +0200
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2022-01-27 07:12:26 +0100
commit4f0a5e1540c391610950d6ae9ce64ba0dd218d72 (patch)
treee0e3a0327237691d3fe5df542835ced376d3bfae /multimedia/openshot
parentcc7a787d5f043014dcea80bd0058dd7117a5e308 (diff)
downloadfreebsd-ports-4f0a5e1540c391610950d6ae9ce64ba0dd218d72.zip
PyQt: Update sip to 6.5.0, reintroduce sip4 and simplify PyQt framework.
SIP: As mentioned in the update from sip to sip5, this is a transitional version to remove what is deprecated in sip4. Sip6 completely removes the deprecated parts. Unfortunately, some ports — mostly cura things — can not use sip6, so we reintroduce sip4. PyQt: At the same time, we took the opportunity to simplify PyQT and propose only one package as for devel/pyside2. */py-qt5-* have been merged — excepted chart, networkauth and webengine — into devel/py-qt5-pyqt. This allows us to be in adequacy with the packages that the author of these libraries proposes, namely: PyQt - devel/py-qt5-pyqt PyQt-Charts - x11-toolkits/py-qt5-chart PyQt-NetworkAuth – net/py-qt5-networkauth PyQt-WebEngine – www/py-qt5-webengine SIP – devel/py-sip py-sip - devel/py-qt5-sip PyQt-builder - devel/py-qtbuilder Qscintilla - devel/py-qt5-qscintilla2 Reviewed by: diizzy, kde Tested by: kai, rhurlin, arrowd, madpilot Approved by: makc, tcberner, kde Differential Revision: https://reviews.freebsd.org/D33237 Exp-run by: antoine
Diffstat (limited to 'multimedia/openshot')
-rw-r--r--multimedia/openshot/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/multimedia/openshot/Makefile b/multimedia/openshot/Makefile
index 1a4426595d15..57cc45e6bff7 100644
--- a/multimedia/openshot/Makefile
+++ b/multimedia/openshot/Makefile
@@ -22,7 +22,7 @@ USES= desktop-file-utils pyqt:5 python:3.5+ shared-mime-info shebangfix
USE_GITHUB= yes
GH_ACCOUNT= OpenShot
GH_PROJECT= ${PORTNAME}-qt
-USE_PYQT= core gui svg webkitwidgets widgets
+USE_PYQT= pyqt5
USE_PYTHON= distutils optsuffix
SHEBANG_FILES= src/language/generate_translations.py\
src/language/show_translations.py\