summaryrefslogtreecommitdiff
path: root/multimedia/librespot
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2020-11-01 11:09:56 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2020-11-01 11:09:56 +0000
commite207f441c2f815aeddc0a1c44691145459c83e9b (patch)
tree5c8cfbccc2a157d83c47e51ca4e6b6d6dc9e1f5d /multimedia/librespot
parent228ee3956d5eae57d62162d326d9cdad85d30706 (diff)
downloadfreebsd-ports-e207f441c2f815aeddc0a1c44691145459c83e9b.zip
Be more precise in the description for the ALSA option. The option enables rodio
support which is an audio playback library written in rust. The library itself uses ALSA but throughout the documentation the backend is referred to as rodio. While here switch the default audio backend from rodio (ALSA) to portaudio, a more BSD-native library.
Diffstat (limited to 'multimedia/librespot')
-rw-r--r--multimedia/librespot/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/multimedia/librespot/Makefile b/multimedia/librespot/Makefile
index bcef11bdcd4e..d201f2390f6b 100644
--- a/multimedia/librespot/Makefile
+++ b/multimedia/librespot/Makefile
@@ -3,6 +3,7 @@
PORTNAME= librespot
PORTVERSION= 0.1.3
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= multimedia
MAINTAINER= ehaupt@FreeBSD.org
@@ -16,12 +17,15 @@ USES= cargo
USE_GITHUB= yes
GH_ACCOUNT= librespot-org
+CARGO_FEATURES= --no-default-features
+
PLIST_FILES= bin/librespot
OPTIONS_DEFINE= TREMOR VORBIS
-OPTIONS_DEFAULT= ALSA TREMOR VORBIS
+OPTIONS_DEFAULT= PORTAUDIO TREMOR VORBIS
OPTIONS_MULTI= BACKEND
OPTIONS_MULTI_BACKEND= ALSA GSTREAMER JACK PORTAUDIO PULSEAUDIO SDL
+ALSA_DESC= Rodio audio backend using ALSA
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
ALSA_VARS= CARGO_FEATURES+=rodio-backend