summaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-08-17 10:13:26 +0200
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-08-22 15:59:34 +0200
commitb04e09d545577dc6dcdda32017e89613a24c946c (patch)
tree248c68b9adeb9cc540df0653eb059ff0c8599503 /misc
parent065f5a90b4f99e71d8e8b8e2ebdda0e8b1f329fe (diff)
downloadfreebsd-ports-b04e09d545577dc6dcdda32017e89613a24c946c.zip
misc/libpri: update to 1.6.1
ChangeLog: https://www.asterisk.org/asterisk-news/libpri-1-6-1-now-available/ * .github: Add Releaser workflow * Link README to README.md * Makefile: Fix modern compiler errors. * Makefile: Add the ability to build libpri on MacOS for Linux target. * q931.c: Fix subaddress finding octet 4. Reported by: portscout
Diffstat (limited to 'misc')
-rw-r--r--misc/libpri/Makefile2
-rw-r--r--misc/libpri/distinfo6
-rw-r--r--misc/libpri/files/patch-Makefile24
3 files changed, 16 insertions, 16 deletions
diff --git a/misc/libpri/Makefile b/misc/libpri/Makefile
index c94a106b983c..616431910691 100644
--- a/misc/libpri/Makefile
+++ b/misc/libpri/Makefile
@@ -1,5 +1,5 @@
PORTNAME= libpri
-PORTVERSION= 1.6.0
+PORTVERSION= 1.6.1
CATEGORIES= misc
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/libpri/releases/
diff --git a/misc/libpri/distinfo b/misc/libpri/distinfo
index 689c1c293639..c9b0615bc6e1 100644
--- a/misc/libpri/distinfo
+++ b/misc/libpri/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1544570232
-SHA256 (libpri-1.6.0.tar.gz) = 7225ea7ec334a115f9dc08e71f55589c38cb4e00b13964cd2f08cc4e6123e3f6
-SIZE (libpri-1.6.0.tar.gz) = 340578
+TIMESTAMP = 1692260005
+SHA256 (libpri-1.6.1.tar.gz) = d4d1a62766695455f1b616f5f7603458e6d23df787ebabc31ffda1c6298d0509
+SIZE (libpri-1.6.1.tar.gz) = 334119
diff --git a/misc/libpri/files/patch-Makefile b/misc/libpri/files/patch-Makefile
index d68dccf3a0cc..032dc86ae072 100644
--- a/misc/libpri/files/patch-Makefile
+++ b/misc/libpri/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2017-01-27 23:25:12.000000000 +0700
-+++ Makefile 2018-12-12 06:20:14.634544000 +0700
+--- Makefile.orig 2023-08-16 15:52:02 UTC
++++ Makefile
@@ -24,7 +24,7 @@
# Uncomment if you want libpri not send PROGRESS_INDICATOR w/ALERTING
#ALERTING=-DALERTING_NO_PROGRESS
@@ -8,8 +8,8 @@
+CC?=gcc
GREP=grep
AWK=awk
-
-@@ -34,7 +34,7 @@
+ AR=ar
+@@ -36,7 +36,7 @@ PROC?=$(shell uname -m)
# SONAME version; should be changed on every ABI change
# please don't change it needlessly; it's perfectly fine to have a SONAME
# of 1.2 and a version of 1.4.x
@@ -18,12 +18,12 @@
STATIC_LIBRARY=libpri.a
DYNAMIC_LIBRARY:=libpri.so.$(SONAME)
-@@ -68,10 +68,10 @@
+@@ -70,10 +70,10 @@ DYNAMIC_OBJS= \
$(STATIC_OBJS)
CFLAGS ?= -g
CFLAGS += $(CPPFLAGS)
--CFLAGS += -Wall -Werror -Wstrict-prototypes -Wmissing-prototypes
-+CFLAGS += -Wall -Wstrict-prototypes -Wmissing-prototypes
+-CFLAGS += -Wall -Werror -Wstrict-prototypes -Wmissing-prototypes -Wno-zero-length-bounds -Wno-stringop-overflow
++CFLAGS += -Wall -Wstrict-prototypes -Wmissing-prototypes -Wno-zero-length-bounds -Wno-stringop-overflow
CFLAGS += -fPIC $(ALERTING) $(LIBPRI_OPT) $(COVERAGE_CFLAGS)
-INSTALL_PREFIX=$(DESTDIR)
-INSTALL_BASE=/usr
@@ -32,7 +32,7 @@
libdir?=$(INSTALL_BASE)/lib
ifneq ($(findstring Darwin,$(OSARCH)),)
SOFLAGS=$(LDFLAGS) -dynamic -bundle -Xlinker -macosx_version_min -Xlinker 10.4 -Xlinker -undefined -Xlinker dynamic_lookup -force_flat_namespace
-@@ -89,7 +89,7 @@
+@@ -91,7 +91,7 @@ else
ifeq (${OSARCH},FreeBSD)
LDCONFIG_FLAGS=-m
CFLAGS += -I../zaptel -I../zapata
@@ -41,7 +41,7 @@
endif
endif
ifeq (${OSARCH},SunOS)
-@@ -149,12 +149,12 @@
+@@ -151,12 +151,12 @@ install: $(STATIC_LIBRARY) $(DYNAMIC_LIBRARY)
mkdir -p $(INSTALL_PREFIX)$(libdir)
mkdir -p $(INSTALL_PREFIX)$(INSTALL_BASE)/include
ifneq (${OSARCH},SunOS)
@@ -58,7 +58,7 @@
else
install -f $(INSTALL_PREFIX)$(INSTALL_BASE)/include -m 644 libpri.h
install -f $(INSTALL_PREFIX)$(libdir) -m 755 $(DYNAMIC_LIBRARY)
-@@ -190,7 +190,7 @@
+@@ -192,7 +192,7 @@ MAKE_DEPS= -MD -MT $@ -MF .$(subst /,_,$@).d -MP
$(CC) $(CFLAGS) $(MAKE_DEPS) -c -o $@ $<
%.lo: %.c
@@ -66,8 +66,8 @@
+ $(CC) $(CFLAGS) $(MAKE_DEPS) -fPIC -c -o $@ $<
$(STATIC_LIBRARY): $(STATIC_OBJS)
- ar rcs $(STATIC_LIBRARY) $(STATIC_OBJS)
-@@ -198,7 +198,7 @@
+ $(AR) rcs $(STATIC_LIBRARY) $(STATIC_OBJS)
+@@ -200,7 +200,7 @@ $(STATIC_LIBRARY): $(STATIC_OBJS)
$(DYNAMIC_LIBRARY): $(DYNAMIC_OBJS)
$(CC) $(SOFLAGS) -o $@ $(DYNAMIC_OBJS)