summaryrefslogtreecommitdiff
path: root/misc/py-onnx-tf
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-05-23 21:41:41 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-05-23 21:41:41 +0000
commita640075728307b18dbbcd5e2600731a60d0b81e4 (patch)
treeae968fef6d0d141475c3e665154574fa62d2edc3 /misc/py-onnx-tf
parent8609f172597c509e789c5f22cc7de4d5c1f44f71 (diff)
downloadfreebsd-ports-a640075728307b18dbbcd5e2600731a60d0b81e4.zip
Fix index
Diffstat (limited to 'misc/py-onnx-tf')
-rw-r--r--misc/py-onnx-tf/Makefile23
-rw-r--r--misc/py-onnx-tf/distinfo3
-rw-r--r--misc/py-onnx-tf/pkg-descr4
3 files changed, 30 insertions, 0 deletions
diff --git a/misc/py-onnx-tf/Makefile b/misc/py-onnx-tf/Makefile
new file mode 100644
index 000000000000..4a54def3fcbf
--- /dev/null
+++ b/misc/py-onnx-tf/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= onnx-tf
+DISTVERSION= 1.3.0
+CATEGORIES= misc python # machine-learning
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Tensorflow backend for ONNX (Open Neural Network Exchange)
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}onnx>0:misc/py-onnx@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils concurrent autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/misc/py-onnx-tf/distinfo b/misc/py-onnx-tf/distinfo
new file mode 100644
index 000000000000..54323813fa9c
--- /dev/null
+++ b/misc/py-onnx-tf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1572021506
+SHA256 (onnx-tf-1.3.0.tar.gz) = f4641053780c196406afcc2a319fa0ac3cab3741180bbc0a8f7a61f884f6d695
+SIZE (onnx-tf-1.3.0.tar.gz) = 57987
diff --git a/misc/py-onnx-tf/pkg-descr b/misc/py-onnx-tf/pkg-descr
new file mode 100644
index 000000000000..e4074cdfb4f9
--- /dev/null
+++ b/misc/py-onnx-tf/pkg-descr
@@ -0,0 +1,4 @@
+TensorFlow Backend and Frontend for ONNX allowing ONNX to inter-operate with
+TensofFlow.
+
+WWW: https://github.com/onnx/onnx-tensorflow/