summaryrefslogtreecommitdiff
path: root/misc/man.el
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1999-02-03 11:12:01 +0000
committerSatoshi Asami <asami@FreeBSD.org>1999-02-03 11:12:01 +0000
commit5114e2637e2224ea9b0e0ea4b315bc38370ccf04 (patch)
tree414dd9b31f0192eb7d0054b2463c2eed8afd25b4 /misc/man.el
parentfd5131ad95770d2ae6bee7059204950dfa6402d1 (diff)
downloadfreebsd-ports-5114e2637e2224ea9b0e0ea4b315bc38370ccf04.zip
Adjust port Makefiles to new EXTRACT_* variable defaults. See log of
bsd.port.mk rev. 1.304 for details on the change. The fix here is one of the following. (1) Define USE_BZIP2 instead of BUILD_DEPENDS on bzip2 and redefining EXTRACT_* commands. (2) Change ${EXTRACT_CMD} to ${TAR} when the command is obviously calling the "tar" command (i.e., arguments like "-xzf" are spelled out). (3) If ${EXTRACT_CMD} is called directly with ${EXTRACT_BEFORE_ARGS}, add ${EXTRACT_AFTER_ARGS} to the command line as well. (4) If any of EXTRACT_CMD, EXTRACT_BEFORE_ARGS or EXTRACT_AFTER_ARGS is set, define the other two too.
Diffstat (limited to 'misc/man.el')
-rw-r--r--misc/man.el/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/misc/man.el/Makefile b/misc/man.el/Makefile
index c85ec10ae6e6..5f3ef8f8ac2c 100644
--- a/misc/man.el/Makefile
+++ b/misc/man.el/Makefile
@@ -3,7 +3,7 @@
# Date created: 10 September 1998
# Whom: KIRIYAMA Kazuhiko <kiri@kiri.toba-cmt.ac.jp>
#
-# $Id: Makefile,v 1.2 1998/12/02 05:54:52 asami Exp $
+# $Id: Makefile,v 1.3 1998/12/16 11:33:28 flathill Exp $
#
DISTNAME= i18n-man-1.1
@@ -23,6 +23,6 @@ ELISPDIR= ${PREFIX}/share/emacs/site-lisp
do-install:
@${MKDIR} ${ELISPDIR}
@cd ${WRKSRC}; \
- ${INSTALL_DATA} `${EXTRACT_CMD} tzf ${DISTDIR}/${DISTFILES}` ${ELISPDIR}
+ ${INSTALL_DATA} `${TAR} tzf ${DISTDIR}/${DISTFILES}` ${ELISPDIR}
.include <bsd.port.mk>