summaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2016-01-13 01:19:33 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2016-01-13 01:19:33 +0000
commitd0e31d59aa16b6cae61fe3ce7b392bd1624761b9 (patch)
tree60efdac3fabfa114e1b1c835e16f40b0a275d8e8 /math
parent848139fcb9426fce91540da81f031ed2994f9a42 (diff)
downloadfreebsd-ports-d0e31d59aa16b6cae61fe3ce7b392bd1624761b9.zip
- Update to 1.4. The only change is to call octave-cli instead of octave.
Diffstat (limited to 'math')
-rw-r--r--math/octave-forge-base/Makefile2
-rw-r--r--math/octave-forge-base/files/load-octave-pkg.in8
2 files changed, 5 insertions, 5 deletions
diff --git a/math/octave-forge-base/Makefile b/math/octave-forge-base/Makefile
index 36d1062133ed..ac7f34403a61 100644
--- a/math/octave-forge-base/Makefile
+++ b/math/octave-forge-base/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= octave-forge-base
-PORTVERSION= 1.3
+PORTVERSION= 1.4
CATEGORIES= math
MASTER_SITES= #none
DISTFILES= #none
diff --git a/math/octave-forge-base/files/load-octave-pkg.in b/math/octave-forge-base/files/load-octave-pkg.in
index 3c305c6d723f..5da1b478262f 100644
--- a/math/octave-forge-base/files/load-octave-pkg.in
+++ b/math/octave-forge-base/files/load-octave-pkg.in
@@ -17,7 +17,7 @@ use File::Remove qw(remove);
# Interrogate octave to see where it stores its packages.
-open(OCTAVE,"octave -H -q --no-site-file --eval \"pkg('prefix');pkg('global_list')\" |") || die;
+open(OCTAVE,"octave-cli -H -q --no-site-file --eval \"pkg('prefix');pkg('global_list')\" |") || die;
my $install_prefix = <OCTAVE> || die;
chomp $install_prefix;
$install_prefix =~ s/.*\s+//;
@@ -76,7 +76,7 @@ while (my $p = <$install_prefix/*>) {
# out everything.
my %check_installed;
-open(OCTAVE,"octave -H -q --no-site-file --eval \"pkg('list')\" |") || die;
+open(OCTAVE,"octave-cli -H -q --no-site-file --eval \"pkg('list')\" |") || die;
<OCTAVE>;
my $out = join "",<OCTAVE>;
while ($out =~ s/^\s*(\S+)\s*\|\s*(\S+).*$//m) {
@@ -158,7 +158,7 @@ if ($nr_to_remove>0) {
foreach my $p (@ordered_list_to_remove) {
print "load-octave-pkg: octave is uninstalling $p.\n";
$p =~ s/\-[\d\.]+\.tar\.gz//;
- system "octave -H -q --no-site-file --eval \"pkg('uninstall','$p')\" > /dev/null";
+ system "octave-cli -H -q --no-site-file --eval \"pkg('uninstall','$p')\" > /dev/null";
}
}
@@ -238,7 +238,7 @@ make_ordered_list_to_install(join("|",sort keys %to_install));
foreach my $p (@ordered_list_to_install) {
print "load-octave-pkg: octave is installing $p.\n";
- system "octave -H -q --no-site-file --eval \"pkg('install','$tardir/$p')\" > /dev/null\n";
+ system "octave-cli -H -q --no-site-file --eval \"pkg('install','$tardir/$p')\" > /dev/null\n";
}
# Remove directories that may have been left behind by the octave packaging