summaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2016-01-13 01:53:49 +0000
committerMaho Nakata <maho@FreeBSD.org>2016-01-13 01:53:49 +0000
commita2415bfdec45804a2e1618e23a6f6f4ad05c07e9 (patch)
tree8b871bde7f65cf504c6163a9537e96fee07e2a30 /math
parent03da2131d6adf58e2545b64f7db9456ce593f47f (diff)
downloadfreebsd-ports-a2415bfdec45804a2e1618e23a6f6f4ad05c07e9.zip
Forgot to add patches, and bump port revision
PR: 201737 Submitted by: you.akira.noda@gmail.com Also spotted by: stephen@
Diffstat (limited to 'math')
-rw-r--r--math/octave/Makefile2
-rw-r--r--math/octave/files/patch-libinterp-octave-value-ov-classdef.cc14
-rw-r--r--math/octave/files/patch-libinterp-octave-value-ov-classdef.h11
3 files changed, 26 insertions, 1 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index f559d679f292..ece66f8f7c54 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -3,6 +3,7 @@
PORTNAME= octave
PORTVERSION= 4.0.0
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= GNU
@@ -38,7 +39,6 @@ USES= charsetfix fortran gmake libtool perl5 pkgconfig tar:xz
USE_LDCONFIG= yes
USE_PERL5= build
USE_TEX= dvipsk:build
-USE_GCC= yes
GNU_CONFIGURE= yes
USE_JAVA= yes
JAVA_VERSION= 1.7+
diff --git a/math/octave/files/patch-libinterp-octave-value-ov-classdef.cc b/math/octave/files/patch-libinterp-octave-value-ov-classdef.cc
new file mode 100644
index 000000000000..5280dad9cd8c
--- /dev/null
+++ b/math/octave/files/patch-libinterp-octave-value-ov-classdef.cc
@@ -0,0 +1,14 @@
+--- libinterp/octave-value/ov-classdef.cc.orig 2015-07-21 17:05:21.000000000 +0900
++++ libinterp/octave-value/ov-classdef.cc 2015-07-21 17:05:32.000000000 +0900
+@@ -1937,6 +1937,11 @@
+ return true;
+ }
+
++void cdef_object_scalar::mark_as_constructed (const cdef_class& cls)
++{
++ ctor_list.erase (cls);
++}
++
+ handle_cdef_object::~handle_cdef_object (void)
+ {
+ #if DEBUG_TRACE
diff --git a/math/octave/files/patch-libinterp-octave-value-ov-classdef.h b/math/octave/files/patch-libinterp-octave-value-ov-classdef.h
new file mode 100644
index 000000000000..d7c413868baa
--- /dev/null
+++ b/math/octave/files/patch-libinterp-octave-value-ov-classdef.h
@@ -0,0 +1,11 @@
+--- libinterp/octave-value/ov-classdef.h.orig 2015-07-21 17:04:55.000000000 +0900
++++ libinterp/octave-value/ov-classdef.h 2015-07-21 17:05:32.000000000 +0900
+@@ -438,7 +438,7 @@
+
+ void mark_as_constructed (void) { ctor_list.clear (); }
+
+- void mark_as_constructed (const cdef_class& cls) { ctor_list.erase (cls); }
++ void mark_as_constructed (const cdef_class& cls);
+
+ bool is_constructed (void) const { return ctor_list.empty (); }
+