summaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2007-04-26 14:56:31 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2007-04-26 14:56:31 +0000
commit8eb148fbc655d8de3a39d293be14af2c9a9f2f34 (patch)
treee4b09a96aa0f8d7c224078afe171dc490f06b6cb /math
parent313b301050a23196774800af669bdc6e0d54ea5d (diff)
downloadfreebsd-ports-8eb148fbc655d8de3a39d293be14af2c9a9f2f34.zip
- Update to version 0.8.1
- Use MASTER_SITES_ABBREVS in MASTER_SITES PR: 112136 Submitted by: KATO Tsuguru <tkato432 AT yahoo.com> Approved by: clsung (mentor, implicitly)
Diffstat (limited to 'math')
-rw-r--r--math/fityk/Makefile18
-rw-r--r--math/fityk/distinfo6
-rw-r--r--math/fityk/files/patch-configure110
3 files changed, 15 insertions, 119 deletions
diff --git a/math/fityk/Makefile b/math/fityk/Makefile
index 534e12acbf72..fec4c1de4a47 100644
--- a/math/fityk/Makefile
+++ b/math/fityk/Makefile
@@ -7,10 +7,9 @@
#
PORTNAME= fityk
-PORTVERSION= 0.7.8
+PORTVERSION= 0.8.1
CATEGORIES= math
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Free peak fitting software
@@ -24,15 +23,21 @@ USE_GNOME= gnometarget gtk20
USE_WX= 2.6
WX_CONF_ARGS= absolute
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
+USE_LDCONFIG= yes
MAN1= fityk.1
PLIST_FILES= bin/cfityk \
bin/fityk \
- %%DATADIR%%/fityk_tips.txt \
- %%DATADIR%%/fitykhelp.htb
+ include/fityk.h \
+ lib/libfityk.a \
+ lib/libfityk.la \
+ lib/libfityk.so \
+ lib/libfityk.so.0 \
+ %%DATADIR%%/fitykhelp.htb \
+ %%DATADIR%%/tips.txt
PLIST_DIRS= %%DATADIR%%
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
@@ -42,5 +47,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|^CPPFLAGS=|#CPPFLAGS=|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|config 3rdparty|config|g ; \
s|^install-data-am:|install-data-am:#|g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|fityk_tips|tips|g' ${WRKSRC}/src/wxgui/gui.cpp
.include <bsd.port.mk>
diff --git a/math/fityk/distinfo b/math/fityk/distinfo
index 7244f18ae89a..d524c6b3bda6 100644
--- a/math/fityk/distinfo
+++ b/math/fityk/distinfo
@@ -1,3 +1,3 @@
-MD5 (fityk-0.7.8.tar.bz2) = 830ed8668ab524c7b1697ec3a2ed5554
-SHA256 (fityk-0.7.8.tar.bz2) = 57443b3c93d0dad5498ed07b65e87dd977b9aafd299f571d498df94e8c4d3207
-SIZE (fityk-0.7.8.tar.bz2) = 1102741
+MD5 (fityk-0.8.1.tar.bz2) = f93d2ce9b9c21e0d79d69f1adb797a66
+SHA256 (fityk-0.8.1.tar.bz2) = f0135432d93711255180c2d36b628642cb4f37b3f3e93dec6828c50797a6551c
+SIZE (fityk-0.8.1.tar.bz2) = 1294006
diff --git a/math/fityk/files/patch-configure b/math/fityk/files/patch-configure
deleted file mode 100644
index fd071117313a..000000000000
--- a/math/fityk/files/patch-configure
+++ /dev/null
@@ -1,110 +0,0 @@
---- configure.orig Tue Feb 6 22:44:47 2007
-+++ configure Tue Mar 6 02:41:21 2007
-@@ -6341,107 +6341,6 @@
- READLINE_LIBS="$with_readline $gp_tcap"
- fi
- fi
-- { echo "$as_me:$LINENO: checking whether rl_completion_matches is declared" >&5
--echo $ECHO_N "checking whether rl_completion_matches is declared... $ECHO_C" >&6; }
--if test "${ac_cv_have_decl_rl_completion_matches+set}" = set; then
-- echo $ECHO_N "(cached) $ECHO_C" >&6
--else
-- cat >conftest.$ac_ext <<_ACEOF
--/* confdefs.h. */
--_ACEOF
--cat confdefs.h >>conftest.$ac_ext
--cat >>conftest.$ac_ext <<_ACEOF
--/* end confdefs.h. */
--#include <readline/readline.h>
--
--int
--main ()
--{
--#ifndef rl_completion_matches
-- char *p = (char *) rl_completion_matches;
-- return !p;
--#endif
--
-- ;
-- return 0;
--}
--_ACEOF
--rm -f conftest.$ac_objext
--if { (ac_try="$ac_compile"
--case "(($ac_try" in
-- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
-- *) ac_try_echo=$ac_try;;
--esac
--eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
-- (eval "$ac_compile") 2>conftest.er1
-- ac_status=$?
-- grep -v '^ *+' conftest.er1 >conftest.err
-- rm -f conftest.er1
-- cat conftest.err >&5
-- echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); } &&
-- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
-- { (case "(($ac_try" in
-- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
-- *) ac_try_echo=$ac_try;;
--esac
--eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
-- (eval "$ac_try") 2>&5
-- ac_status=$?
-- echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); }; } &&
-- { ac_try='test -s conftest.$ac_objext'
-- { (case "(($ac_try" in
-- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
-- *) ac_try_echo=$ac_try;;
--esac
--eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
-- (eval "$ac_try") 2>&5
-- ac_status=$?
-- echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); }; }; then
-- ac_cv_have_decl_rl_completion_matches=yes
--else
-- echo "$as_me: failed program was:" >&5
--sed 's/^/| /' conftest.$ac_ext >&5
--
-- ac_cv_have_decl_rl_completion_matches=no
--fi
--
--rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
--fi
--{ echo "$as_me:$LINENO: result: $ac_cv_have_decl_rl_completion_matches" >&5
--echo "${ECHO_T}$ac_cv_have_decl_rl_completion_matches" >&6; }
--if test $ac_cv_have_decl_rl_completion_matches = yes; then
--
--cat >>confdefs.h <<_ACEOF
--#define HAVE_DECL_RL_COMPLETION_MATCHES 1
--_ACEOF
--
--
--else
-- cat >>confdefs.h <<_ACEOF
--#define HAVE_DECL_RL_COMPLETION_MATCHES 0
--_ACEOF
--
--{ { echo "$as_me:$LINENO: error:
-- Although you seem to have a readline-compatible library,
-- it is either old GNU readline <= 4.1 (XX century),
-- or readline-compatible library, like libedit, but it's not compatible
-- enough with readline >= 4.2.
-- Either install libreadline >= 4.2,
-- or configure fityk with option --without-readline" >&5
--echo "$as_me: error:
-- Although you seem to have a readline-compatible library,
-- it is either old GNU readline <= 4.1 (XX century),
-- or readline-compatible library, like libedit, but it's not compatible
-- enough with readline >= 4.2.
-- Either install libreadline >= 4.2,
-- or configure fityk with option --without-readline" >&2;}
-- { (exit 1); exit 1; }; }
--fi
--
--
- else
-
- cat >>confdefs.h <<\_ACEOF