summaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2016-01-13 03:24:32 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2016-01-13 03:24:32 +0000
commit3da75467c686058c5ee66b5447231fc1b7720bdf (patch)
tree720bc4a638896347a42be8693e44c4bb517d16ac /math
parentd5b256c4ddb5405c5a288fdf51299812d7b6a722 (diff)
downloadfreebsd-ports-3da75467c686058c5ee66b5447231fc1b7720bdf.zip
- New port math/octave-forge-sparsersb.
The octave-forge package is the result of The GNU Octave Repositry project, which is intended to be a central location for custom scripts, functions and extensions for GNU Octave. contains the source for all the functions plus build and install scripts. This port uses math/librsb, which is quite difficult to install. Therefore this port will not be installed as part of the math/octave-forge meta-port.
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-sparsersb/Makefile28
-rw-r--r--math/octave-forge-sparsersb/distinfo2
-rw-r--r--math/octave-forge-sparsersb/pkg-descr10
-rw-r--r--math/octave-forge-sparsersb/pkg-plist1
5 files changed, 42 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index d22f87a82fb9..c0de78dce0e1 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -377,6 +377,7 @@
SUBDIR += octave-forge-signal
SUBDIR += octave-forge-simp
SUBDIR += octave-forge-sockets
+ SUBDIR += octave-forge-sparsersb
SUBDIR += octave-forge-specfun
SUBDIR += octave-forge-special-matrix
SUBDIR += octave-forge-spline-gcvspl
diff --git a/math/octave-forge-sparsersb/Makefile b/math/octave-forge-sparsersb/Makefile
new file mode 100644
index 000000000000..fee9b0159eb0
--- /dev/null
+++ b/math/octave-forge-sparsersb/Makefile
@@ -0,0 +1,28 @@
+# Created by: Stephen Montgomery-Smith <stephen@math.missouri.edu>
+# $FreeBSD$
+
+PORTNAME= octave-forge-sparsersb
+PORTVERSION= 1.0.0
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/librsb.a:${PORTSDIR}/math/librsb
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${DISTNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+post-build:
+ ${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.mk>
diff --git a/math/octave-forge-sparsersb/distinfo b/math/octave-forge-sparsersb/distinfo
new file mode 100644
index 000000000000..d0203531c607
--- /dev/null
+++ b/math/octave-forge-sparsersb/distinfo
@@ -0,0 +1,2 @@
+SHA256 (octave-forge/sparsersb-1.0.0.tar.gz) = be106ea9f32d7fbc2ffe67b65bb39650cdfaf34b3bb38a373688f205e471d411
+SIZE (octave-forge/sparsersb-1.0.0.tar.gz) = 79786
diff --git a/math/octave-forge-sparsersb/pkg-descr b/math/octave-forge-sparsersb/pkg-descr
new file mode 100644
index 000000000000..a2893dfa91c2
--- /dev/null
+++ b/math/octave-forge-sparsersb/pkg-descr
@@ -0,0 +1,10 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is sparsersb.
+
+ Interface to the librsb package implementing the RSB sparse matrix format.
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge-sparsersb/pkg-plist b/math/octave-forge-sparsersb/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/math/octave-forge-sparsersb/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty