summaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2016-01-16 20:14:03 +0000
committerThomas Zander <riggs@FreeBSD.org>2016-01-16 20:14:03 +0000
commit1820fb01b50293b402077a3f2daa1908c766909c (patch)
tree714f13b38e12c6be9a68ada7f3439d5de99a6805 /math
parent42287e44e1f928c1fae56e5376381d2cb1f75de8 (diff)
downloadfreebsd-ports-1820fb01b50293b402077a3f2daa1908c766909c.zip
Update to upstream version 2.8
PR: 206090 Submitted by: dieterich@ogolem.org (maintainer)
Diffstat (limited to 'math')
-rw-r--r--math/clfft/Makefile5
-rw-r--r--math/clfft/distinfo4
-rw-r--r--math/clfft/files/patch-src_include_sharedLibrary.h17
-rw-r--r--math/clfft/files/patch-src_statTimer_statisticalTimer.h4
-rw-r--r--math/clfft/pkg-plist26
5 files changed, 20 insertions, 36 deletions
diff --git a/math/clfft/Makefile b/math/clfft/Makefile
index 10e8cb53ea9b..44dd90e77cf7 100644
--- a/math/clfft/Makefile
+++ b/math/clfft/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= clfft
-PORTVERSION= 2.6.1
+PORTVERSION= 2.8
DISTVERSIONPREFIX= v
CATEGORIES= math
@@ -17,6 +17,8 @@ LIB_DEPENDS= libOpenCL.so:${PORTSDIR}/devel/ocl-icd
RUN_DEPENDS= opencl>=0:${PORTSDIR}/devel/opencl
BROKEN_FreeBSD_9= clFFT is only supported on FreeBSD 10.1 and newer
+ONLY_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS_REASON_amd64= only builds and is supported on amd64
USE_GITHUB= yes
GH_ACCOUNT= clMathLibraries
@@ -27,6 +29,7 @@ USES= cmake
CMAKE_ARGS+= -DBUILD_CLIENT=OFF \
-DBUILD_TEST=OFF \
+ -DBUILD_CALLBACK_CLIENT=OFF \
-DSUFFIX_LIB=""
CMAKE_SOURCE_PATH= ${WRKSRC}/src
diff --git a/math/clfft/distinfo b/math/clfft/distinfo
index 8dd0ac4889db..e5d91864b930 100644
--- a/math/clfft/distinfo
+++ b/math/clfft/distinfo
@@ -1,2 +1,2 @@
-SHA256 (clMathLibraries-clFFT-v2.6.1_GH0.tar.gz) = 2b5b15b903baeef4dcea6bb8efbe6aba284510148c04d20f9b151a94ae71c050
-SIZE (clMathLibraries-clFFT-v2.6.1_GH0.tar.gz) = 893794
+SHA256 (clMathLibraries-clFFT-v2.8_GH0.tar.gz) = 9964b537f0af121560e64cb5a2513b153511ca85e011f23a332c45cc66f3d60a
+SIZE (clMathLibraries-clFFT-v2.8_GH0.tar.gz) = 967253
diff --git a/math/clfft/files/patch-src_include_sharedLibrary.h b/math/clfft/files/patch-src_include_sharedLibrary.h
deleted file mode 100644
index 22a9956049e0..000000000000
--- a/math/clfft/files/patch-src_include_sharedLibrary.h
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/include/sharedLibrary.h.orig 2015-08-07 18:40:37.855840000 -0400
-+++ src/include/sharedLibrary.h 2015-08-07 18:40:42.675578000 -0400
-@@ -52,6 +52,14 @@
- {
- std::cerr << ::dlerror( ) << std::endl;
- }
-+#elif defined(__FreeBSD__)
-+ tstring freebsdName = unixPrefix;
-+ freebsdName += libraryName += ".so";
-+ void* fileHandle = ::dlopen( freebsdName.c_str( ), RTLD_NOW );
-+ if( !quiet && !fileHandle )
-+ {
-+ std::cerr << ::dlerror( ) << std::endl;
-+ }
- #else
- #error "unsupported platform"
- #endif
diff --git a/math/clfft/files/patch-src_statTimer_statisticalTimer.h b/math/clfft/files/patch-src_statTimer_statisticalTimer.h
index ae92e4dd8b91..4d1224b87a92 100644
--- a/math/clfft/files/patch-src_statTimer_statisticalTimer.h
+++ b/math/clfft/files/patch-src_statTimer_statisticalTimer.h
@@ -1,5 +1,5 @@
---- src/statTimer/statisticalTimer.h.orig 2015-10-11 19:43:16.998055000 +0200
-+++ src/statTimer/statisticalTimer.h 2015-10-11 19:44:10.217558000 +0200
+--- src/statTimer/statisticalTimer.h.orig 2015-10-20 00:29:59 UTC
++++ src/statTimer/statisticalTimer.h
@@ -21,6 +21,7 @@
#include <vector>
#include <functional>
diff --git a/math/clfft/pkg-plist b/math/clfft/pkg-plist
index 6128268f1068..30bf1c00e86b 100644
--- a/math/clfft/pkg-plist
+++ b/math/clfft/pkg-plist
@@ -1,22 +1,20 @@
-bin/examples/fft1d
-bin/examples/fft2d
-bin/examples/fft3d
include/clAmdFft.h
include/clAmdFft.version.h
include/clFFT.h
include/clFFT.version.h
+lib/cmake/clFFT/clFFTConfig.cmake
+lib/cmake/clFFT/clFFTConfigVersion.cmake
+lib/cmake/clFFT/clFFTTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/clFFT/clFFTTargets.cmake
lib/libStatTimer.so
lib/libStatTimer.so.2
-lib/libStatTimer.so.2.6.1
+lib/libStatTimer.so.2.8.0
lib/libclFFT.so
lib/libclFFT.so.2
-lib/libclFFT.so.2.6.1
-share/clFFT/clFFTConfig.cmake
-share/clFFT/clFFTConfigVersion.cmake
-share/clFFT/clFFTTargets-%%CMAKE_BUILD_TYPE%%.cmake
-share/clFFT/clFFTTargets.cmake
-share/clFFT/errorHandler.py
-share/clFFT/fftPerformanceTesting.py
-share/clFFT/measurePerformance.py
-share/clFFT/performanceUtility.py
-share/clFFT/plotPerformance.py
+lib/libclFFT.so.2.8.0
+share/clFFT/examples/fft1d
+share/clFFT/examples/fft1d.c
+share/clFFT/examples/fft2d
+share/clFFT/examples/fft2d.c
+share/clFFT/examples/fft3d
+share/clFFT/examples/fft3d.c